Closed Bug 844641 Opened 7 years ago Closed 7 years ago

CSS text-indent without units doesn't work anymore

Categories

(Core :: CSS Parsing and Computation, defect)

19 Branch
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: freewon, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Opera/9.80 (Windows NT 5.1; U; en) Presto/2.2.15 Version/10.10

Steps to reproduce:

I wanted to intend some text by the CSS-property text-indent.


Actual results:

As you can see in the attached code: Although the text-indent is set in the styles tag, the text 'Test' is not indented by 20. If you change text-indent, nothing happens, so the style text-indent doesn't work at all anymore.

This issue first occured in version 17.0.1 and isn't solved until today.

Works with Firefox 14.0.1, 16.0.1
Problem since 17.0.1
Issue not solved in 19.0


Expected results:

The text should have intended.
Component: Untriaged → Style System (CSS)
Product: Firefox → Core
Attachment #717653 - Attachment mime type: text/plain → text/html
You've got to supply units. A raw number is not valid. See http://www.w3.org/TR/CSS2/text.html#indentation-prop for more details.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
Sorry, but all browser accept this, and until version 16.0.1 also Firefox accepted it, too.

Now you thought that since 17.0.1. you just drop it?

Even worse: Some fields without "px" work in Firefox 19.0, only a few don't!

Either you accept raw values like a few months ago in 16.0.1, or you just don't accept a value without a "px".

That link to www.w3.org still doesn't convince me to use Firefox anymore in the future (by the way the link doesn't work, hahaha).

If you would only do the standarts, you could also drop the supply for Javascript setTimeout or setInterval. You know, what I mean: Browser must support more than the standart. Otherwise user change the browser.

So, I still consider this as a bug.
Version: 17 Branch → 19 Branch
Still a bug in my opinion.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Have you noticed this problem on sites that you use but are not the developer of?
OS: Windows XP → All
Hardware: x86 → All
Summary: CSS text-indent doesn't work anymore → CSS text-indent without units doesn't work anymore
To be honest: No, I don't know another site yet (I'm personally using other Browsers, and Firefox only for tests).

But there are other sites: http://stackoverflow.com/questions/14173821/firefox-17-css-issue-text-indent-ignored

I mean: How many sites are out there which don't work anymore or will show issues? We could only assume a percentage: 10%? 20%? More? I don't know.

But what if somebody just forget the "px" somewhere. Is this a reason to show his site now drawn incorrectly, with wrong text-indent and min-weight/-height?

As I said: If you are consequent, you should eliminate the parsing of any value without a "px". Then you see, how many user will change the Browser, so you will clearly know it, how important it is or not.

And as I said above: "Browser must support more than the standard. Otherwise user change the browser."

Greetings,
Marcus
I haven't seen any feedback from users of sites about those sites being broken, and we've been shipping this on the release channel for quite a few months now.

This is also something we've never supported in standards mode; it's quirks mode only.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.