Closed Bug 844649 Opened 7 years ago Closed 7 years ago

CSS min-width and min-height without units don't work anymore

Categories

(Core :: CSS Parsing and Computation, defect)

19 Branch
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: freewon, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Opera/9.80 (Windows NT 5.1; U; en) Presto/2.2.15 Version/10.10

Steps to reproduce:

I wanted to use the CSS-properties min-width and min-height, as you can see in the attached code.


Actual results:

The CSS-properties min-width and min-height have no effect anymore.

Because the min-width isn't checked anymore by Firefox, it's possible to overlay the 'content' (which is a div using the min-weight) with the 'right_layer' (which is just another div) by narrowing the browser window.

And because the min-height isn't checked anymore by Firefox, a normal div using min-height is shown very improperly (in my code example the div 'content' is only drawn as a bold line instead as a huge layer).

This issues first occured in version 17.0.1 and aren't solved until today.

Works with Firefox 14.0.1, 16.0.1
Problem since 17.0.1
Issue not solved in 19.0


Expected results:

The CSS properties min-width and min-height should have worked.
Comment on attachment 717659 [details]
A small code showing the CSS error of min-width and min-max

><!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
><html>
><head>
><title>Untitled Document</title>
></head>
><body>
><div name="edge" style="border:0;position:fixed;min-width:600;width:100%">
><div id="content" style="background:#FF0000;margin:0;border:0;padding:10;position:absolute;top:80;left:140;right:204;width:auto;min-height:400;overflow:hidden">
></div>
>  <div id="right_layer" style="background:#00FF00;margin:0;border:0;padding:10;text-indent:10;position:absolute;right:0;top:80;width:214;height:300;overflow:visible">
>  </div>
></div>
></body>
></html>
Attachment #717659 - Attachment mime type: text/plain → text/html
Same issue as before. You need units.
Blocks: 774122
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
Same answer as before: "You" is "a Firefox user since 17.0.1", nobody else, no other Browser.

Look into my commentary on: https://bugzilla.mozilla.org/show_bug.cgi?id=844641
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Have you noticed this problem on sites that you use but are not the developer of?
Component: Untriaged → Style System (CSS)
OS: Windows XP → All
Product: Firefox → Core
Hardware: x86 → All
Summary: CSS min-width and min-height don't work anymore → CSS min-width and min-height without units don't work anymore
I haven't seen any feedback from users of sites about those sites being broken, and we've been shipping this on the release channel for quite a few months now.

This is also something we've never supported in standards mode; it's quirks mode only.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → INVALID
I've no problem with that.

But: When Firefox is running in quirks mode, why not inform the developers about this issue in the log.console or the error log?

I don't know how good you know compileable languages, but a good compiler always tells the programmer if there is an error in the code. And because browser often don't do this, it's really a huge mess to work with browsers!

Somehow the browser developer think that all programmer (must) read all specifications about any browser. But this is a very wrong concept, any programming (in C, C# or Java), couldn't be done with this concept! Without validation, I just see that something doesn't work, but I don't know why, while the browser knows why, but doesn't tell me. That's a very strange concept and not programmer friendly at all.

And I'm certainly not going to read all those rules in https://developer.mozilla.org/en-US/docs/Mozilla_Quirks_Mode_Behavior, that's the Job of the browser to integrate those rules and notify the programmer if something isn't okey.

So, I please you to inform me in the future when Firefox runs in quirks mode. That would be just a few lines of code in the Firefox core, but a huge improvement for all developers.

Thanks in advance.
But we do that in the Error Console already...

Timestamp: 25/02/2013 07:23:19
Warning: Error in parsing value for 'min-width'.  Declaration dropped.
Source File: https://bug844649.bugzilla.mozilla.org/attachment.cgi?id=717659
Line: 0

Timestamp: 25/02/2013 07:23:19
Warning: Error in parsing value for 'min-height'.  Declaration dropped.
Source File: https://bug844649.bugzilla.mozilla.org/attachment.cgi?id=717659
Line: 0

Timestamp: 25/02/2013 07:23:19
Warning: Error in parsing value for 'text-indent'.  Declaration dropped.
Source File: https://bug844649.bugzilla.mozilla.org/attachment.cgi?id=717659
Line: 0
But you want something that says "You're in quirks mode" in the log.
For that right click, choose Page Info and the Render Mode is labelled as Quirks mode.
You need to log in before you can comment on or make changes to this bug.