If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Provide support for click disambiguation

RESOLVED DUPLICATE of bug 663803

Status

Fennec Graveyard
Readability
RESOLVED DUPLICATE of bug 663803
5 years ago
3 years ago

People

(Reporter: jwir3, Unassigned)

Tracking

({uiwanted})

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 717699 [details]
screenshot

Google chrome, on mobile, supports a type of click disambiguation that is similar to the "light box" concept that kats was working on a bit ago. When the user clicks a link that is small enough that the user's touch event overlaps two or more potential links, a small dialog appears that is essentially a zoomed-in version of the potential links. The user can then click the link he/she wanted in the first place, rather than possibly getting sent to a page that was not what he/she wanted (see attachment).

We should support a similar concept - I'm constantly clicking the wrong link when I know what I want to click (and thus don't zoom in), but my fingers are too large to accurately hit the text I desire.
(Reporter)

Updated

5 years ago
OS: Linux → Android
Hardware: x86_64 → All
Duplicate of this bug: 849550
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 663803
(Assignee)

Updated

3 years ago
Product: Firefox for Android → Fennec Graveyard
You need to log in before you can comment on or make changes to this bug.