All users were logged out of Bugzilla on October 13th, 2018

Context menu "open link in new window" crashes M091 [@ nsSliderFrame::DoLayout]

VERIFIED DUPLICATE of bug 83805

Status

()

--
critical
VERIFIED DUPLICATE of bug 83805
18 years ago
17 years ago

People

(Reporter: selmer, Assigned: eric)

Tracking

({crash, qawanted, topcrash})

Trunk
mozilla0.9.2
x86
Other
crash, qawanted, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

18 years ago
6/5 and 6/6 builds both crashed at least once.
(Reporter)

Comment 1

18 years ago
(don't tab and hit return, it'll submit for you :-)

I meant both 6/5 and 6/7 crashed.  Not sure if this is the right component. 
Crash was actually in GKLayout.

Talkback ID = TB31441935Z for the 6/7 build.

Don't know yet if there's anything special about the links involved.  The 6/5
crash was opening an attachment to a bug from the link in the description.  The
6/7 crash was opening a bug from its link in a bug list.

Can we look for this signature and see whent this started and how many people
are hitting it?
Target Milestone: --- → mozilla0.9.1

Comment 2

18 years ago
I'm not seeing this on Windows NT commercial 2001-06-07-06-0.9.1.

Comment 3

18 years ago
dunno if that's the same, but just started playing with
  Mozilla/5.0 (X11; U; Linux 2.4.4 i686; en-US; rv:0.9.1) Gecko/20010606
a few hours ago and I already had one crash when clicking on a link
with middle mouse key (=open link in new window) on a website I visit daily.
unable to reproduce and sorry no talkback
it's been awhile since Mozilla last crashed on me... hmm ...

Comment 4

18 years ago
This should be critical/keyword=crash, ja?
Severity: normal → critical
Keywords: crash
trunk or branch or both?
should this go over to the layout component? talkback report:

Incident ID 31441935 
 Stack Signature          nsSliderFrame::DoLayout ecf605bb 
 Trigger Time             2001-06-07 08:51:45 
 User Comments            bugzilla bug link, "open in new window", crash 
 Build ID                 2001060706

nsSliderFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSliderFrame.cpp, line 386] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line
985] 
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 417] 
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553] 
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 979] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line
985] 
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 417] 
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553] 
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 979] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line
985] 
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 417] 
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553] 
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 979] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line
985] 
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 417] 
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553] 
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 979] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line
985] 
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 417] 
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553] 
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 979] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line
985] 
nsPopupSetFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsPopupSetFrame.cpp, line 291] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line
985] 
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 417] 
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553] 
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 979] 
nsMenuFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsMenuFrame.cpp, line 805] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line
985] 
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 417] 
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553] 
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 979] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line
985] 
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 417] 
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553] 
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 979] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line
985] 
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 417] 
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553] 
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 979] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line
985] 
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 417] 
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553] 
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 979] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line
985] 
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 417] 
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553] 
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 979] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line
985] 
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 417] 
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553] 
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 979] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line
985] 
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 417] 
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553] 
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 979] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line
985] 
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 417] 
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553] 
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 979] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line
985] 
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 417] 
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553] 
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 979] 
tested with 2001.06.07.03-branch and 2001.06.07.09-trunk comm bits on winNT --i
couldn't get a crash when selecting "open link in new window".

going to test mac and linux branch/trunk builds soon...

moving this over to layout --but pls do punt to a more appropriate place, as
needed. :)
Assignee: blakeross → karnaze
Component: XP Apps: GUI Features → Layout
QA Contact: sairuh → petersen
hrm, i couldn't repro this on linux or mac, either. i tried links in
http://mozilla.org, as well as bug links in a bug listing, and bug links within
bug reports.

mac [comm] 2001.06.07.08-trunk and 2001.06.07.03-branch: tried both long-click
and ctrl-click to bring up the context menu, then selected "open link in new
window".

linux [comm] 2001.06.07.08-trunk and 2001.06.07.04-branch: tried both selecting
the item from the context menu, as well as middle-button-clicking links.
Summary: Context menu "open in new window" crashes → Context menu "open link in new window" crashes
(Reporter)

Comment 9

18 years ago
My crashes were all on Branch builds.  It's relatively rare, and only struck me
because I hit in two builds.  I do open in new window zillions of times and only
have these 2 crashes.  That's why I'm interested in seeing if it's showing up in
talkback.
(Reporter)

Comment 10

18 years ago
Shiva, any luck finding this signature?
(Reporter)

Comment 11

18 years ago
If there are a lot of talkbacks, please move back to mozilla0.9.1.  ->092
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Comment 12

18 years ago
Reassigning to evaughan based on stack.
Assignee: karnaze → evaughan

Comment 13

18 years ago
Intial(M091) talkback reports doesn't show this crash as topcrash. But, there
are 13 crashes reported with this stack signature.
Summary: Context menu "open link in new window" crashes → Context menu "open link in new window" crashes [@ nsSliderFrame::DoLayout]
(Assignee)

Comment 14

18 years ago
Don't know what to say here. The stack trace points to a place where thumbBox is 
dereferenced. But according to the code logic its impossible for thumbBox to be 
null. I have no idea what went wrong here. John can you see if we can get a 
reproducable test case for this?
Assignee: evaughan → jrgm

Updated

18 years ago
Keywords: qawanted, topcrash
Summary: Context menu "open link in new window" crashes [@ nsSliderFrame::DoLayout] → Context menu "open link in new window" crashes M091 [@ nsSliderFrame::DoLayout]

Comment 15

18 years ago
Latest talkback information from Mozilla Milestone 0.9.1 release

Stack Trace: 

	 nsSliderFrame::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSliderFrame.cpp  line 386]
	 nsBox::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp  line 985]
	 nsSprocketLayout::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp  line 417]
	 nsContainerBox::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp  line 553]
	 nsBoxFrame::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp  line 979]
	 nsBox::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp  line 985]
	 nsSprocketLayout::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp  line 417]
	 nsContainerBox::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp  line 553]
	 nsBoxFrame::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp  line 979]
	 nsBox::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp  line 985]
	 nsSprocketLayout::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp  line 417]
	 nsContainerBox::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp  line 553]
	 nsBoxFrame::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp  line 979]
	 nsBox::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp  line 985]
	 nsSprocketLayout::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp  line 417]
	 nsContainerBox::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp  line 553]
	 nsBoxFrame::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp  line 979]
	 nsBox::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp  line 985]
	 nsSprocketLayout::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp  line 417]
	 nsContainerBox::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp  line 553]
	 nsBoxFrame::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp  line 979]
	 nsBox::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp  line 985]
	 nsPopupSetFrame::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsPopupSetFrame.cpp  line 291]
	 nsBox::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp  line 985]
	 nsSprocketLayout::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp  line 417]
	 nsContainerBox::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp  line 553]
	 nsBoxFrame::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp  line 979]
	 nsMenuFrame::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsMenuFrame.cpp  line 805]
	 nsBox::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp  line 985]
	 nsSprocketLayout::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp  line 417]
	 nsContainerBox::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp  line 553]
	 nsBoxFrame::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp  line 979]
	 nsBox::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp  line 985]
	 nsSprocketLayout::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp  line 417]
	 nsContainerBox::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp  line 553]
	 nsBoxFrame::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp  line 979]
	 nsBox::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp  line 985]
	 nsSprocketLayout::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp  line 417]
	 nsContainerBox::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp  line 553]
	 nsBoxFrame::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp  line 979]
	 nsBox::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp  line 985]
	 nsSprocketLayout::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp  line 417]
	 nsContainerBox::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp  line 553]
	 nsBoxFrame::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp  line 979]
	 nsBox::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp  line 985]
	 nsSprocketLayout::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp  line 417]
	 nsContainerBox::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp  line 553]
	 nsBoxFrame::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp  line 979]
	 nsBox::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp  line 985]
	 nsSprocketLayout::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp  line 417]
	 nsContainerBox::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp  line 553]
	 nsBoxFrame::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp  line 979]
	 nsBox::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp  line 985]
	 nsSprocketLayout::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp  line 417]
	 nsContainerBox::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp  line 553]
	 nsBoxFrame::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp  line 979]
	 nsBox::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp  line 985]
	 nsSprocketLayout::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp  line 417]
	 nsContainerBox::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp  line 553]
	 nsBoxFrame::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp  line 979]
	 nsBox::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp  line 985]
	 nsSprocketLayout::Layout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp  line 417]
	 nsContainerBox::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp  line 553]
	 nsBoxFrame::DoLayout	
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp  line 979]
 
 	Source File : 
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xul/base/src/nsSlider
Frame.cpp line : 386
     (31565959)	URL: grc.com/dos/grcdos.htm
     (31565959)	Comments: reading web mail and clicking on a urlsee crash dump 
from windows MOZILLA a cause une exception 10H dans le module GKLAYOUT.DLL a 
0167:60379c42.Registres :EAX=01bc3dbc CS=0167 EIP=60379c42 
EFLGS=00010246EBX=0000000f SS=016f ESP=0068d680
     (31565959)	Comments:  EBP=0068d6f0ECX=0068d6c4 DS=016f ESI=01bc3d00 
FS=0d6fEDX=0068d6d8 ES=016f EDI=00000000 GS=0000Octets a CS : EIP :d9 5e 44 8b 
08 dd d8 ff 51 18 83 7d e8 00 7e 45 Etat de la pile :01bc3dbc 0068ecf8 0068d6d8 
00000000 00000001 01bc3d00 024ac3e0
     (31565959)	Comments:  0068ecf8 0068d7bc 603116c0 024c9b10 01bc3ccc 60ea739b 
00000000 00000000 00000000 
     (31565158)	URL: www.acsalaska.com
     (31565158)	Comments: I was in preferences trying to change the font on my 
menus
     (31564787)	URL: http://www.oasis-open.org/committees/relax-ng/tutorial.html
     (31564787)	Comments: Suddenly crashed while entering another URL
     (31562281)	URL: grc.com/dos/grcdos.htm
     (31562281)	Comments: open a new page on a link grc.com/dos/winxp.htm when 
printing a the same time
     (31561572)	URL: www.cache.net
     (31561572)	Comments: Was attempting to enter new URL in "Location" field 
while HP DJ932 printer on LPT1 was printing web page.
     (31560193)	URL: www.sgalaxy.com
     (31560193)	Comments: opening new navigator window.
     (31558601)	Comments: I had just pasted in a url into the location bar
     (31558601)	Comments:  the URLIt seems to be treating the IE booksmarks as a 
text file and not as a list of hyperlinks
     (31556811)	Comments: printing an e-mail message
     (31528173)	Comments: Again only started the browser and wnated to type 
url.Using WinNt 4 Pack 6
     (31526219)	Comments: Clicked the "home" button and it crashed.  The GUI had 
been buggy just before this (right click yielded greyed out back and forward 
choices).
     (31516552)	URL: www.slashdot.org
     (31516552)	Comments: browsing
     (31500525)	Comments: ctrl-N just after printing
     (31500087)	Comments: ctrl-n for new window
     (31491170)	Comments: I don't know what happen.When Browsing Pages
     (31485718)	Comments: typing in a url causes mozilla to 
crash.HAAAAAAAAAAAAAAAAAAAAAAAAAAa!
     (31484073)	Comments: Opened a new window after I started JSPager (see also 
bug 83451)
     (31480340)	Comments: was typing an URL in the url field and the program 
crashed
     (31478979)	Comments: I was clicking on a link
     (31474590)	URL: http://www.elsa.com/
     (31474590)	Comments: After Alt-N Mozilla 0.9.1 crashed
     (31473236)	Comments: tried to type in a new url.
     (31472924)	Comments: just readin'
     (31463106)	Comments: trying to print



Comment 16

18 years ago
I spent a good hour and a half going through the abvoe comments and trying to 
find a way to reproduce this crash (can I party or what) but I couldn't find a 
way (win2k/0.9.1 since all the stack traces were windowsen).

I note that the stacks are deeply recursive, just going through the same
four frames as many times as talkback will tell you about (about 15 in the
samples above). It may be that the crash in nsSliderFrame::DoLayout is just
the inevitable result of an infinite recursion. 

Anyone else have a way to reproduce this? (back to evaughan, but he will be 
away after Wednesday for a while).
Assignee: jrgm → evaughan

Comment 17

18 years ago
Isn't this a dup of 83805?

Comment 18

18 years ago
Er, yeah. 

*** This bug has been marked as a duplicate of 83805 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 19

17 years ago
verifying dup
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsSliderFrame::DoLayout]
You need to log in before you can comment on or make changes to this bug.