If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[RFE] setup sync on new computer using Firefox for Android

RESOLVED WORKSFORME

Status

Android Background Services
Android Sync
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Stanislav Ochotnicky, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Short summary:
To setup a Sync on new computer it's not enough to have Firefox for Android already setup. You need desktop installation of Firefox to setup new Firefox Sync devices.

Environment:
1 desktop machine with Firefox Sync setup and working (base)
1 Android phone with Firefox Sync setup  and working (phone)
1 fresh installation of notebook, no Sync (notebook)

Task:
Set up Sync on notebook. 

Approach:
1. On notebook run Firefox and go to Tools->Set Up Sync...
2. Click "I have an Account"
3. Pairing codes appear in 3 text fields with instructions 'To activate select "Pair a Device" on your other device'
4. There is no feature in Firefox for Android for "Pair a Device". Settings->Sync are just for setting up Sync account *on* phone
5. Only way to sync notebook is to be near base (another desktop computer with Sync setup) and follow normal Sync instructions

It would be nice if Firefox on Android could be used setup new computer for Sync.

*Note:* Tested on latest FfM available in Google Play (Firefox 19.0 at this time)

Updated

5 years ago
Component: General → Android Sync
Product: Firefox for Android → Mozilla Services
Version: Firefox 19 → unspecified
Hi Stanislav,

I think Firefox for Android already supports this, but it's a little hidden (mostly due to Android changes over time).  If you go to Settings > Accounts & Sync and select your Sync Account, you should find a "Pair a Device" button.  Tap that and you should get a page asking you to enter the 12-digit code *on your phone*.

Now, on your laptop, go to Tools > Set up Sync... and click on "I have an Account".  This should show you the 12-digit code that you will enter *into your phone*.

I think the tricky part here is actually finding the "Pair a Device" button -- IIRC, Android has changed the menu structure during the Android 4.0, 4.1, and 4.2 release time frames.

Let me know if this works for you.
Flags: needinfo?(sochotnicky+mozbugs)
Stanislav, you can also get to your Sync Account from within Firefox for Android: go to Settings, Sync, and it should take you there.  (Again, depends on Android version.)
This is probably on SUMO, but I can't find it.  I've added Michelle Luna to the CC list; hopefully she can point to any documentation we have on these steps.  Thanks Michelle!
Flags: needinfo?(mluna)
(Reporter)

Comment 4

5 years ago
(In reply to Nick Alexander :nalexander from comment #1)
> Hi Stanislav,
> 
> I think Firefox for Android already supports this, but it's a little hidden
> (mostly due to Android changes over time).  If you go to Settings > Accounts
> & Sync and select your Sync Account, you should find a "Pair a Device"
> button.  Tap that and you should get a page asking you to enter the 12-digit
> code *on your phone*.
>
> Now, on your laptop, go to Tools > Set up Sync... and click on "I have an
> Account".  This should show you the 12-digit code that you will enter *into
> your phone*.
>
> I think the tricky part here is actually finding the "Pair a Device" button
> -- IIRC, Android has changed the menu structure during the Android 4.0, 4.1,
> and 4.2 release time frames.
> 
> Let me know if this works for you.

Huh, now this is interesting. If I use Firefox menu to go to Settings->Sync it only gives me option to add sync account or look at current ones. When I click on Sync account I've already setup it gives me only option to stop sync-ing. 

*However* If I go to (Android) Settings->Sync->Firefox Sync, I have a button "pair a device" there and it is usable. For the record this is Samsung S3, stock ROM, 4.1.2.

It looks like this is a UI issue not a feature request anymore I guess. I'll leave reassigning/changing summary to you. I can provide screenshots if it would help.
Flags: needinfo?(sochotnicky+mozbugs)
(Reporter)

Comment 5

5 years ago
I also tested this on Aurora and if needed can test nightly builds.
> > Let me know if this works for you.
> 
> Huh, now this is interesting. If I use Firefox menu to go to Settings->Sync
> it only gives me option to add sync account or look at current ones. When I
> click on Sync account I've already setup it gives me only option to stop
> sync-ing. 
> 
> *However* If I go to (Android) Settings->Sync->Firefox Sync, I have a button
> "pair a device" there and it is usable. For the record this is Samsung S3,
> stock ROM, 4.1.2.

Yup.  Android has changed this interface several times.  Long term, we should fold any Sync configuration into Firefox for Android's settings, but we don't have immediate plans to do this.  Since there is a work-around, it's very low priority.
 
> It looks like this is a UI issue not a feature request anymore I guess. I'll
> leave reassigning/changing summary to you. I can provide screenshots if it
> would help.

Screenshots and additional testing is not necessary, but thanks for offering.  Sorry that this is counter-intuitive.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

5 years ago
Component: Android Sync → Android Sync
Product: Mozilla Services → Android Background Services
Sounds like this bug is resolved. Most of the support pain will go away when FxA gets into the wild.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.