Flash Player 11.6.602.168 high memory usage (plugin-container.exe) under Firefox 19.0. Warnings in about:memory.

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P3
normal
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: programings, Unassigned, NeedInfo)

Tracking

19 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

1. Be sure you using last Flash Player version - 11.6.602.168.
1. Remember the memory usage of plugin-container.exe before this test.
1. Open page with flash content (for example radio player or page with a lot of youtube videos embeded in it)
2. Wait 1-2 hours.
3. See the difference in memory usage of plugin-container.exe before and after the test.

Look about:memory page too - may have a warnings.


Actual results:

After 1 - 2 hours using, Mozilla Firefox 19.0 and my operating system started working really slowly.
When i see the memory usage in Task Manager, the process plugin-container.exe use a lot of memory (130 - 140 MB of RAM) - sometimes more than Firefox.
In about:memory page i see warning about negative or unreasonably large values in memory (not every time).
The only solution is browser restart or plugin-container.exe terminate.


Expected results:

Firefox and all operating system started working slowly because plugin-container.exe use a lot of RAM.
(Reporter)

Comment 1

5 years ago
Created attachment 717924 [details]
plugin-container.exe memory usage

Only one youtube video opened in this moment.

Comment 2

5 years ago
Try these actions:
1) Disable hardware acceleration in Flash: http://forums.adobe.com/thread/891337
2) Disable protected mode in Flash: http://forums.adobe.com/thread/1018071 (section 'last resort')
3) Update your GPU drivers if possible

Does it fix your issue?
Flags: needinfo?(programings)
(Reporter)

Comment 3

5 years ago
No.

I did these things before file a new bug.
The problem is not on my system.
Flags: needinfo?(programings)
The plugin-container.exe is a small shell around each plugin.
It looks like a memory leak in the plugin if the memory usage raises.
Component: Untriaged → Plug-ins
Product: Firefox → Core
(Reporter)

Comment 5

5 years ago
I file a new bug in Adobe Bugbase:
https://bugbase.adobe.com/index.cfm?event=bug&id=3506392
Priority: -- → P3
The amount of RAM used doesn't seem that excessive, but if it's a reproducible leak it might be worth making sure what is triggering it.
(Reporter)

Comment 7

5 years ago
Created attachment 718389 [details]
memory_leak_log.txt

I monitored the memory usage of plugin-container.exe for 1 hour with only one opened radio player that was using Flash Player.

The results (with about:memory data included) are in the attachment log file.

Comment 8

5 years ago
Have you tried with 11.6.602.171 stable or 11.6.602.175 beta?
(Reporter)

Comment 9

5 years ago
Yes.
Same problem with this 2 versions of Flash Player.

Comment 10

5 years ago
Hi, I have same problem here, I use the last Mozilla Firefox 19.0.1, and the last Flash player update 11.6.602.168, I have Windows 8 X64, and when I open some sites that contains Flash. Firefox becomes blocked, after a message said Flash Player has bugged, send report or refresh, So I click on send report. For have control of Firefox, I need to do ctrl + alt + del and finally end task Flash player after Firefox responds
(In reply to Joffrey Dubus from comment #10)
> Hi, I have same problem here, I use the last Mozilla Firefox 19.0.1, and the
> last Flash player update 11.6.602.168, I have Windows 8 X64, and when I open
> some sites that contains Flash. Firefox becomes blocked, after a message
> said Flash Player has bugged, send report or refresh, So I click on send
> report. 

This bug is about a possible Flash using more memory than it should, not Firefox becoming unresponsive with Flash.
If you have URLs where you can reproduce that, please file a new bug report with a description on how to trigger this behaviour.

Comment 12

4 years ago
I can consistently cause the problem by playing Hidden Chronicles. All memory will be consumed over time (I have 12G on my machine). A restart of Firefox will release the memory. It will consume the memory in a 24 hour period even if the game was only played once, but the browser is still open. This has been a continuing problem from as far back as version 17 of Firefox.

Comment 13

4 years ago
What version are you running? I see that 11.7.700.224 has been released: http://tinyurl.com/7rzpbdt

Comment 14

4 years ago
(In reply to Arthur K. from comment #13)
> What version are you running? I see that 11.7.700.224 has been released:
> http://tinyurl.com/7rzpbdt

I am running Firefox22b4 and flash 11.8.800.75 on Mac OS 10.8.4

Comment 15

4 years ago
Those are both beta and not stable versions.

Comment 16

4 years ago
(In reply to Arthur K. from comment #15)
> Those are both beta and not stable versions.

Also does same thing with firefox 21 and Flash 11.7.700.225

It has been very consistent
Is this still an issue using latest Flash Player and Firefox Nightly ? nightly.mozilla.org
Flags: needinfo?(programings)

Comment 18

4 years ago
I still see high-ish CPU use on both XP and Win 7 64 when visiting, for example, speedtest.net and even using Flash 11.8.800.129.

Comment 19

4 years ago
Sorry, memory use seemed reasonable, not high.

Comment 20

4 years ago
(In reply to Paul Silaghi [QA] from comment #17)
> Is this still an issue using latest Flash Player and Firefox Nightly ?
> nightly.mozilla.org



Yes still an issue with 23b10 and flash 11.8.800.129
Tested on nightly 25.0a1 (2013-08-05), Flash Player 11.8.800.94
On Win 7 x64, plugin-container.exe didn't exceed 7 MB of memory.
But on Win XP x86, plugin-container.exe easily reached 100 MB with a youtube open.

What could be different between Win 7 and XP? Something with OOPP ?
Flags: needinfo?(georg.fritzsche)

Comment 22

4 years ago
(In reply to Paul Silaghi [QA] from comment #21)
> Tested on nightly 25.0a1 (2013-08-05), Flash Player 11.8.800.94
> On Win 7 x64, plugin-container.exe didn't exceed 7 MB of memory.
> But on Win XP x86, plugin-container.exe easily reached 100 MB with a youtube
> open.
> 
> What could be different between Win 7 and XP? Something with OOPP ?

Is it the same with 11.8.800.129?
Where did you get that?
http://get2.adobe.com/flashplayer/

Comment 24

4 years ago
(In reply to Paul Silaghi [QA] from comment #23)
> Where did you get that?
> http://get2.adobe.com/flashplayer/

http://labs.adobe.com/downloads/flashplayer.html
That is a beta version, I didn't test it yet.

Comment 26

4 years ago
(In reply to Paul Silaghi [QA] from comment #25)
> That is a beta version, I didn't test it yet.

Yes it is beta but worth seeing if it's still present in post 11.8.800.94 versions on XP. If so, there would be stronger evidence that it points to something XP specific I would think.
(In reply to Paul Silaghi [QA] from comment #21)
> Tested on nightly 25.0a1 (2013-08-05), Flash Player 11.8.800.94
> On Win 7 x64, plugin-container.exe didn't exceed 7 MB of memory.
> But on Win XP x86, plugin-container.exe easily reached 100 MB with a youtube
> open.
> 
> What could be different between Win 7 and XP? Something with OOPP ?

Hm, i don't know off-hand. I think we'd need to investigate that (with some memory-allocation tracing) to see where this is coming from.
Flags: needinfo?(georg.fritzsche)
Reopen if you can reproduce this using latest Flash Player and Firefox Nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 29

3 years ago
Flash 16 and firefox 36. Still a problem

Comment 30

3 years ago
(In reply to neopeeves from comment #29)
> Flash 16 and firefox 36. Still a problem

Which version Flash 16 specifically? What OS are you using? Can you upload an about:memory report when you see high memory usage? Some examples of Video/Flash content that caused the memory to spike?

Comment 31

3 years ago
(In reply to Arthur K. from comment #30)
> (In reply to neopeeves from comment #29)
> > Flash 16 and firefox 36. Still a problem
> 
> Which version Flash 16 specifically? What OS are you using? Can you upload
> an about:memory report when you see high memory usage? Some examples of
> Video/Flash content that caused the memory to spike?

Flash 16.0.0.287
Windows 7

Completely closing firefox reduces the memory to acceptable levels (obviously). I didn't screenshot about:memory, but it was explicit/storage/sqlite at -2.05mb. When I closed firefox from task manager after it froze, places.sqlite-wal was at around 330,000kb.

It seems to be that firefox is retaining memory that it should be freeing up when tabs are closed, or websites are changed. Some websites accumulate stuck data faster than others. In today's case, I was using "The worst things for sale" website when firefox's memory doubled. A website that has no video and no flash elements (There in no plugin icon in the address bar)

Comment 32

3 years ago
(In reply to neopeeves from comment #31)
> (In reply to Arthur K. from comment #30)
> > (In reply to neopeeves from comment #29)
> > > Flash 16 and firefox 36. Still a problem
> > 
> > Which version Flash 16 specifically? What OS are you using? Can you upload
> > an about:memory report when you see high memory usage? Some examples of
> > Video/Flash content that caused the memory to spike?
> 
> Flash 16.0.0.287
> Windows 7
> 
> Completely closing firefox reduces the memory to acceptable levels
> (obviously). I didn't screenshot about:memory, but it was
> explicit/storage/sqlite at -2.05mb. When I closed firefox from task manager
> after it froze, places.sqlite-wal was at around 330,000kb.
> 
> It seems to be that firefox is retaining memory that it should be freeing up
> when tabs are closed, or websites are changed. Some websites accumulate
> stuck data faster than others. In today's case, I was using "The worst
> things for sale" website when firefox's memory doubled. A website that has
> no video and no flash elements (There in no plugin icon in the address bar)

There were a spate of Flash versions released in Feb. Please test with the current Flash version 16.0.0.315: http://www.adobe.com/uk/products/flashplayer/distribution3.html and see if it still repros.

Comment 33

3 years ago
(In reply to neopeeves from comment #31)
> (In reply to Arthur K. from comment #30)
> > (In reply to neopeeves from comment #29)
> > > Flash 16 and firefox 36. Still a problem
> > 
> > Which version Flash 16 specifically? What OS are you using? Can you upload
> > an about:memory report when you see high memory usage? Some examples of
> > Video/Flash content that caused the memory to spike?
> 
> Flash 16.0.0.287
> Windows 7
> 
> Completely closing firefox reduces the memory to acceptable levels
> (obviously). I didn't screenshot about:memory, but it was
> explicit/storage/sqlite at -2.05mb. When I closed firefox from task manager
> after it froze, places.sqlite-wal was at around 330,000kb.
> 
> It seems to be that firefox is retaining memory that it should be freeing up
> when tabs are closed, or websites are changed. Some websites accumulate
> stuck data faster than others. In today's case, I was using "The worst
> things for sale" website when firefox's memory doubled. A website that has
> no video and no flash elements (There in no plugin icon in the address bar)

Sorry, typo: 16.0.0.305

Comment 34

2 years ago
Should be reopened:
https://bugzilla.mozilla.org/show_bug.cgi?id=647878#c21

Can confirm with latest flash on Linux and Chrome's flash plugin through freshplayerplugin.
I tried Adobe Flash 11.2.202.481-1 for Linux and freshplayerplugin using Chrome's flash 18.0.0.204-1
Firefox 39.0
Arch Linux, KDE
You need to log in before you can comment on or make changes to this bug.