Fixed background image overdraws foreground text during scrolling

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: aryx, Unassigned)

Tracking

34 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox34 affected, fennec+)

Details

(URL)

Attachments

(3 attachments)

Created attachment 717937 [details]
screenshot of background and missing text

Firefox for Android 20130225, Android 4.1.2 (stock), Google Nexus

It's possible that text layered over a background image is not visible, only the background image is shown, as long as the user scrolls/pans.

Steps to reproduce:
1. Go to http://quotes.burntelectrons.org/browse?start=100
2. Scroll down (if you scroll down fast and release, you should see it; else scroll and hold the finger until you see the issue).
Created attachment 8470623 [details]
Reddit

Noticed this today; Nightly 34, KitKat, HTC One m7.
This is the style fragment:

body{
	background:url("http://c.thumbs.redditmedia.com/gLrpnvRtu1goUW58.png") no-repeat fixed center center
}
tracking-fennec: --- → ?
status-firefox34: --- → affected
Summary: Text over background image not visible, only the background image shown, as long as user scrolls/pans → Fixed background image overdraws foreground text during scrolling
Kats - How does your APZ work affect this?
tracking-fennec: ? → +
Flags: needinfo?(bugmail.mozilla)
It likely doesn't affect this at all. The same bug appears in the B2G browser.
Flags: needinfo?(bugmail.mozilla)
Created attachment 8476808 [details]
Layer tree of the reddit page while scrolling (Fennec aurora 33)
The layer tree doesn't change structurally while scrolling vs when stationary, so it's not obvious to me why the teapot appears on top of the text while scrolling. This will require some investigation.
Moving to Core::Panning and Zooming so I don't forget about this bug. It is not Fennec-specific since it happens on B2G as well.
Component: Graphics, Panning and Zooming → Panning and Zooming
Product: Firefox for Android → Core
Version: Trunk → 34 Branch
filter on [mass-p5]
Priority: -- → P5
Janky as hell, affects major sites -> not P5.
Priority: P5 → --
This appears to have been fixed at some point in the recent past. There were a few fixes to how things are layerized in the presence of async transforms which were probably responsible but I didn't check.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.