Apps awaiting review are incorrectly marked as featured blocking the developer from editing details.

RESOLVED INVALID

Status

Marketplace
Developer Pages
P2
normal
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: bsilverberg, Assigned: chuck)

Tracking

2013-03-14
x86
Mac OS X
Points:
---

Details

(Whiteboard: [fromAutomation] p=1)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 718028 [details]
Screen cap of dialog preventing editing of categories

One of our automated tests for Marketplace started failing because we are unable to edit categories for a submitted app as it is marked as featured. Our process is to choose a free submitted app from the "My Submissions" listing, then edit it, then clear out the categories and assert that the correct validation is displayed. This test is unable to proceed when it cannot edit the categories due to the app being listed as featured. See the attached screen cap for the dialog.
(Reporter)

Updated

5 years ago
Whiteboard: [fromAutomation]

Updated

5 years ago
Summary: Submitted apps on dev are marked as featured → Apps awaiting review are incorrectly marked as featured blocking the developer from editing details.
Chuck, do you have any ideas here? This is the point in the code where we check: https://github.com/mozilla/zamboni/blob/master/mkt/developers/forms.py#L799
Assignee: nobody → charmston
Priority: -- → P2
Whiteboard: [fromAutomation] → [fromAutomation] p=1
Target Milestone: --- → 2013-03-14
(Assignee)

Comment 2

5 years ago
This is actually a feature, not a bug. Featured apps should not be editable, to prevent miscellaneous shenanigans by malicious developers. If you wouldn't mind providing the app ID (the name is pretty unsearchable), I can unmark the app as featured so the tests start passing again.
Flags: needinfo?(bob.silverberg)
This app is actually gone:

https://marketplace-dev.allizom.org/app/test-app-1359719736/

Not sure how it's missing but it is.
Flags: needinfo?(bob.silverberg)
(Assignee)

Comment 4

5 years ago
And that explains why I couldn't find it in search.

Closing up! Bob, let me know if you need additional help getting your tests passing.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Comment 5

5 years ago
Removed that part of the test for now. Thanks
You need to log in before you can comment on or make changes to this bug.