The built-in DOM Inspector removes trailing spaces from edited text

RESOLVED DUPLICATE of bug 878514

Status

RESOLVED DUPLICATE of bug 878514
6 years ago
4 months ago

People

(Reporter: M8R-d5p26, Unassigned)

Tracking

21 Branch
x86_64
All

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20140305])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130224 Firefox/21.0
Build ID: 20130224042019

Steps to reproduce:

Tried to edit text with trailing spaces


Actual results:

The trailing spaces were removed


Expected results:

The trailing spaces should have been preserved, since there was an <a> element after it.  Removing the trailing space from the text removed the space between a plaintext word and the linked word that followed it.
Component: Untriaged → Developer Tools: Inspector

Comment 1

5 years ago
Thank you for filing this!

I am duping it to the newer bug because it seems to contain a little more information ("preceding" and "changes do not actually have to be made") and a testcase.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
OS: Windows 7 → All
Resolution: --- → DUPLICATE
Whiteboard: [bugday-20140305]
Duplicate of bug: 878514

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.