File picker should default to <input accept= attribute instead of "All Files".

RESOLVED DUPLICATE of bug 826185

Status

()

RESOLVED DUPLICATE of bug 826185
6 years ago
6 years ago

People

(Reporter: dixo0015, Unassigned)

Tracking

19 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

Set up a file input with a single accept entry for a specific mime type, e.g. <input accept="image/jpeg" type="file"/>


Actual results:

The input dialog defaults to having "All Files" selected, instead of "image/jpeg".


Expected results:

The input should default to "image/jpeg", since there's just one item in the accept attribute.
Status: UNCONFIRMED → NEW
Component: Untriaged → DOM: Core & HTML
Ever confirmed: true
OS: Mac OS X → All
Product: Firefox → Core

Comment 1

6 years ago
Looks like a duplicate of bug 826185.
Mime type support for input file was implemented as part of bug 565274.
This is indeed a duplicate of bug 826185.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 826185
(Reporter)

Comment 3

6 years ago
Thanks -- I voted for 826176, which looks like it would add the behavior I'm looking for.

Comment 4

6 years ago
Just to clarify: bug 826176 is about adding support for file extensions for <input type="text", in addition of mimetype which Firefox currently supports. It's a different thing.
(Reporter)

Comment 5

6 years ago
Assuming you meant <input type="file", that makes sense.  I've written up https://bugzilla.mozilla.org/show_bug.cgi?id=846270, which I think captures a request that's been in the comments of a few of these bugs, given that this support won't be added for all mimetypes.
You need to log in before you can comment on or make changes to this bug.