Calender Settings Screen Layout Update

RESOLVED INVALID

Status

Firefox OS
Gaia::Calendar
RESOLVED INVALID
5 years ago
4 years ago

People

(Reporter: epang, Assigned: ivanovpavel)

Tracking

({polish})

unspecified
All
Other
polish
Dependency tree / graph

Firefox Tracking Flags

(b2g18+ affected)

Details

(Whiteboard: visual design, UX-P1, yedo, landed in UX branch)

Attachments

(4 attachments, 2 obsolete attachments)

(Reporter)

Description

5 years ago
Created attachment 718163 [details]
Calender Settings Screen Mock Up

See image attachment for detailed changes.
(Reporter)

Updated

5 years ago
Blocks: 843818
(Reporter)

Comment 1

5 years ago
Created attachment 718758 [details]
Calender Settings Screen Mock Up

See attached image for list of changes
Attachment #718163 - Attachment is obsolete: true
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?
(Reporter)

Comment 2

5 years ago
Part of LG's request for font updates.
Mass edit to set tracking-b2g18+ for these UX bugs that were called out for v1.1
tracking-b2g18: --- → +

Updated

5 years ago
blocking-b2g: leo? → ---
Duplicate of this bug: 845114
(Reporter)

Comment 5

5 years ago
Pavel, when this bug is fixed can you attach this screen as well as one for bug 845114? Since the fix should take care of both of them. Thanks!
Flags: needinfo?(pivanov)
Created attachment 732494 [details]
After patch
Flags: needinfo?(pivanov)
Created attachment 732495 [details]
patch for Gaia repo
Attachment #732495 - Flags: review?(sjochimek)
Hmm, for the alarm implementation we agreed not to center the text in the select boxes as other places do not center it. I would recommend leaving it as left-aligned, as that's how the labels are.
(Reporter)

Comment 9

5 years ago
(In reply to Pavel Ivanov [:ivanovpavel] from comment #6)
> Created attachment 732494 [details]
> After patch

This looks good, but can you check if the type in the drop does is Medium weight? Thanks!
(Reporter)

Comment 10

5 years ago
(In reply to Kevin Grandon :kgrandon from comment #8)
> Hmm, for the alarm implementation we agreed not to center the text in the
> select boxes as other places do not center it. I would recommend leaving it
> as left-aligned, as that's how the labels are.

Hi Kevin, as part of the scrub Przemek and I worked on for Email, Contact and Calender we updated the drop downs and buttons to have centered copy.  

Przemek, what do you think should be done.  A decision needs to made so the drop downs and buttons are consistent throughout the device.
Flags: needinfo?(pabratowski)
Attachment #732494 - Attachment is obsolete: true
Created attachment 732685 [details]
After patch

Update select font-size to medium.
Blocks: 845072
(Reporter)

Comment 12

5 years ago
(In reply to Pavel Ivanov [:ivanovpavel] from comment #11)
> Created attachment 732685 [details]
> After patch
> 
> Update select font-size to medium.

Looks good now, thanks for making the change!
In my opinion the drop downs should match the regular buttons and use a centered text alignment. For settings screens with both regular and drop down buttons having an inconsistent text alignment looks strange.
Flags: needinfo?(pabratowski)

Comment 14

5 years ago
Created attachment 733773 [details]
No accounts - Screenshot

Comment 15

5 years ago
Comment on attachment 732495 [details]
patch for Gaia repo

It's an r+ but we should file a bug to hide the subtitle 'Accounts' if there is no account.
Attachment #732495 - Flags: review?(sjochimek) → review+

Comment 17

5 years ago
Landed in master https://github.com/mozilla-b2g/gaia/commit/15468abcba0dd2549f0c102df887a5c049b9c641
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Whiteboard: visual design, UX-P1, yedo → visual design, UX-P1, yedo, landed in UX branch
status-b2g18: --- → affected
Master build : 2013-04-05-03-05-43
name="mozilla-central" revision="55f9e3e3dae7"  
name="integration/gaia-central" revision="2005e026bdae"
"gecko.git" revision="66b64f47a4eac1bd4f5ea6748b42ddf732297550"
"gaia.git" revision="15468abcba0dd2549f0c102df887a5c049b9c641"
Unagi

Verified ... please uplift!
Status: RESOLVED → VERIFIED
Comment on attachment 732495 [details]
patch for Gaia repo

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): UX polish
User impact if declined: user settings won't be as intuitive for the user as possible
Testing completed: yes
Risk to taking this patch (and alternatives if risky):low, it's adding css changes, and dom linting
String or UUID changes made by this patch: https://github.com/mozilla-b2g/gaia/commit/15468abcba0dd2549f0c102df887a5c049b9c641
Attachment #732495 - Flags: approval-gaia-v1?
(In reply to Przemek Abratowski [:przemek] UX from comment #13)
> In my opinion the drop downs should match the regular buttons and use a
> centered text alignment. For settings screens with both regular and drop
> down buttons having an inconsistent text alignment looks strange.

Hi Przemek, 
The solution Eric is providing and you're suggesting is not right. There's a whole set of common controls designed and have been used and cannot just make a change for this particular case. Please check the existing patterns, there are a few sources where you can check:
Common controls file: https://www.dropbox.com/sh/g8wtwodhw6eb0jw/LOj09sWlOf

Wiki: https://wiki.mozilla.org/Gaia/Design/BuildingBlocks

And I am providing the written rules in the shape of formal Style Guidelines that are being iterated but will share this week.

Please if you have any doubt about the existing components, do not hesitate to ask. My skype is @vixvixy.

Thanks!
Flags: needinfo?(pabratowski)
Yes we agree it should be left aligned, we've reverted this decision in this bug https://bugzilla.mozilla.org/show_bug.cgi?id=847436.

thank you
Flags: needinfo?(pabratowski)

Comment 22

5 years ago
Comment on attachment 732495 [details]
patch for Gaia repo

removing approval requests as there are issues reported by TEF UX team
Attachment #732495 - Flags: approval-gaia-v1?
(Reporter)

Comment 23

5 years ago
(In reply to Przemek Abratowski [:przemek] UX from comment #21)
> Yes we agree it should be left aligned, we've reverted this decision in this
> bug https://bugzilla.mozilla.org/show_bug.cgi?id=847436.
> 
> thank you

Hi Pavel, can you update the drop downs to be left align (the way we have everywhere else now).  Thanks!
Status: VERIFIED → REOPENED
Flags: needinfo?(pivanov)
Resolution: FIXED → ---
Please do not reopen bugs that have patches already landed. File followups for changes you need.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 25

5 years ago
(In reply to Jason Smith [:jsmith] from comment #24)
> Please do not reopen bugs that have patches already landed. File followups
> for changes you need.

Sorry Jason, thanks for letting me know.

Pavel should I file a new bug or will this be fixed within another bug? Let me know, thanks!
(Reporter)

Comment 26

5 years ago
(In reply to Victoria Gerchinhoren from comment #20)
> (In reply to Przemek Abratowski [:przemek] UX from comment #13)
> > In my opinion the drop downs should match the regular buttons and use a
> > centered text alignment. For settings screens with both regular and drop
> > down buttons having an inconsistent text alignment looks strange.
> 
> Hi Przemek, 
> The solution Eric is providing and you're suggesting is not right. There's a
> whole set of common controls designed and have been used and cannot just
> make a change for this particular case. Please check the existing patterns,
> there are a few sources where you can check:
> Common controls file: https://www.dropbox.com/sh/g8wtwodhw6eb0jw/LOj09sWlOf
> 
> Wiki: https://wiki.mozilla.org/Gaia/Design/BuildingBlocks
> 
> And I am providing the written rules in the shape of formal Style Guidelines
> that are being iterated but will share this week.
> 
> Please if you have any doubt about the existing components, do not hesitate
> to ask. My skype is @vixvixy.
> 
> Thanks!

Hi Victoria, I'm planning to open a follow up bug for this.  Was everything besides the drop down correct?  I'm planning to only mock up layout changes and leave the drop down to the Building Blocks.  Let me know what you think. Thanks!
Flags: needinfo?(vpg)
Hey Eric,
We can open new bug
Flags: needinfo?(pivanov)
(Reporter)

Comment 28

5 years ago
created a follow up bug https://bugzilla.mozilla.org/show_bug.cgi?id=873504
Status: VERIFIED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: FIXED → INVALID
Clearing need info as this is solved, if something related comes up, please needinfo me again. Thanks.
Flags: needinfo?(vpg)
You need to log in before you can comment on or make changes to this bug.