Contextual menu doesn't have "Open link..." options

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: v.lopezg, Unassigned)

Tracking

20 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130220104816

Steps to reproduce:

1. Open any page that has pure HTML link (<a> elements with an href, not javascript actions)
2. Cmd+click on any link to bring the contextual menu


Actual results:

Firefox opened a contextual menu without the link-related options (Open in new tab/window, save link as..., etc). Instead it opened the contextual menu you get when cmd+click (or right click) on non link content (background, text) 


Expected results:

Firefox should have opened the contextual menu that contains said options.
Is this still an issue if you go through the troubleshooting steps at https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems
Flags: needinfo?(v.lopezg)
Hello Victor! 
I tested this using this example: http://www.w3schools.com/html/html_links.asp ("Try it Yourself - Examples" and hit "HTML links")
I don`t have an Apple keyboard I Used a keyboard with MS Windows logo (Windows key should take the role of cmd key).
I windows key + left click and it opens the link in a new tab, however Ctrl + left click opens the context menu.
Component: Untriaged → Menus
I get the same behavior on Chrome and Safari, with a MS Windows logo keyboard as well. So I don`t know what should be the expected result here.
(Reporter)

Comment 4

6 years ago
Sorry I didn't come back to this earlier. In my case I open the context menu with a "double tap" on a trackpad, but it's basically the same thing as ctrl+left click. The problem disappeared after restarting Firefox and I tried unsuccessfully to replicate it by restoring the session. Let me know if there's anything else I can do to help.

Thank you!
Flags: needinfo?(v.lopezg)
Thank you for the follow up. Going to close this out as works for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.