Images appear as bullets in Print Preview the 1st time it is opened (after refresh)

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: alexinbeijing, Unassigned)

Tracking

19 Branch
mozilla21
x86_64
Linux
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

When the attached page is loaded and "Print Preview" is opened from the File menu, some of the images appear as bullets (round dots). At first, I thought FF's implementation of the list-style-image CSS attribute might not be working, but then I discovered that if you simply close Print Preview and open it again (without doing anything else), all the images appear correctly.

This behavior is consistent: the first time Print Preview is opened after a page refresh, the images always appear incorrectly. Closing PP and immediately opening it again always causes the images to appear.

I have included the needed CSS and images in the attached .zip file.
Attachment #718264 - Attachment mime type: application/octet-stream → application/zip
I can reproduce the problem in FF19, 20, 21.  It works fine in Nightly 22.0a1
(2013-02-25) though.  (all on Linux)
Component: General → Print Preview
Product: Firefox → Core
I take it that FF22 isn't a stable release (yet)?
(Correct -- Nightly 22 is a build from nightly.mozilla.org, built from development trunk. The code on Nightly now will make it to release in ~18 weeks)
It would be good if we can figure out the exact bug that fixed this to make sure
it's not just a timing issue or a coincidence that makes it work on trunk.
Keywords: qawanted
Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0

Reproduced on Firefox 19.0 but it was fixed since then probably in another bug. Works for me in Firefox 21 RC (buildID: 20130512144307), latest Nightly (buildID: 20130603031140), latest Aurora (buildID: 20130603004018).
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
Testing the -aurora builds (FF21) here:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013/02/
I get this range where the problem disappeared:
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=5ce84c1fcfc7&tochange=66736a53ee17
so I'm guessing bug 816498 fixed this.
Depends on: 816498
Flags: in-testsuite?
Target Milestone: --- → mozilla21
You need to log in before you can comment on or make changes to this bug.