bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

hang if JavaScript is used to communicate with Java applet on same page

VERIFIED DUPLICATE of bug 83698

Status

Core Graveyard
Java: OJI
--
critical
VERIFIED DUPLICATE of bug 83698
17 years ago
8 years ago

People

(Reporter: gmezero, Assigned: edburns)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Watch out! Brought down my Linux box !!! - pschwartau ], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; rv:0.9) Gecko/20010505
BuildID:    20010521

When you have a web page with a Java applet, and you attempt to use JavaScript
to send data to the applet for the applet to process, Mozilla with 100% lock-up
completely, sometimes locking up the desktop as well. The only way to free-up
the lock is to issue a process kill on Mozilla.

Reproducible: Always
Steps to Reproduce:
1. Load URL
2. Click on JavaScript button/link/form element, etc...
3. that's it, now go kill that process and get your browser back.

Actual Results:  As I mentioned in the description. The browser (and all open
browser windows completely lock-up) and sometimes, the entire desktop locks-up,
so that I've had to telnet into the system from another machine to kill the
Mozilla process. Then the machine appears to run fine, and Mozilla can be
reloaded and works as if nothing happened.

Expected Results:  I expect the Java applet to produce a result based on the
input it is expecting to receive from JavaScript.

My limited educated guess is that this appears like a case where the
JavaScript/Java applet functions aren't being exposed correctly to each other,
and causing critical failure in the browser.

Three other example URLs you can look at are:
http://www.kfki.hu/~cspeter/jvm-bugs/ns6jsace.html
http://www.gamezero.com/shrines/tgpceaeiou/press_pass.html
http://www.polymer-city.com/gallery.shtml
  (this last one is the same mechanism as the GameZero page, but the transaction
happens across frames)

Additionally, this failure appears to happen to various degrees on Mac browsers
(have not seen, only told by others), and KDE's Konqueror (does not crash, but
fails to work).

In my attempts to debug the problem with both Mozilla 0.9 and Konqueror under
RH7.1, the JavaScript function is being reported "undefined" by the browsers.

This type of JavaScript/Java communication DOES WORK correctly with:
Netscape 4.76 (Linux RH7.1)
Netscape 4.77 (Win98SE)
Mozilla 0.9 (Win98SE)
Hot Java 3.0 (Win98SE)
Internet Explorer 5.X/6.X versions (Win98SE)

FWIW, I am using the Sun JRE 1.3.1 installed under both RH7.1 and Win98SE in my
above tests.

Updated

17 years ago
Keywords: hang
Summary: crash if JavaScript is used to communicate with Java applet on same page → hang if JavaScript is used to communicate with Java applet on same page

Comment 1

17 years ago
Browser, not engine --> OJI component. 

Confirming bug with 20010607xx (on Linux only, I do NOT hang on WinNT).
I believe this may be a dupe: 

bug 84412   Browser lockup on Java initialization (but this affects WinNT...) 
bug 83698  (Unix) JavaScript to Java won't work unless open Java console first
bug 77600   Java to JavaScript does not work (fix just checked in today...)

cc'ing Xiaobin, Patrick -
Assignee: rogerl → edburns
Status: UNCONFIRMED → NEW
Component: Javascript Engine → OJI
Ever confirmed: true
QA Contact: pschwartau → shrir

Updated

17 years ago
Depends on: 83698

Comment 2

17 years ago
Watch out! While trying this in Mozilla, this brought down my Linux box !!!
Whiteboard: [Watch out! Brought down my Linux box !!! - pschwartau ]

Comment 3

17 years ago
I tried this experiment, again using my Linux build. I went to the URL,
but before I clicked on the select box to make the applet change color,
I tried to bring up the Java Console first. This is a trick that makes
some recent bugs "go away" (see bug 84864, for example).

However, in this case when I try that, Mozilla crashes and I get this 
error in the debug console:


                  Internal error: Null plugin manager


Comment 4

17 years ago
I think this bug is a dup of 83698 Joe is fixing.
(Assignee)

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 83698 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
Marking verified duplicate -
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.