history.go(-tooFar) disables session history

VERIFIED DUPLICATE of bug 84519

Status

()

Core
Document Navigation
P3
major
VERIFIED DUPLICATE of bug 84519
17 years ago
10 years ago

People

(Reporter: Jesse Ruderman, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
mozilla0.9.4
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Steps to reproduce:
1. Open a new window to your home page.
2. Click a link.
3. Type javascript:history.go(-2) into the location bar and hit enter.
4. Try to navigate using the back and forward buttons.

Results:
- Navigating session history using the back and forward buttons no longer works.
- javascript:history.go(-1) to go back one page no longer works.

Expected: history.go(-2) goes back two pages, or to the first page visited if
going back two pages would be too far.  (It should not throw an exception,
because then the page could figure out how long your session history list is
using try/catch in a loop.)

This bug can be triggered accidentally if a site has a "back" link that uses
history.go(-1) but the page was the first loaded in a window.

I'm marking this bug as major because it allows a page to cripple a browser
window and possibly cause data loss.

See also bug 84519, after doing history.go(+tooFar), must press back button many
times to go back.
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla0.9.3

Comment 1

17 years ago
Not platform specific
OS: Windows NT → All
Hardware: PC → All

Comment 2

17 years ago
Missed the 0.9.3 train.  Since the back button not working (as in, disabled) was
a major pr1 complaint, though, I think we should seriously consider this for 0.9.4.
Keywords: nsCatFood
Target Milestone: mozilla0.9.3 → mozilla0.9.4
The underlying problem is the same as in 84519

*** This bug has been marked as a duplicate of 84519 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
VERIFIED based on comments.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.