Firefox 19.0 pdf viewer ignores pdf encryption

RESOLVED DUPLICATE of bug 792816

Status

()

Firefox
PDF Viewer
RESOLVED DUPLICATE of bug 792816
5 years ago
5 years ago

People

(Reporter: kashtan99@yahoo.com, Unassigned)

Tracking

19 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

We have web application which is generating pdf document and encrypts it  using iText PdfEncryptor.encrypt(...) so some users are not allowed to print out this document. It was successfully working for several years.


Actual results:

Last week after new update FireFox pdf viewers just ignores this encryption completely and show Print button on pdf document disregarding page encryption. Our application is  working properly in other browsers, for example IE.


Expected results:

Pdf viewer should not ignore pdf encryption, generated pdf should not have print button for users who are not supposed to print them according our code.
(Reporter)

Updated

5 years ago
Component: Untriaged → PDF Viewer
Copy & print permission support is deliberately removed by the request from the Firefox product team.
https://bugzilla.mozilla.org/show_bug.cgi?id=792816#c12
Please start a newsgroup discussion about reintroducing the feature.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 792816
You need to log in before you can comment on or make changes to this bug.