Galaxy Fit should be not be blacklisted on google play for firefox beta

RESOLVED FIXED

Status

()

RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: lord.dhruv, Unassigned)

Tracking

20 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331



Actual results:

Galaxy fit (GT-S5670) is an android armv6 device with 384 mb ram(280mb user availabe) and 600Mhz processor with a QVGA display.According to the release notes firefox 20 adds support for QVGA display and 384mb ram(firefox 19 added support for 600Mhz).
Thus the device should have been compatible on google play website and app.


Expected results:

A message displayed that the app was incompatible with my Galaxy Fit and on the app it never showed.
(Reporter)

Comment 1

6 years ago
Um the actual and expected seems to have switched places.
(Reporter)

Updated

6 years ago
OS: Windows 8 → Android
Hardware: x86 → ARM
The devices aren't blocked but are currently unsupported devices due to manifest settings in our APK: Galaxy Fit(GT-S5670), Galaxy Fit(GT-S5670B) and the Galaxy Fit(GT-S5670L). Usually the case being either the device is running Android 2.1 or lower or that OpenGL ES 2.0 is not supported. Usually any Android system info program will tell you the later.
Ah I believe the requirement to support small screens with LDPI is the issue here.
http://mxr.mozilla.org/mozilla-beta/source/mobile/android/base/AndroidManifest.xml.in#12

I dont think we have support yet.
(Reporter)

Comment 4

6 years ago
(In reply to Aaron Train [:aaronmt] from comment #3)
> Ah I believe the requirement to support small screens with LDPI is the issue
> here.
> http://mxr.mozilla.org/mozilla-beta/source/mobile/android/base/
> AndroidManifest.xml.in#12
> 
> I dont think we have support yet.

(In reply to Aaron Train [:aaronmt] from comment #2)
> The devices aren't blocked but are currently unsupported devices due to
> manifest settings in our APK: Galaxy Fit(GT-S5670), Galaxy Fit(GT-S5670B)
> and the Galaxy Fit(GT-S5670L). Usually the case being either the device is
> running Android 2.1 or lower or that OpenGL ES 2.0 is not supported. Usually
> any Android system info program will tell you the later.

well the condition of android version and opengl is certainly met(android 2.3 officially ,opengl ES 2.0) as for ldpi resolution isnt version 20 suppose to(and its release as stating) support Qvga resolution that is 320x240 which is the resolution for these devices so seems to be confusing for me is 20 not supporting qvga or is it?
also which version will be planned to add these features (currently)...?
I've emailed some folks for clarification.
(Reporter)

Comment 6

6 years ago
(In reply to Aaron Train [:aaronmt] from comment #5)
> I've emailed some folks for clarification.

Thank You.

Updated

6 years ago
tracking-firefox20: --- → ?

Updated

6 years ago
Depends on: 845335
If the theory holds in bug 845335; this should be fixed with the next Beta release tomorrow (Friday) afternoon PST.
(In reply to Aaron Train [:aaronmt] from comment #7)
> If the theory holds in bug 845335; this should be fixed with the next Beta
> release tomorrow (Friday) afternoon PST.

Theory is *not* holding as of Friday 1 March 2p.m. PST. 

My 384MB RAM, 600MHz, QVGA ARMv6 phone, Samsung GT-S5570 aka Galaxy Mini QVGA doesn't get offered Firefox Beta in the Google Play store. I think this phone should be offered FF 20 (which is the current Firefox Beta) according to what I have heard and the PRD: 

https://wiki.mozilla.org/Mobile/Fx20_PRD#ARMv6_expanded_support:_600MHz.2C_384MB.2C_QVGA

Am I right?
(In reply to Aaron Train [:aaronmt] from comment #7)
> If the theory holds in bug 845335; this should be fixed with the next Beta
> release tomorrow (Friday) afternoon PST.

Update: It will be the following Beta, first week of March.
Let's verify bug 845335 in beta 3 and then dupe this to that bug if all goes as expected.
Are you able to find Firefox Beta and download it now on Google Play?
Flags: needinfo?(lord.dhruv)
(Reporter)

Comment 12

6 years ago
(In reply to Aaron Train [:aaronmt] from comment #11)
> Are you able to find Firefox Beta and download it now on Google Play?

yes, sorry didn't confirm it earlier.

but a new bug has appeared.the app that gets downloaded from the playstore causes a system freeze along with a reboot but the beta4 multi apk from the FTP servers doesn't(actually works wonderfully) and this has affected a lot of gFit owners (not just me).will file a seperste big with a logcat soon.
Flags: needinfo?(lord.dhruv)
(In reply to lord.dhruv from comment #12)
> (In reply to Aaron Train [:aaronmt] from comment #11)
> > Are you able to find Firefox Beta and download it now on Google Play?
> 
> yes, sorry didn't confirm it earlier.

Great, thanks for checking.

> but a new bug has appeared.the app that gets downloaded from the playstore
> causes a system freeze along with a reboot but the beta4 multi apk from the
> FTP servers doesn't(actually works wonderfully) and this has affected a lot
> of gFit owners (not just me).will file a seperste big with a logcat soon.

Let's open a new bug for this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
tracking-firefox20: ? → ---
You need to log in before you can comment on or make changes to this bug.