Manifest change for supporting small-screens (LDPI)

VERIFIED FIXED in Firefox 20

Status

()

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: aaronmt, Assigned: bnicholson)

Tracking

Trunk
Firefox 22
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox20+ verified, firefox21+ fixed, firefox22 fixed, relnote-firefox 20+)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
http://mxr.mozilla.org/mozilla-beta/source/mobile/android/base/AndroidManifest.xml.in#12

I believe this needs to be toggled otherwise devices trying to download Firefox will get 'unsupported due to manifest' messages on Google Play.
Blocks: 845307
tracking-firefox19: --- → ?

Updated

6 years ago
tracking-firefox20: --- → ?
The first opportunity we'll have to fix this is FF20b3 (going to build on Tuesday). Mark/Brad probably won't be able to address this before Monday due to MWC, but it's possible that Matt can help push a patch along (or tell us why this isn't the correct path forward).
tracking-firefox19: ? → ---
(Reporter)

Comment 2

6 years ago
Context in email I sent out, bug 845307 was filed from a user with a device meeting system requirements but not meeting manifest spec on Google Play (unable to download Firefox). I believe the store is looking at http://mxr.mozilla.org/mozilla-beta/source/mobile/android/base/AndroidManifest.xml.in#12
and blocking the device; Galaxy Fit (320x240 QVGA). 

Fx20 supposedly supports QVGA displays (outlined in the release-notes) including 320x240 (~120 LDPI) as far as I know that's Android defined as 'small-screen'; but as far as I'm aware we don't support LDPI yet (Sriram says MDPI is downscaled, but I thought we were waiting on bug 795408). If we support QVGA; 480x640 (HDPI), I believe we still need to flip that manifest setting.

http://developer.android.com/guide/practices/screens_support.html (was using Table 3 near the bottom for info)
(Assignee)

Comment 3

6 years ago
Created attachment 719216 [details] [diff] [review]
Add back support for small screens
Assignee: nobody → bnicholson
Status: NEW → ASSIGNED
Attachment #719216 - Flags: review?(mark.finkle)
Comment on attachment 719216 [details] [diff] [review]
Add back support for small screens

Let's hope we have all the required resources for this to work...
Attachment #719216 - Flags: review?(mark.finkle) → review+
(Reporter)

Comment 5

6 years ago
As far as I can recall, the only suck with small-screens is bug 840593
https://hg.mozilla.org/mozilla-central/rev/caabb125d096
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
(Assignee)

Comment 8

6 years ago
Comment on attachment 719216 [details] [diff] [review]
Add back support for small screens

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 805191
User impact if declined: phones with small screens can't use Fennec
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): unknown - have no small screen phones to test
String or UUID changes made by this patch: none
Attachment #719216 - Flags: approval-mozilla-beta?
Attachment #719216 - Flags: approval-mozilla-aurora?
status-firefox20: --- → affected
status-firefox21: --- → affected
status-firefox22: --- → fixed
tracking-firefox20: ? → +
tracking-firefox21: --- → +
relnote-firefox: --- → ?
Comment on attachment 719216 [details] [diff] [review]
Add back support for small screens

Approving this for uplift assuming that QA will find a device (or a community member) who can verify this.
Attachment #719216 - Flags: approval-mozilla-beta?
Attachment #719216 - Flags: approval-mozilla-beta+
Attachment #719216 - Flags: approval-mozilla-aurora?
Attachment #719216 - Flags: approval-mozilla-aurora+
We're waiting for verification here in order to resolve bug 845307.
Keywords: qawanted, verifyme
firefox 20 beta 4 is offered to me by google play store on my Samsung Galaxy Mini (ARMv6, 384MB RAM, QVGA), so i guess that's one data point towards setting this bug to verified. What are the criteria? Two or more armv6 384mb, qvga devices tested successfully? or is 1 sufficient?
(Reporter)

Updated

6 years ago
Status: RESOLVED → VERIFIED
status-firefox20: fixed → verified
Keywords: qawanted
This is already in the relnotes as "System requirements have been lowered to 384MB of RAM and QVGA displays"
relnote-firefox: ? → 20+
(Reporter)

Updated

6 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.