cannot set attachments to open for .doc and docx

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: anjeyelf, Unassigned)

Tracking

17 Branch
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130201065344

Steps to reproduce:

Using Windows Vista
Thunderbird 17.0.3
program Microsoft Office 2007 installed.

Previously I received a .doc attachment.
Right click, select open, then open with, browse, chose MSWord and do this from now on.
This appears under:
Tools > Options > Attachments > Incoming tab
content type:Microsoft Office word 97 - 2003 document(application/msword, .doc)
All ,doc documents open ok.

then I receive a .docx document.
Right click, select open, then open with, browse, 




Actual results:

no option to choose MSWord, only other products eg: openoffice
click on the second 'browse'
locate Microsoft Office, locate winword.exe
click on open
small window now says:
Open with Microsoft Office Word

the option to 'do this automatically for files like this from now on'
is greyed out, so cannot be chosen.
When I click on ok MSWord opens showing the document as read only.
So I can open it, but it is long winded as option should be available



Expected results:

when I right click on docx and choose to open:
there should be an option to choose MSWord.
after locating the winword.exe to open the document:
the option to 'do this automatically for files like this from now on' needs to be available. It is not available - it is greyed out.

In Tools > Options > Attachments > Incoming tab
The action for opening attachments with a .docx extension should be added to the .doc, but there is no means of doing this.

I have MSOffice 2007 on the computer which can save as different version eg: .doc and .docx

Thunderbird needs to be able to add .doc and .docx  to the Incoming tab, so that future attachments can be opened.
(Reporter)

Comment 1

6 years ago
Update since last posting:

So I did the following:

Under the Control panel >Default programs > set associations
noted that .docx was described as a DOCX file and not a Word 2007 document.

Run > Regedit

HKEY_CLASSES_ROOT\Word.Document.12\shell\Open
the ddexec sub key had e a value of :
[REM _DDE_Direct][FileOpen("%1")]

the command sub key had a value of:
C:\PROGRA~1\MICROS~3\Office12\Moc.exe "%1"

I changed this to:
"C:\Program Files\Microsoft Office\Office12\WINWORD.EXE" /n /dde "%1"

Then located a .docx document saved to my computer and right click chose 'open with' and choose a default program.
select 'Microsoft Office Word' and 'always use the selected program to open this kind of file' and clicked on Ok.

Then rechecked the default programs > set associations
noted that .docx was now described as a Word 2007 document and not a DOCX file.

Then in Thunderbird:
locate an email with a .docx and choose to open with, now MS Office Word is an option, select it and select to always open with this program.

under Tools > Options > Attachments> Incoming tab
now displays:
Microsoft Office Word 97-2003 - Use Microsoft Office Word (default)
Word 2007 Document - Use Microsoft Office Word (default)

the top one opens .doc
the lower opens .docx

This has now fixed this issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.