Search UI: File result to POP acct level crashes.

VERIFIED FIXED in mozilla0.9.2

Status

P2
major
VERIFIED FIXED
18 years ago
11 years ago

People

(Reporter: laurel, Assigned: naving)

Tracking

({crash})

Trunk
mozilla0.9.2
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
Using jun7 commercial branch
Assume it happens on trunk, too.

I don't know if this is due to the lack of fix for bug 74406 (which might
prohibit filing to account level). Note that we pushed target milestone for
74406 to 0.9.3 (past commercial RTM).

Because of lack of fix for 74406 it is hard to select the account level, but it
can be done by accident (I did).

Problem description:  If you file a search result to POP account acct level, a
crash occurs.  Note: filing to IMAP acct level will error with "mailbox doesn't
exist".

Steps:
1.  Go to mail window, login to POP account.
2.  Search|Search Mail/News Messages, initiate a simple search for the POP
account which will yield matches.
3.  Select a message in the search results pane and click File.  Select the POP
account level as the destination for the move.  Note:  the account level is not
specified with text, but there is a selectable space above the separator.

Result: crash occurs.
(Reporter)

Comment 1

18 years ago
Created attachment 37574 [details]
TB 31456194
(Reporter)

Updated

18 years ago
Keywords: crash, nsbeta1
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 2

18 years ago
CLarification:  Only POP and Local Folders acct level as file search result
destinations crash.  Newsgroups or news servers (see bug 76401) and Webmail acct
levels don't error, don't crash, and don't do anything adverse.  AOL acct and
IMAP acct levels error and don't do anything advers.
(Assignee)

Comment 3

18 years ago
I will attach a patch to prevent the crash which is the right thing to do for 
now. Solving this problem from the FE may take more time because the XUL 
templates are almost the same for both 3-pane and search window, but it is not
working for search window.
(Assignee)

Comment 4

18 years ago
Created attachment 37579 [details] [diff] [review]
proposed fix
(Assignee)

Comment 5

18 years ago
assert and return if destination folder is rootfolder. Need r & sr from bhuvan 
and david. 

Comment 6

18 years ago
Yes. We should atleast prevent the crash from occuring in the current UI.
Though, it is unlikely that any user is going to select the account level due to
existing UI mess up, it will be nice to have protection in the backend to
prevent any filing activities at account level. I am hoping to find possible
solutions for the File button template UI weirdness once my current bugs are done...

bhuvan

Comment 7

18 years ago
moving to 0.9.2
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9.2

Comment 8

18 years ago
r=bhuvan
Whiteboard: [nsbeta1+]
Target Milestone: mozilla0.9.2 → ---

Comment 9

18 years ago
hey, you overwrote my changes!
Priority: -- → P2
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9.2

Comment 10

18 years ago
have you checked that this works? comparing two comptr's for equality like this?
If so, sr=bienvenu and I notice you're checking in that null check for newHdr,
which is a good thing too.
(Assignee)

Comment 11

18 years ago
Created attachment 37594 [details] [diff] [review]
revised patch. grrrr!
(Assignee)

Comment 12

18 years ago
better fix. I have seen places where we do compare for comptrs equality and it 
works!!

Comment 13

18 years ago
I don't know that it doesn't work, but I just wanted to be sure. sr=bienvenu

Comment 14

18 years ago
Sorry Scott. I promise that was an accident..!

Updated

18 years ago
Blocks: 83989
a= asa@mozilla.org for checkin to the trunk.
(on behalf of drivers)
(Assignee)

Comment 16

18 years ago
fix checked in. 
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 17

18 years ago
OK, no crash, using june 14 commercial trunk builds: win98, mac OS 9.0, linux rh6.2
Status: RESOLVED → VERIFIED
(Assignee)

Comment 18

18 years ago
*** Bug 83886 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Updated

11 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.