Closed Bug 845511 Opened 10 years ago Closed 10 years ago

Regular Tabs, Private Tabs, and Remote Tabs buttons are missing accessibility labels

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox20+ verified, firefox21 verified, firefox22 verified, fennec20+)

VERIFIED FIXED
Firefox 22
Tracking Status
firefox20 + verified
firefox21 --- verified
firefox22 --- verified
fennec 20+ ---

People

(Reporter: MarcoZ, Assigned: sriram)

References

Details

(Keywords: access)

Attachments

(1 file, 2 obsolete files)

The buttons for regular tabs, private tabs and remote tabs do not have proper accessibility contentDescription associations. Also, it is not indicated which is the active tab. The buttons I'm referring to are those in the tabs panel at the top to the left of the "new tab" button.

While we're here, it should also be made sure that all UI elements are accessible, like the "Close all" button which I have not seen with TalkBack at all.
tracking-fennec: --- → ?
Sriram - Let's try to get a patch and uplift for Beta... soon
Assignee: nobody → sriram
tracking-fennec: ? → 20+
@Kevin, Firefox for desktop is not affected by this bug, it is specifically one for Firefox for Android's UI.
Attached patch Patch (obsolete) — Splinter Review
setContentDescription() added to the buttons.
Attachment #719711 - Flags: review?(mark.finkle)
Attached patch Patch: Option 2 (obsolete) — Splinter Review
This is a bit cleaner approach.
Attachment #719715 - Flags: review?(mark.finkle)
Attached patch Patch: Option 2Splinter Review
Option 2 feels better (had to refresh the patch).
Attachment #719711 - Attachment is obsolete: true
Attachment #719715 - Attachment is obsolete: true
Attachment #719711 - Flags: review?(mark.finkle)
Attachment #719715 - Flags: review?(mark.finkle)
Attachment #719717 - Flags: review?(mark.finkle)
Comment on attachment 719717 [details] [diff] [review]
Patch: Option 2

Yeah, I agree. Clean.
Attachment #719717 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/8e091dcbd424
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Verified fixed in the 2013-03-01 Nightly build (Firefox 22).
Comment on attachment 719717 [details] [diff] [review]
Patch: Option 2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New tab panels (Private browsing tabs etc.)
User impact if declined: Blind users won't know which button activates which type of tabs.
Testing completed (on m-c, etc.): Yes.
Risk to taking this patch (and alternatives if risky): None, simple addition of contentDescriptions.
String or UUID changes made by this patch: None. Strings that are spoken are already present.
Attachment #719717 - Flags: approval-mozilla-beta?
Attachment #719717 - Flags: approval-mozilla-aurora?
Attachment #719717 - Flags: approval-mozilla-beta?
Attachment #719717 - Flags: approval-mozilla-beta+
Attachment #719717 - Flags: approval-mozilla-aurora?
Attachment #719717 - Flags: approval-mozilla-aurora+
Depends on: 847634
Verified fix on Aurora 21.0a2 2013-03-14 and Firefox Mobile 20 beta 5 on the Samsung Galaxy Tab 2 7.0 (Android 4.1.1)
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.