If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Settings] In Display, undoing "adjust automatically" and tapping on the brightness will not change the brightness, it will bring up the number keypad

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Settings
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: nhirata, Assigned: rudyl)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 affected, b2g18-v1.0.1 unaffected)

Details

## Environment :
Mercurial-Information:"mozilla-central" revision="aaefec5d34f8" Mercurial-Information:"integration/gaia-central" revision="ff0a35cefd32"
BuildID : 2013-02-26-03-10-44
Unagi
  
## Repro :
1. go to settings
2. go to display
3. unselect the "adjust automatically"
4. tap on the brightness slide

## Expected :
slide will adjust; brightness will change

## Actual :
number keyboard appears; brightness does not change

## Note :
Occurs in v1 train,
Mercurial-Information: 
"releases/mozilla-b2g18" revision="d683eefee3f0"
"integration/gaia-v1-train" revision="b60b10ae5894"

but not in 1.0.1
Mercurial-Information: 
"releases/mozilla-b2g18_v1_0_1" revision="819504e27351"
"integration/gaia-1_0_1" revision="440f9ac49d59"/>
status-b2g18: --- → affected
status-b2g18-v1.0.1: --- → unaffected
blocking-b2g: --- → leo?

Comment 2

5 years ago
Andrew said this may not be reproducible, but if it is, we need to find the regression and kill it.
Assignee: nobody → ehung
blocking-b2g: leo? → leo+
Keywords: regression
since ehung is busy for the week, reassign to rlu.
Assignee: ehung → rlu

Updated

5 years ago
QA Contact: atsai
Could the newly landed <input type=range> support in Gecko cause this?

Rudy, could you land a quick patch on that?
QA Contact: atsai
Hi all,

I could not reproduce this issue with the latest v1-train,
https://pvtbuilds.mozilla.org/pub/mozilla.org/b2g/nightly/mozilla-b2g18-unagi/2013/03/2013-03-18-23-02-04/
<input type=range> support is in bug 344618, and I think it has not landed yet.


I guess, this might be one of the regressions that was caused by Settings app. performance improvement.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.