Closed Bug 845623 Opened 7 years ago Closed 6 years ago

Intermittent services/common/tests/unit/test_storage_server.js | test failed (with xpcshell return code: 0), see following log: | 412 == 204 | 2147500036 - See following stack:

Categories

(Cloud Services :: Firefox: Common, defect)

x86
Linux
defect
Not set

Tracking

(firefox24 fixed, firefox25 fixed, firefox26 fixed)

RESOLVED FIXED
mozilla26
Tracking Status
firefox24 --- fixed
firefox25 --- fixed
firefox26 --- fixed

People

(Reporter: RyanVM, Assigned: gps)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=20115593&tree=Mozilla-Inbound

Ubuntu 12.04 mozilla-inbound debug test xpcshell on 2013-02-26 11:50:28 PST for push 729d41f6743b
slave: tst-linux32-ec2-008

12:47:47     INFO -  TEST-INFO | /builds/slave/test/build/tests/xpcshell/tests/services/common/tests/unit/test_storage_server.js | running test ...
12:47:50  WARNING -  TEST-UNEXPECTED-FAIL | /builds/slave/test/build/tests/xpcshell/tests/services/common/tests/unit/test_storage_server.js | test failed (with xpcshell return code: 0), see following log:
12:47:50  WARNING -  This is a harness error.
12:47:50     INFO -  >>>>>>>
12:47:50     INFO -  ### XPCOM_MEM_LEAK_LOG defined -- logging leaks to /tmp/tmp6GApal/runxpcshelltests_leaks.log
12:47:50     INFO -  TEST-INFO | (xpcshell/head.js) | test 1 pending
12:47:50     INFO -  TEST-INFO | (xpcshell/head.js) | test 2 pending
12:47:50     INFO -  TEST-INFO | (xpcshell/head.js) | test 2 finished
12:47:50     INFO -  TEST-INFO | (xpcshell/head.js) | running event loop
12:47:50     INFO -  TEST-INFO | (xpcshell/head.js) | test 2 pending
12:47:50     INFO -  TEST-INFO | /builds/slave/test/build/tests/xpcshell/tests/services/common/tests/unit/test_storage_server.js | Starting test_creation
12:47:50     INFO -  Ensure a simple server can be created.
12:47:50     INFO -  TEST-PASS | /builds/slave/test/build/tests/xpcshell/tests/services/common/tests/unit/test_storage_server.js | [test_creation : 121] true == true
12:47:50     INFO -  Started on 8080
12:47:50     INFO -  TEST-PASS | /builds/slave/test/build/tests/xpcshell/tests/services/common/tests/unit/test_storage_server.js | [test_creation/< : 125] 8080 == 8080
12:47:50     INFO -  TEST-INFO | (xpcshell/head.js) | test 2 finished
12:47:50     INFO -  TEST-INFO | (xpcshell/head.js) | test 2 pending
12:47:50     INFO -  TEST-INFO | (xpcshell/head.js) | test 2 finished
12:47:50     INFO -  TEST-INFO | (xpcshell/head.js) | test 2 pending
12:47:50     INFO -  TEST-INFO | /builds/slave/test/build/tests/xpcshell/tests/services/common/tests/unit/test_storage_server.js | Starting test_synchronous_start
12:47:50     INFO -  Ensure starting using startSynchronous works.
12:47:50     INFO -  TEST-INFO | (xpcshell/head.js) | test 2 finished
12:47:50     INFO -  TEST-INFO | (xpcshell/head.js) | test 2 pending
12:47:50     INFO -  TEST-INFO | (xpcshell/head.js) | test 2 finished
12:47:50     INFO -  TEST-INFO | (xpcshell/head.js) | test 2 pending
12:47:50     INFO -  TEST-INFO | /builds/slave/test/build/tests/xpcshell/tests/services/common/tests/unit/test_storage_server.js | Starting test_url_parsing

12:47:51     INFO -  TEST-PASS | /builds/slave/test/build/tests/xpcshell/tests/services/common/tests/unit/test_storage_server.js | [test_bso_if_unmodified_since : 362] null == undefined
12:47:51  WARNING -  TEST-UNEXPECTED-FAIL | /builds/slave/test/build/tests/xpcshell/tests/services/common/tests/unit/test_storage_server.js | 412 == 204 - See following stack:
12:47:51  WARNING -  This is a harness error.
12:47:51     INFO -  JS frame :: /builds/slave/test/build/tests/xpcshell/head.js :: do_throw :: line 461
12:47:51     INFO -  JS frame :: /builds/slave/test/build/tests/xpcshell/head.js :: do_report_result :: line 563
12:47:51     INFO -  JS frame :: /builds/slave/test/build/tests/xpcshell/head.js :: _do_check_eq :: line 573
12:47:51     INFO -  JS frame :: /builds/slave/test/build/tests/xpcshell/head.js :: do_check_eq :: line 580
12:47:51     INFO -  JS frame :: /builds/slave/test/build/tests/xpcshell/tests/services/common/tests/unit/test_storage_server.js :: test_bso_if_unmodified_since :: line 363
12:47:51     INFO -  JS frame :: /builds/slave/test/build/tests/xpcshell/head.js :: _run_next_test :: line 1119
12:47:51     INFO -  JS frame :: /builds/slave/test/build/tests/xpcshell/head.js :: .run :: line 428
12:47:51     INFO -  native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
12:47:51     INFO -  TEST-INFO | (xpcshell/head.js) | exiting test
12:47:51  WARNING -  TEST-UNEXPECTED-FAIL | /builds/slave/test/build/tests/xpcshell/head.js | 2147500036 - See following stack:
12:47:51  WARNING -  This is a harness error.
12:47:51     INFO -  JS frame :: /builds/slave/test/build/tests/xpcshell/head.js :: do_throw :: line 461
12:47:51     INFO -  JS frame :: /builds/slave/test/build/tests/xpcshell/head.js :: _run_next_test :: line 1121
12:47:51     INFO -  JS frame :: /builds/slave/test/build/tests/xpcshell/head.js :: .run :: line 428
12:47:51     INFO -  native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
12:47:51     INFO -  TEST-INFO | (xpcshell/head.js) | exiting test
12:47:51     INFO -  TEST-INFO | (xpcshell/head.js) | test 2 finished
12:47:51     INFO -  !!! error running onStopped callback: TypeError: callback is not a function
12:47:51     INFO -  WARNING: nsExceptionService ignoring thread destruction after shutdown: file ../../../xpcom/base/nsExceptionService.cpp, line 167
12:47:51     INFO -  WARNING: NS_ENSURE_TRUE(compMgr) failed: file nsComponentManagerUtils.cpp, line 58
12:47:51     INFO -  WARNING: OOPDeinit() without successful OOPInit(): file ../../../toolkit/crashreporter/nsExceptionHandler.cpp, line 2274
12:47:51     INFO -  nsStringStats
12:47:51     INFO -   => mAllocCount:           3628
12:47:51     INFO -   => mReallocCount:          286
12:47:51     INFO -   => mFreeCount:            3628
12:47:51     INFO -   => mShareCount:           8820
12:47:51     INFO -   => mAdoptCount:            241
12:47:51     INFO -   => mAdoptFreeCount:        241
12:47:51     INFO -  <<<<<<<
See Also: → 902089
Duplicate of this bug: 902089
We were accessing a potentially different timestamp than what we should
have been. Please r+ if this makes the failure go away.
Attachment #792577 - Flags: review?(gbrown)
Assignee: nobody → gps
BTW, the suggested patch in bug 902089 won't work. This test is explicitly testing a boundary condition. The patch in bug 902089 loosens the boundary condition test. Furthermore, it still leaves open a window for an intermittent failure due to timing. This patch "pins" the tested value to the proper timestamp.
Comment on attachment 792577 [details] [diff] [review]
Intermittent failure in test_storage_server.js

Review of attachment 792577 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks -- this is an effective fix for the Android x86 emu failure.
Attachment #792577 - Flags: review?(gbrown) → review+
https://hg.mozilla.org/mozilla-central/rev/2ec747c7385f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
You need to log in before you can comment on or make changes to this bug.