@invalid rule doesn't cause @import to be dropped

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: Hixie (not reading bugmail), Assigned: Pierre Saslawsky)

Tracking

({css1, regression, testcase})

Trunk
x86
Linux
css1, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
STEPS TO REPRODUCE
   @invalid rule;
   @import "stylesheet";

ACTUAL RESULTS
   Stylesheet imported.

EXPECTED RESULTS
   The @import; rule should be dropped since it is in an invalid position. The 
   CSSOM should treat it as an unknown rule.
(Reporter)

Updated

17 years ago
Keywords: css1, regression, testcase
OS: Windows 2000 → Linux
Whiteboard: [Hixie-P2]
(Reporter)

Comment 1

17 years ago
After speaking with dbaron and studying the spec, we have come to the conclusion
that this bug is invalid.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Summary: @invalid rule; doesn't cause @import to be dropped → @invalid rule doesn't cause @import to be dropped
Whiteboard: [Hixie-P2]
(Reporter)

Comment 2

17 years ago
<dbaron> VERIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.