Incorrect font encoding in pdf annotations of pole-emploi.fr documents

VERIFIED FIXED in Firefox 31

Status

()

Firefox
PDF Viewer
P3
major
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: NicolasWeb, Unassigned)

Tracking

unspecified
Firefox 31
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox31 verified)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 718899 [details]
pdf fx 19 bug-no text displayed.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130218103317

Steps to reproduce:

Connect to pole-emploi.fr
Login
Send a form
click on the returned (result) link that open a new tab with built-in pdf viewer

Pole-emploi.fr is a french institutionnal site that unemployed people need to use (by law).


Actual results:

No text was shown, only the left logo


Expected results:

It should have shown approx 10 lines of text.
with the same file saved and open with ubuntu 12.04 pdf reader it works well
(Reporter)

Updated

5 years ago
Severity: normal → major
Component: Untriaged → PDF Viewer
(Reporter)

Comment 1

5 years ago
Created attachment 718900 [details]
Expected file's content rendering
(Reporter)

Updated

5 years ago
OS: Linux → All
Hardware: x86_64 → All
(Reporter)

Comment 2

5 years ago
OOooops I forget to mention that it's a regression since pdf view has been enable against pdf reader plug-in
Nicolas, 

when loading such a pdf, could you open the Console and copy here the eventual logs that appear? It may give us the info about what feature is missing.

Updated

5 years ago
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering][pdfjs-f-need-info]
(Reporter)

Comment 4

5 years ago
Jean-Yves,

Here are the logs (in French) when I load a pole-emploi's pdf :
[12:17:40,904] POST https://www6.pole-emploi.fr/atte/pdf/attsival.asp [HTTP/1.1 200 OK 281ms]
[12:17:41,518] GET https://www6.pole-emploi.fr/pdf_temp/Unidialog_70880599_1363087060912.pdf [HTTP/1.1 200 OK 312ms]
[12:17:41,576] Pseudo-classe ou pseudo-élément « -webkit-full-screen » inconnu.  Jeu de règles ignoré suite à un mauvais sélecteur. @ resource://pdf.js/web/viewer.css:45
[12:17:41,576] Pseudo-classe ou pseudo-élément « fullscreen » inconnu.  Jeu de règles ignoré suite à un mauvais sélecteur. @ resource://pdf.js/web/viewer.css:67
[12:17:41,577] Erreur d'analyse de la valeur pour « background-image ».  Déclaration abandonnée. @ resource://pdf.js/web/viewer.css:245
[12:17:41,578] Propriété « box-sizing » inconnue.  Déclaration abandonnée. @ resource://pdf.js/web/viewer.css:808
[12:17:41,578] Pseudo-classe ou pseudo-élément « -webkit-inner-spin-button » inconnu.  Jeu de règles ignoré suite à un mauvais sélecteur. @ resource://pdf.js/web/viewer.css:865
[12:17:41,579] Propriété « -moz-box-shadow » inconnue.  Déclaration abandonnée. @ resource://pdf.js/web/viewer.css:1046
[12:17:41,579] Erreur d'analyse de la valeur pour « background ».  Déclaration abandonnée. @ resource://pdf.js/web/viewer.css:1109
[12:17:41,579] Couleur attendue, mais « top » trouvé.  Erreur d'analyse de la valeur pour « background ».  Déclaration abandonnée. @ resource://pdf.js/web/viewer.css:1114
[12:17:41,579] Pseudo-classe ou pseudo-élément « selection » inconnu.  Jeu de règles ignoré suite à un mauvais sélecteur. @ resource://pdf.js/web/viewer.css:1194
[12:17:41,579] Propriété « -moz-border-radius » inconnue.  Déclaration abandonnée. @ resource://pdf.js/web/viewer.css:1207

If you need more, feel free to ask me ;-)

Brendan : I'm not sure it's clear in my english translation : it occurs in a French *State* website that *must* be used by unemployed people (citizens) to get they money (it's for an state official pdf-paper). Now there is 3.17 billion unemployed people in France, so I believe this bug touch billion people. I don't know the guides lines to set priority, but I think in a subjective way that it's more critical than P3.
Without a test case it is very hard to fix the issue.  Would you be comfortable sharing the PDF directly with only me and one of my colleagues(Yury Delendik)? If yes, my email is bdahl@mozilla.com.
(Reporter)

Comment 6

5 years ago
That's OK. I sent you an email on march 14th at 10:18.

Updated

5 years ago
Whiteboard: [pdfjs-c-rendering][pdfjs-f-need-info] → [pdfjs-c-rendering][pdfjs-f-need-info][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/3306

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Depends on: 878897
Resolution: --- → FIXED
Character on some annotations are not properly decoded. Re-opening with different title.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
Summary: Empty pdf of pole-emploi.fr (institutional web service site) → Incorrect font encoding in pdf annotations of pole-emploi.fr documents
Whiteboard: [pdfjs-c-rendering][pdfjs-f-need-info][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/3306 → [pdfjs-c-rendering][pdfjs-d-font-conversion]

Updated

4 years ago
Duplicate of this bug: 948951

Updated

4 years ago
Depends on: 990852
Target Milestone: --- → Firefox 31

Updated

4 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED
Using PDF attached to bug 948951 (https://bug948951.bugzilla.mozilla.org/attachment.cgi?id=8345897) I see that correct characters are now displayed. However, formatting seems to be missing, and the following errors still display in the console:
"Warning: AcroForm/XFA is not supported" viewer.js:3353
"Warning: fontRes not available" pdf.worker.js:200
"Warning: Error during font loading: Font OptimaLT is not available" pdf.js:200
"Warning: fontRes not available" pdf.worker.js:200 

Is it enough to call this Verified? 

Tested on Win 7 x64 (Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0) with Firefox 31 Beta 2 (BuildID: 20140616143923).
Yury, can we call this verified based on comment 9? If so, should Florin file a new bug to address the issue in comment 9?
Flags: needinfo?(ydelendik)
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #11)
> Yury, can we call this verified based on comment 9? If so, should Florin
> file a new bug to address the issue in comment 9?

The font warnings just inform that non-standard font was used and it's not available in the PDF. Those warnings typical for non-conformant to PDF32000 spec PDFs and cannot addressed (except hiding them).

"Warning: AcroForm/XFA is not supported" is bug 739043.

Initial issue of "Incorrect font encoding in pdf annotations" is resolved, so we can call this verified.
Flags: needinfo?(ydelendik)
Status: RESOLVED → VERIFIED
status-firefox31: --- → verified
You need to log in before you can comment on or make changes to this bug.