Add "Browse Functional Areas" view

VERIFIED FIXED in 2013-06-27

Status

Participation Infrastructure
Phonebook
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Sambit Roy, Assigned: fxa90id)

Tracking

other
2013-06-27
Dependency tree / graph

Details

(Whiteboard: [kb=981283] [ux][homepageredux])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_3) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.99 Safari/537.22

Steps to reproduce:

1. Go to the phonebook Homepage.
2. Click on 'My Profile'.
3. Observe the options.


Actual results:

1. 'Browse Functional Areas' option is not provided.



Expected results:

1. 'Browse Functional Area' option should be provided.
Whiteboard: [ux]
I'm having a hard time confirming this bug, there is no 'My Profile' link in the homepage.
Was that a reference to the view profile link?
Created attachment 735861 [details]
Browse functional areas screenshot

Sambit, the Browse Functional Areas section appears on the homepage when a user is logged in (screenshot attached). Are you suggesting this section should appear somewhere else in addition?
Flags: needinfo?(sambit.r)
(Reporter)

Comment 3

5 years ago
William, the Browse Functional Areas, according to me it should also be provided in 'View Profile'. It would let others also see in your profile and know what allfunctional areas the user is present in. Sorry for the late reply.
Flags: needinfo?(sambit.r)
Suggested implementation of better "Browse Functional Areas" functionality:

a) Create a page dedicated to listing the functional areas, just like we have a page dedicated to listing groups (/groups)

b) Use the new groups list view (bug 859973) as a starting point for a functional areas list view

c) In addition to the group name and member count, an item in the functional areas list will include the description, e.g. "Boot to Gecko (B2G) is a project with the goal of building a complete, standalone operating system for the Web. It is not a product offering yet, but we are working on transforming it into one." Items will list to the functional area page.

d) Link to the functional area list from the new logged-in homepage (bug 867416)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [ux] → [kb=981283] [ux]
Depends on: 859973
Summary: Phonebook :: Profile :: 'Browse Functional Areas' should be provided. → Add "Browse Functional Areas" view
This code must be built on the homepageredux branch of mozillians, and we're hoping for a PR on 6/7. Thanks!
Assignee: nobody → michaljev
Status: NEW → ASSIGNED
Additional specs...

* The string at the top of the list should be:
"View Mozillians, Stewards and information for any functional area. Find out who works on what and how you can help out."

* The header on the page should be:
"Functional Areas"

* The URL should be:
"/functional_areas"

* There's a new groups view in homepageredux as of 6/4 that should form the basis for this one.
Change to comment 6: 

* the URL should be:
"/functional-areas"
(Assignee)

Comment 8

5 years ago
url: /
http://awesomescreenshot.com/0e51cz4u67 
browse functional areas link is now accessible.

url: /functional-areas/
http://awesomescreenshot.com/0911cz587f 
sorting doesnt work /o\, because of sort function https://github.com/mozilla/mozillians/blob/homepageredux/apps/groups/templates/groups/index.html#L36
Blocks: 766760
No longer depends on: 766760
(Assignee)

Comment 10

5 years ago
landed https://github.com/mozilla/mozillians/commit/c36b262e5f30df9d6a134294ef51269e7bd2961c
Thanks fxa90id!
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Whiteboard: [kb=981283] [ux] → [kb=981283] [ux][homepageredux]
Target Milestone: --- → 2013-06-27
Created attachment 765459 [details]
qa - verified on stage

QA verified on stage - Sambit, excellent suggestions.

Verified per spec in comment 4 - on each user's homepage there is a link to a functional areas view (https://mozillians.allizom.org/functional-areas/).

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.