Remove irc:// links

VERIFIED FIXED in 2013-11-07

Status

Participation Infrastructure
Phonebook
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Sambit Roy, Assigned: geoff)

Tracking

other
2013-11-07

Details

(Whiteboard: [kb=1168636] )

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_3) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.99 Safari/537.22

Steps to reproduce:

1. Go to the phonebook Homepage through Firefox 19.0.
2. Click on 'My Profile'.
3. Click on the IRC Nickname.
4. Go to the phonebook Homepage through Chrome 24.0.
5. Click on 'My Profile'.
6. Click on the IRC Nickname.
7. Go to the phonebook Homepage through Safari 5.1.5.
8. Click on 'My Profile'.
9. Click on the IRC Nickname.


Actual results:

1. A pop-up regarding chatzilla opened up in Firefox 19.0.
2. The pop-up did not open up in Chrome 24.0 and Safari 5.1.5.



Expected results:

1. The pop-up should be opened consistently across all browsers.

Investigative notes:
1. Chatzilla is an add-on for firefox.
2. The Chatzilla add-on is not available for Safari and Chrome.
Hi Sambit

The popup appeared in Firefox because you had Chatzilla installed on Firefox. The url in question is an irc url. Most browsers do not have native support for irc e.g Firefox. Consider adding addons for the other browsers.
Elevating to new so we can fold the idea into a future release (note this may not occur for many months - I suspect that there are a number of users who click that link and are surprised by the behavior.

I wonder if we can address this in a future UX tweak.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Also an issue on Android and maybe other operating systems. Maybe we can remove the link altogether?
Summary: On clicking 'IRC Nickname', chatzilla pop-up is being displayed only for Firefox → irc:// links can lead to unexpected behavior
I agree; I think it is a rare user whose browser will do the appropriate thing with an irc:// link. Let's remove the link.
Assignee: nobody → ggladden
Status: NEW → ASSIGNED
I suggest removing the IRC links on profiles and functional area listing pages.

Profile example
https://mozillians.org/u/williamr

Functional area example
https://mozillians.org/group/developer-tools/
Summary: irc:// links can lead to unexpected behavior → Remove irc:// links

Comment 6

5 years ago
Commit pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/3188f4ed194d06f7d1a6759cb218bde4038ac78a
[Fix Bug 845799] Removed the IRC link from the profile and group pages. IRC name is still visible, it just doesn't link to anything anymore.

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [kb=1168636]
VERIFIED on stage: irc usernames on the group and profile pages are no longer links.
Status: RESOLVED → VERIFIED

Comment 8

5 years ago
Commit pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/3188f4ed194d06f7d1a6759cb218bde4038ac78a
[Fix Bug 845799] Removed the IRC link from the profile and group pages. IRC name is still visible, it just doesn't link to anything anymore.
Verified on staging.
Target Milestone: --- → 2013-11-07
You need to log in before you can comment on or make changes to this bug.