Closed Bug 845877 Opened 11 years ago Closed 11 years ago

GfxInfoThread.getData can deadlock

Categories

(Firefox for Android Graveyard :: Toolbar, defect)

All
Android
defect
Not set
normal

Tracking

(firefox19 wontfix, firefox20 wontfix, firefox21 fixed, firefox22 fixed)

RESOLVED FIXED
Firefox 22
Tracking Status
firefox19 --- wontfix
firefox20 --- wontfix
firefox21 --- fixed
firefox22 --- fixed

People

(Reporter: kats, Assigned: kats)

References

Details

Attachments

(1 file)

Attached patch PatchSplinter Review
If the call to GfxInfoThread.getData happens before the thread is done it's gfx info gathering, severe badness happens. I don't think this happens too often in the wild thankfully, because gecko would have to start up really fast for it to get hit.
Attachment #719049 - Flags: review?(bjacob)
Note also that the InterruptedException blocks go away in bug 844275 part 7.
Attachment #719049 - Flags: review?(bjacob) → review+
https://hg.mozilla.org/mozilla-central/rev/36c520acb93d
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Comment on attachment 719049 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 766251
User impact if declined: needed to uplift bug 844275
Testing completed (on m-c, etc.): on m-c, aurora try build at https://tbpl.mozilla.org/?tree=Try&rev=26b79db37644
Risk to taking this patch (and alternatives if risky): low risk, fennec only
String or UUID changes made by this patch: none
Attachment #719049 - Flags: approval-mozilla-aurora?
Comment on attachment 719049 [details] [diff] [review]
Patch

well baked low risk patch(fennec only) needed to uplift bug 844275(recently approved for aurora)
Attachment #719049 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: