[Contacts][Dialer] Huge delay (5-10s) when trying to interact with contacts (calling screen shown instead of caller screen)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18+ affected, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix)

Details

(Reporter)

Description

6 years ago
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/f1e39ce2164b
Gaia   26b20494ef6b443250a94bc5a4e961777ab7592c
BuildID 20130227070200
Version 18.0

Interacting with contacts show a huge delay when trying to e.g. initiate a call right after each other. In some cases it takes more than 10 seconds until a reaction is visible.

And especially when I try to call someone else I sometimes even see the screen as the other person would call me in this moment! I have no idea why that is possible. It seems to happen when the delay is longer than 10s.

Steps:
1. Open Contacts
2. Select a contact
3. Call the contact
4. Stop the call immediately
5. Call the contact again

With step 5 you can notice the huge delay until an action is triggered.
Henrik can re-flash with the latest build and try to repro?
blocking-b2g: tef? → -
I can reproduce this on the same build ID on my Unagi.
This might show up most often in a dropped call scenario, we're going to have to live with the slow response here for v1.0.1 but will track for 1.next
blocking-b2g: - → ---
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → wontfix
tracking-b2g18: --- → +

Comment 4

6 years ago
I can't reproduce. Setting qawanted keyword.
Keywords: qawanted

Comment 5

6 years ago
Unagi Build: Gecko-854a86c.Gaia-601f50f

Steps:
1. Open Contacts
2. Select a contact
3. Call the contact
4. Stop the call immediately
5. Call the contact again 
6. Repeat steps 3, 4, 5 a few times right after each other. There's no delays between calls
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

6 years ago
This is still not working. Tested with:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/aec2f0738fab
Gaia   601f50f4b498dd952008f60dca0be1db4e2ba2ed
BuildID 20130310230202
Version 18.0
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 7

6 years ago
Any update on this. I'm still unable to reproduce. Henrik, could you please test again?
Flags: needinfo?(hskupin)
(Reporter)

Comment 8

6 years ago
Yes, it's still present with yesterdays build on 1.1.0.0-prerelease.
Status: REOPENED → NEW
Flags: needinfo?(hskupin)

Comment 9

6 years ago
Coul you please upload a video in order to figure out what's happening? Thanks!
(Reporter)

Comment 10

5 years ago
I don't see this behavior anymore. Looks like it has been fixed between March 25th and yesterdays build.

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/08de0253274c
Gaia   48e6e68da32cb725d5182206c7bbd3490dda05a8
BuildID 20130408230206
Version 18.0
Status: NEW → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.