Mozilla crashes shortly after started for all users but root

VERIFIED WORKSFORME

Status

Core Graveyard
Profile: Migration
--
critical
VERIFIED WORKSFORME
17 years ago
2 years ago

People

(Reporter: lemming, Assigned: racham)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.11 i586; en-US; 0.8) Gecko/20010215
BuildID:    2001050521

I am using milestone 0.8. I am unable to migrate to 0.9.1 (0.9 didn't work too),
because Mozilla crashes (segfault) shortly after I write "/opt/mozilla/mozilla"
(~1 sec). It just prints:

/opt/mozilla/run-mozilla.sh /opt/mozilla/mozilla-bin
MOZILLA_FIVE_HOME=/opt/mozilla
  LD_LIBRARY_PATH=/opt/mozilla:/opt/mozilla/plugins
     LIBRARY_PATH=/opt/mozilla:/opt/mozilla/components
       SHLIB_PATH=/opt/mozilla
          LIBPATH=/opt/mozilla
       ADDON_PATH=/opt/mozilla
      MOZ_PROGRAM=/opt/mozilla/mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=



Reproducible: Always
Steps to Reproduce:
Just run mozilla as non-root.

Actual Results:  segfault :-)

Expected Results:  Mozilla running :-)

I tried to run Mozilla as a new user (clean home, didn't ran it before) and it
crashed too. strace -f shown this:

[pid  7004] open("/opt/mozilla/components/libnecko.so", O_RDONLY) = 9
[pid  7004] fstat(9, Сst_mode=S_IFREGШ0755, st_size=781315, ...Ч) = 0
[pid  7004] read(9, о177ELFо1о1о1о0о0о0о0о0о0о0о0о0о3о0о3о0о1о0о0о0До344о0"...,
4096) = 4096
[pid  7004] mmap(NULL, 508436, PROT_READШPROT_EXEC, MAP_PRIVATE, 9, 0) = 0x40809000
[pid  7004] mprotect(0x4087f000, 25108, PROT_NONE) = 0
[pid  7004] mmap(0x4087f000, 28672, PROT_READШPROT_WRITE, MAP_PRIVATEШMAP_FIXED,
9, 0x75000) = 0x4087f000
[pid  7004] close(9)                    = 0
[pid  7004] pipe(─9, 10▄)               = 0
[pid  7004] fcntl(9, F_GETFL)           = 0 (flags O_RDONLY)
[pid  7004] fcntl(9, F_SETFL, O_RDONLYШO_NONBLOCK) = 0
[pid  7004] fcntl(10, F_GETFL)          = 0x1 (flags O_WRONLY)
[pid  7004] fcntl(10, F_SETFL, O_WRONLYШO_NONBLOCK) = 0
[pid  7004] sched_get_priority_max(0)   = 0
[pid  7004] sched_get_priority_min(0)   = 0
[pid  7004] pipe(─11, 12▄)              = 0
[pid  7004] clone()                     = 7005
[pid  7004] write(12,
"о2о0о0о0о5о0о0о0о3о0о0о0о330о340о377о277о264о200о0ДLо2"..., 148) = 148
[pid  7004] rt_sigprocmask(SIG_SETMASK, NULL, ─RT_0▄, 8) = 0
[pid  7004] write(12,
"До320о34До0о0о0о0о200о341о377о277ооо243о32До200о2о21о10"..., 148) = [pid  7004]
open("/opt/mozilla/components/libnecko.so", O_RDONLY) = 9
[pid  7004] fstat(9, Сst_mode=S_IFREGШ0755, st_size=781315, ...Ч) = 0
[pid  7004] read(9, "о177ELFо1о1о1о0о0о0о0о0о0о0о0о0о3о0о3о0о1о0о0о0До344о0"...,
4096) = 4096
[pid  7004] mmap(NULL, 508436, PROT_READШPROT_EXEC, MAP_PRIVATE, 9, 0) = 0x40809000
[pid  7004] mprotect(0x4087f000, 25108, PROT_NONE) = 0
[pid  7004] mmap(0x4087f000, 28672, PROT_READШPROT_WRITE, MAP_PRIVATEШMAP_FIXED,
9, 0x75000) = 0x4087f000
[pid  7004] close(9)                    = 0
[pid  7004] pipe(─9, 10▄)               = 0
[pid  7004] fcntl(9, F_GETFL)           = 0 (flags O_RDONLY)
[pid  7004] fcntl(9, F_SETFL, O_RDONLYШO_NONBLOCK) = 0
[pid  7004] fcntl(10, F_GETFL)          = 0x1 (flags O_WRONLY)
[pid  7004] fcntl(10, F_SETFL, O_WRONLYШO_NONBLOCK) = 0
[pid  7004] sched_get_priority_max(0)   = 0
[pid  7004] sched_get_priority_min(0)   = 0
[pid  7004] pipe(─11, 12▄)              = 0
[pid  7004] clone()                     = 7005
[pid  7004] write(12,
"о2о0о0о0о5о0о0о0о3о0о0о0о330о340о377о277о264о200о0ДLо2"..., 148) = 148
[pid  7004] rt_sigprocmask(SIG_SETMASK, NULL, ─RT_0▄, 8) = 0
[pid  7004] write(12,
"До320о34До0о0о0о0о200о341о377о277ооо243о32До200о2о21о10"..., 148) = 148
[pid  7004] rt_sigprocmask(SIG_SETMASK, NULL, ─RT_0▄, 8) = 0
[pid  7004] rt_sigsuspend(─▄ <unfinished ...>

Updated

17 years ago
Keywords: crash
Reporter: 
You must run it the first time as root.
After that you can run mozilla as user.

Keywords: crash
did you install as root?
(Reporter)

Comment 3

17 years ago
I now downloaded another version, installed (and ran) as root. As root it is
running OK, as normal user I get:
...
 I am inside the initialize
 Hey : You are in QFA Startup 
/opt/mozilla/run-mozilla.sh: line 72: 10687 Segmentation fault      $prog ${1+"$@"}

Comment 4

17 years ago
I get the precise same behaviour. I installed as root, ran as root (once) 
to set up -- all appears well. Running as a user, I get:


bash-2.05$ /usr/local/mozilla/mozilla &
/usr/local/mozilla/run-mozilla.sh /usr/local/mozilla/mozilla-bin
MOZILLA_FIVE_HOME=/usr/local/mozilla
  LD_LIBRARY_PATH=/usr/local/mozilla:/usr/local/mozilla/plugins
     LIBRARY_PATH=/usr/local/mozilla:/usr/local/mozilla/components
       SHLIB_PATH=/usr/local/mozilla
          LIBPATH=/usr/local/mozilla
       ADDON_PATH=/usr/local/mozilla
      MOZ_PROGRAM=/usr/local/mozilla/mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
Registering plugin 0 for: "*","All types",".*"
/usr/local/mozilla/run-mozilla.sh: line 72:  9718 Segmentation fault      $prog
${1+"$@"}
from the release notes:

"Linux: You may encounter problems if you install Mozilla in a root user
environment then run as another user. Problems include saving to Sent folder,
Drafts, Templates or general authentication problems. (Bug 49397)"

asa, is this a known problem?
(Reporter)

Comment 6

17 years ago
It is definitely not #49397. The mozilla does not even start. And I am starting
the browser, not mail/news. And it should not _segfault_ anyway :-)

Comment 7

17 years ago
I had the same problem. It seems to be a permission problem. Installed from rpm
and it did not work until I changed permissions:

chmod -r a+rw /usr/lib/mozilla

I know that that is a stupid way to solve it. But it works on my single user
machine.

/Stefan

Comment 8

17 years ago
This sounds identical to the Linux permissions bug we have had for AGES

I looked in the database, but could not find it, but it was a bug where mozilla
would crash if it didnt have write permission to the binary directory

as far as I know, this has never been fixed...

if someone finds that bug.. i am pretty sure this is a dup of it
(Reporter)

Comment 9

17 years ago
I did `chmod -R /opt/mozilla` (that is where I installed it). Mozilla modifies
file component.reg after start, but still crashes.

Comment 10

17 years ago
not a blocker.
Severity: blocker → critical
(Reporter)

Comment 11

17 years ago
I have downloaded and compiled 0.9.1 sources. Now it works fine. I have also
tried to debug the previous version - the crash occured somewhere in thread
creation.

Comment 12

17 years ago
Marking WORKSFORME as per reporters comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 13

17 years ago
verify
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.