Closed Bug 846092 Opened 8 years ago Closed 8 years ago

[Dialer] In dial pad screen, cannot change keypad volume.

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

(blocking-b2g:leo+, b2g18 verified, b2g18-v1.0.1 fixed)

VERIFIED FIXED
blocking-b2g leo+
Tracking Status
b2g18 --- verified
b2g18-v1.0.1 --- fixed

People

(Reporter: leo.bugzilla.gaia, Assigned: alive)

References

Details

(Keywords: regression)

Attachments

(1 file)

1. Title : In dial pad screen, cannot change keypad volume.
2. Precondition : Settings >> Sound >> Keypad - check >> Home >> Run Dialer >> Dial pad screen
3. Tester's Action : Press side volume up/down key
4. Detailed Symptom (ENG.) : Not change keypad volume.
6. Expected : Can change keypad volume.
7. Reproducibility: Y
1) Frequency Rate : 100%
8. Gaia revision : 6916e18d1f72936e892543cf4a104a7d457f78ad
Bug 832170 - DTMF lower volume
-> When fixing Bug 832170, represent this bug. So I add below source
'''

this._audio.mozAudioChannelType = 'ringer';

'''
Attachment #719335 - Flags: review?
Assignee: nobody → leo.bugzilla.gaia
Comment on attachment 719335 [details]
Patch URL to pull request_8369

Don't do this. There's side effort to promote the channel to ringer or notification.
Attachment #719335 - Flags: review? → review-
Assignee: leo.bugzilla.gaia → nobody
Isn't this bug a high priority? For the case when the sound is muted (or set to silent) using the volume controls, the keypad tones are still played at their full volume (this._audio.volume = 0.5; -- keypad.js#L53) -> a very undesirable UX situation.
blocking-b2g: --- → leo?
tracking-b2g18: --- → ?
I think this is a regression of bug 784184.   it was fixed back then. 

vivien, can you take a look?   i heard you touched audio last.
Assignee: nobody → 21
blocking-b2g: leo? → leo+
Keywords: regression
(In reply to Tony Chung [:tchung] from comment #4)
> I think this is a regression of bug 784184.   it was fixed back then. 
> 

Fix of bug 784184 caused a regression: keypad volume is heard by both headset and speaker.
See discussion in https://bugzilla.mozilla.org/show_bug.cgi?id=832170

> vivien, can you take a look?   i heard you touched audio last.
Assignee: 21 → alive
There're several workarounds we had considered.
1. Just implement silent mode to achieve comment 3. 
   See https://bugzilla.mozilla.org/show_bug.cgi?id=819842
   Side effect: You still couldn't change the volume of DTMF tone.
2. Just implement short audio adjust
   See https://bugzilla.mozilla.org/show_bug.cgi?id=825970
   Side effect: This is general change in sound manager and I'm afraid it would affect other volume.
3. Looking forward backend API change in bug 853101. (Very impractical cuz it's big change)

This one and similar issue is raised again and again, there's just no right answer to this bug now, I am c.c.ing some audio backend guys.
Deassign myself first. Will keep tracking.
Assignee: alive → nobody
(In reply to Alive Kuo [:alive] (PTO during 3/27~4/7) from comment #6)
> There're several workarounds we had considered.
> 1. Just implement silent mode to achieve comment 3. 
>    See https://bugzilla.mozilla.org/show_bug.cgi?id=819842
>    Side effect: You still couldn't change the volume of DTMF tone.
> 2. Just implement short audio adjust
>    See https://bugzilla.mozilla.org/show_bug.cgi?id=825970
>    Side effect: This is general change in sound manager and I'm afraid it
>    would affect other volume.

Could we start by doing these two things and see how well that works? I don't think we'll ever find a perfect solution, but these two things should be fixed no matter what. After that we can reassess what we should do.

> 3. Looking forward backend API change in bug 853101. (Very impractical cuz
> it's big change)

Yeah, I agree, I don't think we should block on that bug here.
Assignee: nobody → alive
Though bug 819842 and bug 825970 are both minus-ed I am going to do one or both of them to lessen the impact of this problem.
I encounter a problem: I found the sound of DTMF audio isn't firing audio-channel-changed event to system app so we'll never know the user is pressing dialer keypad in system.

Trying to investigate it's a gecko problem or not.
Depends on: 860150
Depends on: 819842
This issue is happening in v 1.0.1 as well. I cannot lower the dial pad volume. 

Unagi Build ID: 20130417070205
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/6bac24e14538
Gaia: 2d048a9bdae54e4ec7d48326c2130591c8b869b6
Depends on: 868314
No longer depends on: 819842
Depends on: 819842
My work in bug 819842 makes it possible to mute the keypad sound via volume rocker.
I think it's worthy to close this and use https://bugzilla.mozilla.org/show_bug.cgi?id=825970 for tracking "cannot change a short playing audio".
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Alive, should we mark this as fixed on branches then?
Flags: needinfo?(alive)
This issue seems to be fixed only for V1 train and not for v 1.0.1. 

The user can lower the dial pad volume in
Leo Build ID: 20130513230207 
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/606c4fa198c2
Gaia   23cec618ba1ad9f39da1fc5dfa2a4df2b2d5f933

The user is UNABLE to reduce the dial pad volume
Inari Build ID: 20130515070203
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/0b6bcb1f4175
Gaia   9648799c2e45917ff150fa9eef8aeac79a9ac008
This is being tracked in bug https://bugzilla.mozilla.org/show_bug.cgi?id=825970 verifying out.
Status: RESOLVED → VERIFIED
Flags: in-moztrap?
Added test case in MozTrap: 
https://moztrap.mozilla.org/manage/case/8504/
Flags: in-moztrap? → in-moztrap+
You need to log in before you can comment on or make changes to this bug.