danskgolf.dk - Content doesn't show. an XML Parsing Error occurs instead.

RESOLVED FIXED

Status

P4
normal
RESOLVED FIXED
18 years ago
4 years ago

People

(Reporter: l.aagren, Unassigned)

Tracking

Details

(Whiteboard: [bug248549notfixed] [deny], URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.5 i686; en-US; rv:0.9.1) Gecko/20010607
BuildID:    2001060713

I've just changed from mozilla 0.9 to 0.9.1 and when i try to read
http://www.danskgolf.dk I now get an error message which I didn't get with 0.9:

XML Parsing Error: syntax error 
Location: http://www.danskgolf.dk/ Line Number 1, Column 55:<!DOCTYPE HTML
PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
------------------------------------------------------^

Reproducible: Always
Steps to Reproduce:
1.Just load the page
2.
3.

Actual Results:  XML Parsing Error: syntax error
Location: http://www.danskgolf.dk/ Line Number 1, Column 55:<!DOCTYPE HTML
PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
------------------------------------------------------^

Expected Results:  The content of the page to be shown. I don't see any problems
in the XML.
Could this be a DOCTYPE sniffing problem?  The document is being served as text/
html-there's no reason it should go to the XML parser at all.

Comment 2

18 years ago
yummmmy did we break the 3.2 doctype parsing?? over to parser cc'ing dbaron and
heikki.
Marking NEW, and OS all.
Assignee: heikki → harishd
Status: UNCONFIRMED → NEW
Component: XML → Parser
Ever confirmed: true
OS: Linux → All
QA Contact: petersen → bsharma
HTTP sniffing (using ethereal) shows:

----------
GET / HTTP/1.1
Host: www.danskgolf.dk
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.1+) Gecko/20010516
Accept: text/xml, application/xml, application/xhtml+xml, text/html;q=0.9,
image/png, image/jpeg, image/gif;q=0.2, text/plain;q=0.8, text/css, */*;q=0.1
Accept-Language: en, es; q=0.667, eo; q=0.333
Accept-Encoding: gzip,deflate,compress,identity
Accept-Charset: ISO-8859-1, utf-8; q=0.667, *; q=0.667
Keep-Alive: 300
Connection: keep-alive
Referer: http://bugzilla.mozilla.org/show_bug.cgi?id=84618

HTTP/1.0 200 Ok
Content-type: text/xml

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
<HTML>
<HEAD>
...
----------

I suspect the server is responding to something in the 'Accept' header.

Changing component to Evangelism, since this is not a bug.
Component: Parser → Evangelism
...and reassigning to default owner of Evangelism.
Assignee: harishd → bclary
QA Contact: bsharma → zach
The following is sufficient to reproduce:

----------

GET / HTTP/1.0
Accept: text/xml, text/html
Host: www.danskgolf.dk

HTTP/1.0 200 Ok
Content-type: text/xml

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
<HTML>
...
----------
"text/html, text/xml" and even "text/html, text/xml;q=0.2" also yield a
"text/xml" response.

Updated

18 years ago
Priority: -- → P4

Comment 7

18 years ago
-> Intl
Assignee: bclary → nitot
QA Contact: zach → momoi

Updated

17 years ago
Component: Evangelism → European
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 8

17 years ago
Moving to new component "West Europe".  European component is being removed. 
See bug 95808 for details.
Component: European → West Europe
QA Contact: momoi → caillon
Summary: Content doesn't show. an XML Parsing Error occurs instead. → danskgolf.dk - Content doesn't show. an XML Parsing Error occurs instead.
(Reporter)

Comment 9

17 years ago
I have just sent an email to the webmaster at danskgolf.dk, and they have
allready responded that they acknowledge the problem at that they will try to
fix it right away. So maybe this bug will be resolved soon.
half a year later - still "soon"...?
the error changed, the problem not
(Reporter)

Comment 12

16 years ago
I've recently spoken to the guys at danskgolf.dk again. After some consideration
they've decided not do anything about the problem until they redesign their web
pages. And even then they probably wont support mozilla they say :-/
Mass triage of Tech Evangelism bugs pending deletion of obsolete European
components. To find this spam, search for "WarmApplePieAndMilk"

Specific info for this bug: to other. cant determine language at this venture.
suspect wontfix based upon comment 12
Assignee: nitot → other
Component: Europe: West → Other
QA Contact: z-caillon-obsolete2 → other

Comment 14

15 years ago
move to new danish component
Component: Other → Danish
[deny] according to comment #12
Whiteboard: [bug248549notfixed] [deny]
Domain dead
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.