Tilt error flooding error console (TypeError: mouseLerp is undefined)

RESOLVED FIXED in Firefox 20

Status

defect
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: Dolske, Assigned: vporof)

Tracking

unspecified
Firefox 22
x86
macOS

Firefox Tracking Flags

(firefox20+ verified, firefox21+ verified, firefox22 verified)

Details

Attachments

(1 attachment)

Reporter

Description

6 years ago
I happened to use Tilt yesterday (for the first time in eons, I'm not a regular). I just now opened my Error Console to investigate a separate issue (I think -- cut'n'paste not working), and noticed that it's being absolutely _flooded_ with error messages.

I am literally seeing dozens and dozens of these fly by -- if I clear the messages, the scrollbar shrinks rapidly to it's minimum state within seconds. I also GC/CC debug messages scroll by every couple seconds (I have that pref enabled). The good news is that the browser seems quite responsive!

But this is clearly not a good thing.
Reporter

Comment 1

6 years ago
I was able to reproduce this after restarting my browser.

* Tools -> Web Dev -> Toggle Tools
* Click the cube button
* move the 3D view around a bit to bask in its glory
* Command-W to close the tab.
I saw this too, yesterday in Nightly.
Assignee

Comment 3

6 years ago
Posted patch v1Splinter Review
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Attachment #719396 - Flags: review?(paul)
Assignee

Comment 4

6 years ago
Happens in aurora and beta too. Boo.
Attachment #719396 - Flags: review?(paul) → review+
adding tracking flags. This affects aurora and beta.
Assignee

Comment 6

6 years ago
Thanks rob! 
Inbound and fx-team are CLOSED for now. Need to wait a bit.
Assignee

Comment 8

6 years ago
Comment on attachment 719396 [details] [diff] [review]
v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): closing a window with Tilt open results in a flood of TypeErrors in the Error Console
User impact if declined: Medium, not something a regular user may see, but having lots of errors rapidly showing up in the Error Console (if open) may affect browser responsiveness
Testing completed (on m-c, etc.): local, fx-team
Risk to taking this patch (and alternatives if risky): None, small simple change
String or UUID changes made by this patch: None
Attachment #719396 - Flags: approval-mozilla-aurora?
Assignee

Updated

6 years ago
Attachment #719396 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/9161ede810cb
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Comment on attachment 719396 [details] [diff] [review]
v1

Please land before 3/5(tomorrow) for this to make into fx20 beta3 which goes to build tomorrow.
Attachment #719396 - Flags: approval-mozilla-beta?
Attachment #719396 - Flags: approval-mozilla-beta+
Attachment #719396 - Flags: approval-mozilla-aurora?
Attachment #719396 - Flags: approval-mozilla-aurora+
Verified the large number of error messages for 2013-02-27 Nightly (20130227030925) by following the STR from comment 1.

Verified the fix for Latest Nightly (20130305030833), Latest Aurora (20130305042015) and Firefox 20.0 Beta 3 (20130305164032).

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0
Flagging for verification in Firefox 21 and 22.
Keywords: verifyme

Comment 14

6 years ago
Verified as fixed on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20100101 Firefox/21.0

Comment 15

6 years ago
Verified as Fixed on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:21.0) Gecko/20100101 Firefox/22.0 - 20130514181517.
mass remove verifyme requests greater than 4 months old
Keywords: verifyme
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.