[OPEN_][sound]The volume becomes larger automatic when received SMS, incoming call or other events in listening FM radio.(617002037853)

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
6 years ago
4 years ago

People

(Reporter: Firefox_Mozilla, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: [triaged:3/1])

(Reporter)

Description

6 years ago
Steps to reproduce:
1.power off and then power on the phone;
2.insert the headset and listen FM radio in background;
3.receive SMS message, incoming call or other events;.
Expected results:
1.the volume does not change.
Actual results:
1. when the device receives SMS, incoming call or other event, the volume automatic becomes larger than before.
(Reporter)

Updated

6 years ago
Blocks: 845223
QA will test this bug.
Whiteboard: [triaged:3/1]
Hi, all,

I have double confirmed this case.
The build: 20130218070201 (Cannot reproduce)
The build: 20130304230203 (latest build, I also cannot reproduce, please see attachment)
Could you please provide the build number?
One more question, could I know the "volume" you mentioned was headset's volume or ringer’s volume?
The two volumes didn't have any change while I run this case. FYI.
Thanks!
(Reporter)

Updated

6 years ago
blocking-b2g: --- → tef?
[tef- for now because (1) we have no build information for where this issue is seen, and (2) it can't be reproduced according to comment 2.  Once we have more details on whether this is still an issue at the tip please re-nom for tef+]
blocking-b2g: tef? → -
(Reporter)

Comment 4

6 years ago
we use the new build(mozilla build id:20130304070202, AU031), it also has this bug.
we power on the phone and listen FM or music. the sound of FM or music become larger than before when receive incoming call or SMS.
Hi,

Since we can't reproduce this bug, would you mind to add the log for clarification?

Please add log for stream type and volume index at 

  http://mxr.mozilla.org/mozilla-central/source/dom/system/gonk/AudioManager.cpp#419
  http://mxr.mozilla.org/mozilla-central/source/dom/system/gonk/AudioManager.cpp#427
  http://mxr.mozilla.org/mozilla-central/source/dom/system/gonk/AudioManager.cpp#408

Where are places to configure FM volume.

Thanks.
can you please check and see if this still is occurring on a more recent build, will mark as invalid in 1 week. If it is able to reproduce on a current build i will reopen from there due to age of this bug.
Flags: needinfo?(Firefox_Mozilla)
I am clearing this bug, it does not occur in 2.0 or higher so it will be marked as wont fix. sorry for the confusion.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(Firefox_Mozilla)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.