[OPEN_][settings] The phone reboots when we modify APN in data settings.(617002039618)

VERIFIED FIXED

Status

Firefox OS
Gaia::Settings
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Firefox_Mozilla, Assigned: pgravel)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.1 fixed)

Details

(Whiteboard: [triaged:3/1] [NPOTB] QARegressExclude)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 719377 [details]
reboot log

Steps to reproduce:
1. go into settings-cellular & data-data settings;
2.modify APN and save;
Expected results:
1.It can shown the correct APN according sim card.
2.It can modify APN and save succussful.
Actual results:
1. It can shown the correct APN according sim card. The APN is shown blank and users must set first.
2.If we insert China Unicom sim card, when we input or modify APN as 3gwap or cmwap and save, the system reboot.
(Reporter)

Updated

5 years ago
Blocks: 845223

Comment 1

5 years ago
Ken, can you find someone to help this issue? 
QA will check if we have the China Unicom 3G SIM card.
blocking-b2g: --- → shira?
Flags: needinfo?(kchang)
Whiteboard: [triaged:3/1]

Comment 2

5 years ago
(In reply to Firefox_Mozilla from comment #0)
You upload the reboot log file with wrong format, please upload the log file again.
Flags: needinfo?(kchang)

Comment 3

5 years ago
Reporter, can you help? Thanks.
Flags: needinfo?(Firefox_Mozilla)
Please also let us know which AU is being used here?
blocking-b2g: shira? → tef?

Comment 5

5 years ago
Hi, all,

Just update the relate test from Taiwan site. FYR.
The build: 20130218070201 (Cannot reproduce)
The latest build: 20130304230203 (Cannot reproduce, as attachment)
So, do you think the issue was relate to carriers?
Thanks!

Comment 6

5 years ago
Created attachment 721284 [details]
APN Settings
(Reporter)

Comment 7

5 years ago
we use AU018 and insert China Unicom Usim card that has this issue.
Flags: needinfo?(Firefox_Mozilla)
blocking-b2g: tef? → tef+
Assignee: nobody → kaze
I’m afraid I don’t understand this bug report. Here are the two scenarios I’ve tested:

STR #1:
 • Unagi, latest Gaia-master + Gecko-b2g18
 • open the Settings app
 • Cellular & Data > Data settings
 • in the “Advanced settings” section, modify the APN name
 • save (= tap on “OK”)
Expected results:
 • the data provider name is switched to “(custom settings)” when the APN name is changed
 • the new APN name is properly saved

STR #2:
 • Unagi, latest Gaia-master + Gecko-b2g18
 • open the Settings app
 • Cellular & Data > Data settings
 • if several operators are proposed, select another one
 • save (= tap on “OK”)
Expected results:
 • the APN name (and other parameters in the “Advanced settings” section) is updated
 • all APN parameters (including the Data provider name) are properly saved.

On my build (latest Gaia-master + b2g18), everything works as expected. No reboot.

(In reply to Firefox_Mozilla from comment #0)
> Expected results:
> 1.It can shown the correct APN according sim card.
> 2.It can modify APN and save succussful.

What does this mean?

FWIW, the SIM card only exposes an MCC/MNC tuple and Gaia retrieves all Data providers that match this tuple from our shared `apn.json' database: for my SIM card there’s only one match (208/15 → Free mobile), for other SIM cards there can be several matches (208/1 → Orange, VM, Tele2, Carrefour, NRJ), but the APN parameters are /not/ stored on the SIM card.

If your carrier is China Unicom I expect MCC/MNC to be 406/1, can you confirm?
If not, then we have a bug on the platform side.
If yes, then you should see this list when opening the Data settings:
 • 沃3G连接互联网 (China Unicom)
 • 沃3G手机上网 (China Unicom)
 • 联通2GNET上网 (China Unicom)
 • 联通彩信 (China Unicom)
 • 联通2g彩信 (China Unicom)
 • (custom settings)

In any case, I can’t reproduce your bug here — please provide more information: device, build, mcc/mnc.

I kinda remember we had a similar bug with a Chinese carrier a few months ago, where the mcc/mnc tuple wasn’t properly read by gonk/gecko. Kevin, maybe you remember this one?
info requested to reporter
Flags: needinfo?(Firefox_Mozilla)
(In reply to Firefox_Mozilla from comment #0)
> 2.If we insert China Unicom sim card, when we input or modify APN as 3gwap
> or cmwap and save, the system reboot.

question to reporter. Need to understand the symptom a bit more. when you say system reboot, does it reboot with the bootloader splash screen? or does it reboot with the firefox OS blue screen?

if it is a complete reboot where you can see the bootloader splash screen, suspect a system/driver level issue and you might want to cross check with mvines as well.

if the reboot with firefox OS blue screen only, then probably need you to provide more information on how it can be reproduced. Thanks
Flags: needinfo?(mvines)
Michael, does this need to be tef+ ?
(clearing tef+ until we have more info on this bug)
blocking-b2g: tef+ → ---
Flags: needinfo?(mvines)
(Reporter)

Comment 13

5 years ago
We try again, it also can be reproduced. 
1.first insert China Unicom Usim card.
2.we first turn on Data connection and set APN as 3gnet in Data connection.
3.Then we turn off Data connection;
4.go into data settings to modify APN as 3gwap which also the correct APN of China Unicom and tap OK;
5.turn on data connection in cellular& Data.
6.The system reboots.
we add a video to show this issue.
Flags: needinfo?(Firefox_Mozilla)
OK, thanks.  Assigning this to Anshul to triage further.  Would be good to know exactly what "system reboots" means though.  Is the main b2g process crashing, or are we talking about full system crash?
Assignee: kaze → anshulj
blocking-b2g: --- → tef+

Comment 15

5 years ago
Phil, please have a look at this issue.
Flags: needinfo?(pgravel)
(Reporter)

Comment 16

5 years ago
Created attachment 725238 [details]
video

Comment 17

5 years ago
The reboot logs seems to be junk. Could the reporter please provide android main logs and the radio logs.

 adb logcat -b radio -b main -v time
(Assignee)

Comment 18

5 years ago
Reproduced, will have a fix ready for it soon.
Flags: needinfo?(pgravel)
Assignee: anshulj → pgravel
(Assignee)

Comment 19

5 years ago
Additional checks have been added to the ril to prevent crashes, but the following patch is necessary in network manager to fix root cause.

diff --git a/dom/system/gonk/NetworkManager.js b/dom/system/gonk/NetworkManager.js
index 469f358..a070815 100644
--- a/dom/system/gonk/NetworkManager.js
+++ b/dom/system/gonk/NetworkManager.js
@@ -471,7 +471,7 @@ NetworkManager.prototype = {
       dns2: network.dns2,
       gateway: network.gateway,
       httpproxy: network.httpProxyHost,
-      mmsproxy: Services.prefs.getCharPref("ril.data.mmsproxy")
+      mmsproxy: Services.prefs.getCharPref("ril.mms.mmsproxy")
     };
     this.worker.postMessage(options);
   },
@@ -485,7 +485,7 @@ NetworkManager.prototype = {
       dns2: network.dns2,
       gateway: network.gateway,
       httpproxy: network.httpProxyHost,
-      mmsproxy: Services.prefs.getCharPref("ril.data.mmsproxy")
+      mmsproxy: Services.prefs.getCharPref("ril.mms.mmsproxy")
     };
     this.worker.postMessage(options);
   },


Using the wrong preference name was causing a run-time exception:
03-18 14:13:41.909   124   124 E GeckoConsole: [JavaScript Error: "[Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: jar:file:///system/b2g/omni.ja!/components/NetworkManager.js :: addHostRoute :: line 483"  data: no]" {file: "jar:file:///system/b2g/omni.ja!/components/NetworkManager.js" line: 483}]
This caused RegisterNetworkInterface() to quit early and return -1, even though it actually did register the network interface.
Assignee: pgravel → nobody
seems like this is something that will be fixed in partners ril.
:pgravel, are you not able to fix this and requires other to fix it?
Flags: needinfo?(pgravel)
(Assignee)

Comment 21

5 years ago
:jcheng - We can prevent the actual crash, but it remains a significant problem that RegisterNetworkInterface fails due to the error posted above. Because of the thrown exception the host routing does not occur, serveral NetworkManager internal functions are not being called and no observer notifications are sent. It's a bit of a stroke of luck that things work at all.
Flags: needinfo?(pgravel)

Comment 22

5 years ago
@jcheng, can you please appropriate Moz person to fix the network manager issue pgravel pointed to in comment #19?
What's the user impact when the crash is prevented? Have you observed any? If not, I'd suggest we not block on this bug.
blocking-b2g: tef+ → tef?
Phil will work a patch for the Gecko fix described in comment 19
Assignee: nobody → pgravel
blocking-b2g: tef? → tef+

Comment 25

5 years ago
This network manager issue pgravel said in comment #19 was fixed in Bug 817945. But the patch was only landed on B2G18 and m-c.
Should we mark bug 817945 as tef+ so it gets onto 1.0.1?
oh, nice.  this bug is resolved then, and I'll mark bug 817945 for uplift to 1.0.1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(fix for this bug is NPOTB)
status-b2g18-v1.0.1: --- → fixed
Whiteboard: [triaged:3/1] → [triaged:3/1] [NPOTB]
(Assignee)

Updated

5 years ago
Duplicate of this bug: 850605
(In reply to Michael Vines [:m1] [:evilmachines] from comment #28)
> (fix for this bug is NPOTB)

assuming that the same fix is on v1-train... please set the flag back if it isn't
status-b2g18: --- → fixed

Comment 31

5 years ago
There is a test case that covers this issue:
https://moztrap.mozilla.org/manage/cases/?filter-id=4029
Flags: in-moztrap-

Updated

5 years ago
Whiteboard: [triaged:3/1] [NPOTB] → [triaged:3/1] [NPOTB] QARegressExclude
The uplift of bug 817945 has caused a severe regression (see bug 856997). Can we look for an alternative solution?
Flags: needinfo?(mvines)

Comment 33

5 years ago
Cannot verify, need steps/ information on what to change once in the APN screen.
Can you verify this fix for this patch?
Flags: needinfo?(Firefox_Mozilla)
Keywords: verifyme
(Reporter)

Comment 35

5 years ago
Yes, we use the new build version and can not reproduce. Thank you!
Flags: needinfo?(Firefox_Mozilla)

Updated

5 years ago
Status: RESOLVED → VERIFIED
Keywords: verifyme
Flags: needinfo?(mvines)
You need to log in before you can comment on or make changes to this bug.