[OPEN_][gallery]the image is reversal when landscape in edit mode.(617002039890)

VERIFIED FIXED in Firefox 22

Status

Firefox OS
Gaia::Gallery
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Firefox_Mozilla, Assigned: diego)

Tracking

unspecified
B2G C4 (2jan on)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:tef+, firefox20 wontfix, firefox21 wontfix, firefox22 fixed, b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 fixed)

Details

(Whiteboard: [triaged:3/1])

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Steps to reproduce:
1.Go into Gallery and select an image to view;
2.tap button to go into eidt mode
3.landscape the phone
Expected results:
1.the image shows correctly;
Actual results:
1. the image shows reversal.
(Reporter)

Updated

5 years ago
Blocks: 845223

Comment 1

5 years ago
QA will verify this issue.
Whiteboard: [triaged:3/1]
(Reporter)

Comment 2

5 years ago
Created attachment 719837 [details]
screenshot
(Reporter)

Comment 3

5 years ago
we add a screenshot to show this issue

Comment 4

5 years ago
Hi, all,

Just update the test result. FYR.
The build: 20130218070201 (Cannot reproduce)
The latest build: 20130304230203 (Cannot reproduce, as attachment)
Could you please provide the build number?
Did the issue cause by special image file?
Thanks!

Comment 5

5 years ago
Created attachment 721288 [details]
Edit image
(Reporter)

Updated

5 years ago
blocking-b2g: --- → tef?
[tef- for now because (1) we have no build information for where this issue is seen, and (2) it can't be reproduced according to comment 4.  Once we have more details on whether this is still an issue at the tip please re-nom for tef+]
blocking-b2g: tef? → -
(Reporter)

Comment 7

5 years ago
we use the new build(mozilla build id:20130304070202, AU031), it also has this bug. it can see screenshot in the attachment.
Diego, can you please try to dup this here?  Given the builds in comment 4 and comment 7 are so close, wondering if perhaps this is a HWC issue?
blocking-b2g: - → tef?
Flags: needinfo?(dwilson)

Comment 9

5 years ago
Hi, all,

Sorry for my jump in.
I tried to reproduce this case today.
But I still cannot reproduce this issue.
Please refer to  the following video. If I misunderstand any steps, please let me know.
https://dc1.safesync.com/LMhMpYZW/Gallery_Edit_Function.3gp?a=o8JZONTVpvM

Build: 20130311070204 (mozilla-b2g18_v1_0_1-unagi-eng)
Gecko-revision="d28b134520501bc1b829f0e225a163a111520c70"
Gaia-revision="f03bc0e8647f94ab133fe813d68500061c147681"

Thanks!


Best Regards,
William
(assigning to Diego pending ni? response as this is blocking next steps here)
Assignee: nobody → dwilson
(tef+ assuming a successful reproduction on the tip CDR codebase by Diego on Monday)
blocking-b2g: tef? → tef+
(Assignee)

Comment 12

5 years ago
I can reproduce when rotating the phone clockwise to landscape with HwcComposer2D enabled. The issue seems to be the rotation calculation in Hwc. I'll investigate and report back
Flags: needinfo?(dwilson)
Diego, were you able to find anything from investigating further?
(Assignee)

Comment 14

5 years ago
I found the problem. HwcComposer2d is not handling the combination of rotation and Y-axis flip at the same time. Since this is an uncommon use case I'll just make it fallback to GPU rendering.
(Assignee)

Updated

5 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 15

5 years ago
Actually, the deeper cause is that the image is not in a shared texture. This is a valid use case but not supported in HwcComposer2D.

The solution is to look for a shared texture before attempting to render with Hwc. The patch is on its way.
(Assignee)

Updated

5 years ago
Blocks: 850567
(Assignee)

Comment 16

5 years ago
Created attachment 728527 [details] [diff] [review]
Verify the buffer descriptor is a shared texture
Attachment #728527 - Flags: review?(ncameron)
Attachment #728527 - Flags: review?(jgilbert)
(Assignee)

Comment 17

5 years ago
Firefox_Mozilla@126.com,

Can you try out the patch?

Comment 18

5 years ago
Comment on attachment 728527 [details] [diff] [review]
Verify the buffer descriptor is a shared texture

Review of attachment 728527 [details] [diff] [review]:
-----------------------------------------------------------------

Do we need to do something similar for the other layer types?
Attachment #728527 - Flags: review?(ncameron) → review+
(Assignee)

Comment 19

5 years ago
(In reply to Nick Cameron [:nrc] from comment #18)
> Do we need to do something similar for the other layer types?

Looks like ThebesLayer is missing this check too. Others already do. Good catch!
I am not showing the image in reverse, I am seeing that it stretches in different orientations and changes the image when I select effects in the v1 train build on unagi

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/dec694d585e1
Gaia   5a31a56b96a8fc559232d35dabf20411b9c2ca1d
BuildID 20130325070203
Version 18.0
Duplicate of this bug: 850567
Flags: in-moztrap?
Keywords: testcase-wanted
(Assignee)

Comment 22

5 years ago
Created attachment 729320 [details] [diff] [review]
Verify the buffer descriptor is a shared texture

Same as the patch r+'ed by ncameron only in hg friendly patch format. Carry over r+
Attachment #728527 - Attachment is obsolete: true
Attachment #728527 - Flags: review?(jgilbert)
Attachment #729320 - Flags: review+
(Assignee)

Updated

5 years ago
status-b2g18: --- → affected
status-b2g18-v1.0.1: --- → affected
Keywords: checkin-needed
#6862 test case created in moztrap to cover this use case.
Flags: in-moztrap? → in-moztrap+
Keywords: testcase-wanted
https://hg.mozilla.org/integration/mozilla-inbound/rev/f76635ab8c2b
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/f76635ab8c2b
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → B2G C4 (2jan on)
Keywords: checkin-needed
https://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/67586fc4ad0d
https://hg.mozilla.org/releases/mozilla-b2g18/rev/fe53f54c3ff2
status-b2g18: affected → fixed
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: affected → fixed
status-firefox20: --- → wontfix
status-firefox21: --- → wontfix
status-firefox22: --- → fixed
Keywords: checkin-needed

Comment 27

5 years ago
Verified Fixed on Unagi:
The device enters landscape mode and screen orientation is displayed correctly

Unagi Build ID: 20130329070203
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/56c922308fd1
Gaia: 0a9f78bffafda93a159c1f502e8b110c2f49a500
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.