Closed Bug 846241 Opened 8 years ago Closed 3 years ago

Lazy-load installation and update related code in XPIProvider

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1363925

People

(Reporter: Unfocused, Unassigned)

References

Details

Bug 746916 made XPIDatabase lazy-loaded, but there's also all the installation and update related code that should be pretty easy to lazy-load - and that depends on XPIDatabase anyway.

So that's:
* RDF functions
* AddonInstall
* AddonInstallWrapper
* UpdateChecker
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1363925
You need to log in before you can comment on or make changes to this bug.