Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 719114
5 years ago
5 years ago

People

(Reporter: MihaiMorar, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

5 years ago
It's #44 top browser crasher in FF 20.b1

Here is the first frames of the stack traces:

Frame	Module	      Signature	            Source
0	mozjs.dll     js::gc::Mark<JSAtom>  js/src/gc/Marking.cpp:213
1	mozjs.dll     fun_trace	            js/src/jsfun.cpp:527
2	mozjs.dll     js::GCMarker::processMarkStackTop	           js/src/gc/Marking.cpp:1433
3	mozjs.dll     js::GCMarker::drainMarkStack	js/src/gc/Marking.cpp:1477
4	mozjs.dll     IncrementalCollectSlice	js/src/jsgc.cpp:3998
5	mozjs.dll     GCCycle	                js/src/jsgc.cpp:4165
6	mozjs.dll     js::GCSlice        	js/src/jsgc.cpp:4321
7	mozjs.dll     js::IncrementalGC  	js/src/jsfriendapi.cpp:190
8	xul.dll	      nsJSContext::GarbageCollectNow	dom/base/nsJSEnvironment.cpp:2959
9	xul.dll	      InterSliceGCTimerFired	dom/base/nsJSEnvironment.cpp:3280
10	xul.dll	      nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:482

More reports: 

https://crash-stats.mozilla.com/report/list?range_value=7&range_unit=days&date=2013-02-27&signature=js%3A%3Agc%3A%3AMark%3CJSAtom%3E&version=Firefox%3A20.0b1
(Reporter)

Comment 1

5 years ago
Signature	js::gc::Mark<JSAtom> More Reports Search
UUID	d7fada40-94ba-471b-99d0-a9aea2130228
Date Processed	2013-02-28 09:33:26
Uptime	321
Last Crash	34.0 minutes before submission
Install Age	 3.0 days since version was first installed.
Install Time	2013-02-25 09:39:09
Product	Firefox
Version	20.0
Build ID	20130220104816
Release Channel	beta
OS	Windows NT
OS Version	5.1.2600 Service Pack 2
Build Architecture	x86
Build Architecture Info	GenuineIntel family 15 model 6 stepping 5
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x0
User Comments	
App Notes	
AdapterVendorID: 0x8086, AdapterDeviceID: 0x2972, AdapterSubsysID: 73361462, AdapterDriverVersion: 6.14.10.4926
Adapter Vendor ID	0x8086
Adapter Device ID	0x2972
Total Virtual Memory	2147352576
Available Virtual Memory	1707294720
System Memory Use Percentage	92
Available Page File	1925644288
Available Physical Memory	38707200
Crash Signature: js::gc::Mark<JSAtom>
OS: Windows 7 → Windows XP
(Reporter)

Updated

5 years ago
Keywords: crash
(Reporter)

Updated

5 years ago
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core

Comment 2

5 years ago
It's likely another form of bug 719114.
Crash Signature: js::gc::Mark<JSAtom> → [@ js::gc::Mark<JSAtom> ]
Hardware: x86_64 → x86
Version: 20 Branch → Trunk
(Reporter)

Comment 3

5 years ago
(In reply to Scoobidiver from comment #2)
> It's likely another form of bug 719114.

I've seen that but I think it's not a duplicate of bug 719114. That's why I filed this bug.

Comment 4

5 years ago
(In reply to MarioMi (:MarioMi) from comment #3)
> I've seen that but I think it's not a duplicate of bug 719114. That's why I
> filed this bug.
It's not exactly a duplicate but the third frame is the crash signature of bug 719114. All GC crashes are related.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 719114
You need to log in before you can comment on or make changes to this bug.