[OPEN_][call log]some call log can not be delete.(617002041389)

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: Firefox_Mozilla, Assigned: gtorodelvalle)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.1 verified)

Details

(Whiteboard: [triaged:3/1] QARegressExclude)

Attachments

(5 attachments)

(Reporter)

Description

6 years ago
Created attachment 719412 [details]
logs

Steps to reproduce:
1.using IM to make a call to test device(the number is 075526772333 );
2.the test device answer the call and then hang up;
3.go into dialer-call log. Tap edit button and select all to delete;
4.close Caller Identification of sim card.
5.using other phones to make a call to test device;
6.answer or hang up this call(It is shown “unknown number” in call log).
7.go into dialer-call log. Tap edit button and select all to delete;
Expected results:
1.in step3 and step7, the call log can be deleted successful;
Actual results:
1.in step3 and step7, the call log can be not deleted;
(Reporter)

Comment 1

6 years ago
Created attachment 719413 [details]
screen shot
(Reporter)

Updated

6 years ago
Blocks: 845223
QA will verify this issue.
Whiteboard: [triaged:3/1]
Hi, all,

I have double confirmed this case.
The build: 20130218070201 (Cannot reproduce)
The build: 20130304230203 (Latest build, I also cannot reproduce)
Could you please provide the build number?
Thanks!
(Reporter)

Updated

6 years ago
blocking-b2g: --- → tef?
[tef- for now because (1) we have no build information for where this issue is seen, and (2) it can't be reproduced according to comment 3.  Once we have more details on whether this is still an issue at the tip please re-nom for tef+]
blocking-b2g: tef? → -
(Reporter)

Comment 5

6 years ago
we use the new build(mozilla build id:20130304070202, AU031), it also can reproduce this bug.
we first close Caller Identification. Then use other device to call us. After end call, it will has a record which shown "unknown number" in call log. But when we tap edit button and tap "select all" to delete all call logs, "Unknown number" can not be deleted and also shown in call logs.
Hey Anshul, any chance this may be us?
blocking-b2g: - → tef?
Flags: needinfo?(anshulj)
German, can you have a look at this one? Please use v1.0.1 build to test it!
Hi, all,

Sorry for my jump in.
I tried to reproduce this case today.
But I still cannot reproduce this issue.
Please refer to  the following video. Did I miss any steps?
https://dc1.beta.safesync.com/LMhMpYZW/Call_Log.3gp?a=VS6QD5GSfNo

Build: 20130311070204 (mozilla-b2g18_v1_0_1-unagi-eng)
Gecko-revision="d28b134520501bc1b829f0e225a163a111520c70"
Gaia-revision="f03bc0e8647f94ab133fe813d68500061c147681"

Thanks!


Best Regards,
William
Having a look at it... ;-)
Still having a look at it but let me share with you (if it helps) that there are only 2 cases when "Unknown number" is shown in the Call Log and both are (or should be) kind of "unusual":
1. There is an entry in the call registry IndexedDB with no number (way weird :-p) -> https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/js/recents.js#L554
2. The Utils.getPhoneNumberPrimaryInfo() function returns null (which means that there is a contact associated to the phone number, but when we are getting the info to show it in the Call Log this contact does not have a name, either a company, either a matching phone number (the one which caused match with the contact)) -> https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/js/recents.js#L669 (probably even weirder than the previous one)

Firefox_Mozilla@126.com , could you shed light on which of the scenarios you may be in? Thanks!

On the other hand, I get exactly the same behavior as William, this is, for me it is working fine ;-)
Flags: needinfo?(Firefox_Mozilla)
Hi, all,

Sorry! My bad.
Thanks for you reminder and help.
I reproduced this case at Taiwan site.
You point out an important information.
The incoming call must be "Unknown number"
If user(caller) hide the phone number then dial up, the receiver(test device) will show "Unknown number" and the record cannot be deleted.
I attached the video for your reference.
Thanks again!
----------------------------------------------
The reproduced steps.
1. Make a call to test device.
   (Please dial "#31#your_phone_number" at Taiwan site, the "#31#" can hide your phone number.)
2.The test device answer the call then hang up;
3.Go into dialer-call log. Tap "Edit" button and select all call log to delete
Created attachment 723888 [details]
Unknown - Call log
In fact, I just noticed that I am not able to call any phone number using the #31# prefix using the latest Gaia... I guess you called from another platform to the test device :-)

In case it gets confirmed, I'll fill a bug about that :-)
Yes, I called from another phone to the test device.
Appreciate your help! Have a nice day! :)

Best Regards,
William
Damn it! I just confirmed that we do not correctly deal with "hidden/unknown calls" no only when deleting them but also when grouping them... ;-999 I just filled bug 850170
Depends on: 850170
I have this one fixed. Waiting on bug 850170 and the final grouping criteria for the "hidden calls" to delete the concrete entries depending on this grouping ;-)
blocking-b2g: tef? → tef+
Flags: needinfo?(anshulj)
Assignee: nobody → gtorodelvalle
status-b2g18: --- → affected
status-b2g18-v1.0.1: --- → affected
Created attachment 724357 [details]
Associated PR.
Attachment #724357 - Flags: review?(fbsc)
Attachment #724357 - Flags: review?(fbsc) → review?(jmcf)
Comment on attachment 724357 [details]
Associated PR.

r+ provided the comments in GH are addressed, particularly code clarity in selector generation
Attachment #724357 - Flags: review?(jmcf) → review+

Updated

6 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Merged! ;-) Thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Uplifted commit 9f410bd165e5e7b20790f6b9c4c00ccb7fddd567 as:
v1-train: f5aaa4e7652383ca66ece07d5b61f56709d91efd
v1.0.1: 176c7354461055307c80b583333bce696462ea2e
status-b2g18: affected → fixed
status-b2g18-v1.0.1: affected → fixed
(Reporter)

Comment 22

6 years ago
we now only have the version(build id:20130310070203) which also has this issue. Later we will check in new build.
Flags: needinfo?(Firefox_Mozilla)

Comment 23

6 years ago
This is verified fixed in Unagi MC Build 

Unagi Build ID: 20130328031116
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/mozilla-central/rev/962f5293f87f
Gaia: 2ca952bcca39eda4fa6693ee53cf8c7ec8a3bdcc

However issue still repros in 

Verified fixed on 
Unagi Build ID: 20130329070203
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/56c922308fd1
Gaia: 0a9f78bffafda93a159c1f502e8b110c2f49a500

and

Unagi Build ID: 20130329070203
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/5cc5df16447a
Gaia: 26b463f14caa11e0fc64fda09a17054da4bea68b

Updated

6 years ago
status-b2g18: fixed → verified

Updated

6 years ago
status-b2g18: verified → fixed

Comment 24

6 years ago
There is already a test case that covers this issue:
https://moztrap.mozilla.org/manage/cases/?filter-id=1307
Flags: in-moztrap-
Hi, Darren,

Thanks for your information(test case).
But the test steps seems to miss a trigger point of the bug.
Could we add some step below on it or create a new case to test it?

Title: [CALL LOG] Select and delete a "Unknown" call log
Description: It should be possible to select and delete call logs.
Precondition: Prepare two cell phone, we called Phone-A and Phone-B.
Steps:
1. Phone-B hide the phone number before dial up.
1. Use Phone-B to make a call to call Phone-A.
( On GSM system, you can append #31# before the phone number to hide your phone number
  ex: #31#0978725115, etc...
)
2. Phone-B hang up the call before Phone-A answer it.
3. Phone-A call log will show a record-"Unknown number", please delete the call log

Expected result:
The call log can be deleted.

Thanks! :)

Best Regards,
William
Hi John! I found some weird issues regarding this bug, its patch and mainly the uplifting :-O Basically, I am not able to find in Github the commits related to the uplifting to v1-train either to v1.0.1. Although the hash of the commit made to master is right (https://github.com/mozilla-b2g/gaia/commit/06e0e5ce42bdfb62bdbe38271de6b5b2d9e40e75), the one made to v1-train is not (https://github.com/mozilla-b2g/gaia/commit/06e0e5ce42bdfb62bdbe38271de6b5b2d9e40e75 returns a 404 code) as well as the one made to v1.0.1 (https://github.com/mozilla-b2g/gaia/commit/176c7354461055307c80b583333bce696462ea2e returns a 404 code). Am I missing anything here? Has this patch been uplifted to v1-train and v1.0.1? Thanks!
Flags: needinfo?(jhford)
(In reply to gtorodelvalle from comment #26)
> Hi John! I found some weird issues regarding this bug, its patch and mainly
> the uplifting :-O Basically, I am not able to find in Github the commits
> related to the uplifting to v1-train either to v1.0.1. Although the hash of
> the commit made to master is right
> (https://github.com/mozilla-b2g/gaia/commit/
> 06e0e5ce42bdfb62bdbe38271de6b5b2d9e40e75), the one made to v1-train is not
> (https://github.com/mozilla-b2g/gaia/commit/
> 06e0e5ce42bdfb62bdbe38271de6b5b2d9e40e75 returns a 404 code) as well as the
> one made to v1.0.1
> (https://github.com/mozilla-b2g/gaia/commit/
> 176c7354461055307c80b583333bce696462ea2e returns a 404 code). Am I missing
> anything here? Has this patch been uplifted to v1-train and v1.0.1? Thanks!

I'm not sure what's going on here.  The commit you are referring to is not mentioned in this bug at all (06e0e5ce42bdfb62bdbe38271de6b5b2d9e40e75) before you mentioned it.

$ git branch --contains 06e0e5ce42bdfb62bdbe38271de6b5b2d9e40e75
* v1-train

The two commits from comment 21 weren't present and I'm not sure how or why they aren't.

I have redone the uplift:
v1-train: afb2e21c5f00cdac589e897976b0bfa1c6ab1a13
v1.0.1: b3eacf6db5d0f6c9d16f4e5f71acc0dcbecba534
Flags: needinfo?(jhford)

Comment 29

6 years ago
Verify requires International Sim
Whiteboard: [triaged:3/1] → [triaged:3/1] QARegressExclude
Jeez! My fault... ;-999 It seems I copied the wrong commits into my comment 26 probably due to having too many tabs open in my browser :-( I was referring to https://github.com/mozilla-b2g/gaia/commit/9f410bd165e5e7b20790f6b9c4c00ccb7fddd567 (which exists) and https://github.com/mozilla-b2g/gaia/commit/f5aaa4e7652383ca66ece07d5b61f56709d91efd and https://github.com/mozilla-b2g/gaia/commit/176c7354461055307c80b583333bce696462ea2e which do not. Thanks John for the new uplifting! ;-)

Updated

6 years ago
Keywords: verifyme

Comment 31

6 years ago
Can the reporter please verify this fix?  It requires your SIM and network.
Flags: needinfo?(Firefox_Mozilla)
Sorry for my jump in. Verified this bug.
Great! Happy to know we fixed the bug. Have a nice weekend.
Attach the screenshot.

* Test build:
1. mozilla-central-unagi/2013/04/2013-04-05-10-34-53
   -Mercurial-Information:
     + Gecko revision="40a228f74389"
     + Gaia revision="fc2f77af69be"
   - Git-Information:
     + Gecko revision="39839490f961009f7d0e259d85e6931cfd11263d"
     + Gaia revision="3f824d1dcb15c2c2f3e90483adc9f9d01f122477"

2. mozilla-b2g18_v1_0_1-unagi-eng/2013/04/2013-04-05-23-02-04
   -Mercurial-Information:
     + Gecko revision="18a7bfbdedd2"
     + Gaia revision="f6f9fdf86a5c"
   - Git-Information:
     + Gecko revision="fe6592bf7a145bdb6a0cc06a73879ab05ca4ef15"
     + Gaia revision="28c144fa7e8061ee6bcbbb47ca911ef33b87814b"


Best Regards,
William
Created attachment 734219 [details]
Deleting unknown call log
(Reporter)

Comment 34

6 years ago
we use the new build version and this issue has been fixed. Thanks!
Flags: needinfo?(Firefox_Mozilla)

Updated

6 years ago
Duplicate of this bug: 845706

Comment 36

6 years ago
Verified on an Inari with the following build information :

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/6bac24e14538
Gaia   c883af5ecd0998f78d9aaa4c2337c842e1dbb5a0
BuildID 20130416070200
Version 18.0

Issue did not reoccur

Updated

6 years ago
Status: RESOLVED → VERIFIED
status-b2g18-v1.0.1: fixed → verified
Keywords: verifyme
Shally, can you paste the revisions against which you verified?
Flags: needinfo?(lixia)
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #37)
> Shally, can you paste the revisions against which you verified?

Hi Johan,
 
    According to Comment 36 ,I delete the "Verifyme" in keywords and change "status-b2g18-v1.0.1: fixed" to "verified". And I can't verify this bug because I have no “b2g18-v1.0.1” device.
Flags: needinfo?(lixia) → needinfo?(jlorenzo)
Yes, these bugs were filed against really old versions. I was curious on how you'd verify this one :)

To make things more clear, I would suggest to put an additional comment like "Per comment X" when you flip an old status flag like this one. What do you think?
Flags: needinfo?(jlorenzo)
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #39)
> Yes, these bugs were filed against really old versions. I was curious on how
> you'd verify this one :)
> 
> To make things more clear, I would suggest to put an additional comment like
> "Per comment X" when you flip an old status flag like this one. What do you
> think?

OK, thank you very much.
You need to log in before you can comment on or make changes to this bug.