0.9.1-sea build for Linux has non-working talkback

RESOLVED DUPLICATE of bug 98905

Status

--
major
RESOLVED DUPLICATE of bug 98905
18 years ago
10 years ago

People

(Reporter: andre.bugs2, Assigned: namachi)

Tracking

({qawanted})

Trunk
x86
Linux
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
The sea installer build for linux, pointed at on www.mozilla.org, does not have
working talkback support. Mozilla crashes and talkback does not catch it. This
has been the case for a very long time, and it needs to be fixed now.

This is very serious, because you are missing out on valuable crash data from
all linux crashes, unless people get the non-sea version. Mozilla.org
specifically requests you to use a talkback enabled build, and then points at
the broken -sea version...

To reproduce:

1) Get the 0.9.1 sea version, and choose talkback during installation.

2) Perform steps to crash mozilla (how hard can that be?:-)

Result: Talkback does not catch the crash

Expected results: Talkback catches the crash, and lets to send in a report.

Comment 1

18 years ago
I can't reproduce this... are you sure you're installing talkback? I'm using the
-sea file from the ftp site and it works for me when i kill a mozilla-bin
process with SEGV.

If you aren't doing complete install, i recommend trying that and seeing if
talkback still doesn't come up for you...

are you seeing QFA initialize on the console?

Comment 2

18 years ago
The talkback also failed to start when using Win32 Nightly build.
I got that from
http://ftp.mozilla.org/pub/mozilla/nightly/2001-06-08-09-trunk/mozilla-win32-talkback.zip
(Reporter)

Comment 3

18 years ago
[This is with -sea version of 0.9.1 for linux]

I have investigated this further, and it appears that talkback catches most
crashes, but not the craser I saw first. To reproduce this uncaught crash, do
the following:

1) Go to http://www.skribofont.se

2) Click on the blue button "GoatTalk". That will take you to a forum.

3) Click on the "Hård- och mjukvara" category to the left

4) Click on the icon named "Ny" on the bottom right.

5) Type something in the editbox that comes up, and press "Skicka".

Result: Mozilla will crash AND talkback will not catch the crash. The output on
the console is the following:

Gdk-ERROR **: BadWindow (invalid Window parameter)
  serial 115298 error_code 3 request_code 15 minor_code 0

This crash might very well have been reported before, but this bugreport is
about talkback not catching it.

Could someone please try if they can reproduce the above? I tried some other
crashers, and talkback caught those just fine.

Comment 4

18 years ago
I tried on win98 and also could not reproduce any crash using the steps 
above.

Comment 5

18 years ago
You don't need to generate a crash to see this bug.

As in my case for Win32 build, I simply run "component/talkback.exe" and
talkback agent simply don't show up at all.  Can't see it in the task list too.
(Assignee)

Comment 6

18 years ago
I am re-produce the crash using the steps you mentioned in the bug. I tried it
in RedHat 7.1

Reg. Talkback not working, I need more specific information on which
build and platform.

(Assignee)

Comment 7

18 years ago
Mozilla Milestone 0.91 build on Win32 running components/talkback.exe brings
up the talkback ui for me(not the crash UI) but the Agent UI.

(Assignee)

Comment 8

18 years ago
I am NOT able to reproduce the crash with the given steps in RedHat Linux 
version 7.1. My earlier comment was wrong.
Keywords: qawanted

Comment 9

18 years ago
Win98 seems to have the same sort of problem in 2001-06-18-04 build.  Would a
separate report be preferable?  There is a crash, then Talkback does nothing.

This bug (if it's the same one) is preventing bug 83546 from being anything
other than a WORKSFORME, when I'm quite sure there is a reproduceable crash.
Blocks: 83546
(Reporter)

Comment 10

17 years ago
I filed bug #98905 when I saw this happen again on 2001-09-07-21 on linux. I
couldn't remember the bugnumber for this bug then. Anyway, I would prefer if
this bug was closed in favor of that bug, since I have provided better
information there.
(Reporter)

Comment 11

17 years ago

*** This bug has been marked as a duplicate of 98905 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: Talkback Client → Talkback Client
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.