BaselineCompiler: Assertion failure: !vp.isMagic(), at jsobj.cpp:3650

RESOLVED DUPLICATE of bug 846330

Status

()

Core
JavaScript Engine
--
major
RESOLVED DUPLICATE of bug 846330
5 years ago
5 years ago

People

(Reporter: decoder, Unassigned)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Other Branch
x86
Linux
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [jsbugmon:update,ignore])

(Reporter)

Description

5 years ago
The following testcase asserts on baseline compiler branch revision a261716e1b62 (run with --ion-eager):


function strictNestedEval(code, p) {
  function inner() { eval(code); }
  inner();
}
a1 = strictNestedEval("1", 2);
a2 = strictNestedEval("arguments");

Updated

5 years ago
Depends on: 846330
(Reporter)

Updated

5 years ago
Whiteboard: [jsbugmon:update] → [jsbugmon:update,ignore]
(Reporter)

Comment 1

5 years ago
JSBugMon: The testcase found in this bug no longer reproduces (tried revision f8f0facf81ec).
Bug 846330 fixed this. Setting in-testsuite+ since the testcase added in that bug is just slightly modified from the one in comment 0 and triggered the same assert on the baseline branch.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite+
Resolution: --- → DUPLICATE
Duplicate of bug: 846330
You need to log in before you can comment on or make changes to this bug.