Closed Bug 846343 Opened 7 years ago Closed 7 years ago

Thunderbird forwards some emails as attachments even when forwarding messages is set to inline

Categories

(Thunderbird :: Mail Window Front End, defect)

17 Branch
x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 745919

People

(Reporter: edl, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

Click forward button in the message body window to begin forwarding of a plain text email message. Not that on the composition settings tab, forwarding is set to 'inline' and 'add extensions to filename' is unchecked


Actual results:

Original message text appears quoted in body of new message, with space above for new comments, but a new attachment named "Attached message part" is also created. The file size is reported as 8.5K, but on the receiving end (after sending the message), the file size is reported as 26 bytes and appears to be empty.


Expected results:

Per settings, message should have appeared as quoted text in the body of the new message, with space at the top to add comments - no attachment should have been created.
Attachment #719504 - Attachment mime type: application/octet-stream → text/plain
Attached .eml starts with following lines.
> X-Account-Key: account7
> X-UIDL: GmailId13d2164dcc2b7962
> X-Mozilla-Status: 0001
> X-Mozilla-Status2: 00000000
> X-Mozilla-Keys:
This .eml file of a mail is saved at mail folder of Gmail's POP3 account?

If so, phenomenon you see is Bug 745919, because the mail is text/plai mail with no Content-Type: header and your operation is inline formard.

By the way, why forward such mail in inline multiple times, even though initial mail is normal "Content-Type: multipart/report;" mail for reporting spam mail?
Yes, I would agree that it is the same as that bug, and yes it passed through the Gmail system via google apps before hitting a Thunderbird inbox. The multiple forwards can't be helped - the spam reports are sent to our upline carrier, who fowards them to us, and then we forward them to the correct recipient automatically using Thunderbird filters.

Perhaps a switch or checkbox could be added to the Options UI to prevent the creation of empty attachments....
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 745919
You need to log in before you can comment on or make changes to this bug.