Camera video recordings also generate a JPEG

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
6 years ago
5 years ago

People

(Reporter: diego, Assigned: djf)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18-)

Details

(Reporter)

Description

6 years ago
All /sdcard/DCIM/XXXMZLLA/VID_XXXX.3gp video recordings also have a corresponding /sdcard/DCIM/XXXMZLLA/VID_XXXX.jpg next to them.

I assume this is for thumbnail purposes but it may be confusing for the user to see a snapshot they didn't take. Perhaps it can be moved to a tmp folder or hidden?

Updated

6 years ago
Component: Gaia::Video → Gaia::Camera
QA Contact: mozillamarcia.knous → jhammink
(Assignee)

Comment 1

6 years ago
I would have sworn that I filtered those out.  Are they really appearing in the gallery?

If so, its a trivial fix and my screwup. Please assign to me and nominate for an appropriate branch.

Sorry!

Comment 2

6 years ago
djf: don't see the image in the gallery, just in the DCIM folder. Do those images have to be in DCIM?
(Assignee)

Comment 3

6 years ago
Inder,

No, I don't think they *have* to be in DCIM, but the DCF standard seems to suggest doing it this way.  According to DCF, VID_XXXX.3gp and VID_XXX.jpg are two parts of the same virtual "file".  

Diego is right, by the way, the jpg file serves as a poster image for the video. It is a critical optimization that we use in the Camera, Gallery and Video apps.
(Reporter)

Comment 4

6 years ago
@djf,

Fair enough. Is there some DCIM doc we can point our testers to?
(Assignee)

Comment 5

6 years ago
Diego,

See:

http://en.wikipedia.org/wiki/Design_rule_for_Camera_File_system
http://www.cipa.jp/english/hyoujunka/kikaku/pdf/DC-009-2010_E.pdf

A closer reading of the spec now indicates that to conform, I need to change those video thumbnails to have a .THM extension, so I'm glad you filed this bug.

Doug: can we add ".THM" to the list of recognized extensions for the device storage pictures area?

This is a spec compliance and correctness issue with an easy fix.  Nominating it for tracking-b2g18. Diego, I'll leave it to you to nominate it for tef or shira if you see appropriate.
tracking-b2g18: --- → ?
Flags: needinfo?(doug.turner)
(Assignee)

Updated

6 years ago
Assignee: nobody → dflanagan

Updated

6 years ago
blocking-b2g: --- → tef?
(clearing tef?, a nice to have but not blocking from over here at least)
blocking-b2g: tef? → ---

Comment 7

6 years ago
djf - .THM is fine.  This is what I read the extension type to mean:

"""
In the past this extension was used by programs such as Picture Publisher and PhotoMagic for thumbnails. Today the most likely application would be the camera application on the Apple iPhone where the .THM file (thumbnail) would be paired with an .MP4 file for video.
"""

File a bug or send me a patch :)
Flags: needinfo?(doug.turner) → needinfo?

Comment 8

6 years ago
We don't think this meets our user impact bar for v1, but this can always be investigated for v2 (master/mozilla-central).
tracking-b2g18: ? → -
Flags: needinfo?
(Reporter)

Comment 9

6 years ago
Looks like I'm the only that complained about this, so nevermind
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 866384
Duplicate of this bug: 902752
You need to log in before you can comment on or make changes to this bug.