[Dialer] keypad freezes after dialing invalid number

RESOLVED FIXED

Status

Firefox OS
Gaia::Dialer
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: djf, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
STR:

1) Kill and restart the dialer app
2) Press 1 and then the green "call" button to dial it
3) See the screen flash briefly and then continue to show the keypad
4) Try to use the keypad: nothing happens

The user is now completely locked out of the dialer and cannot make calls without killing and restarting it.

This seems to happen almost 100% of the time for me.

I believe the bug is that there is a race condition between the dialog that says "that is not a valid phone number" and the call screen being shown and then being hidden.  When the phone gets into this state, there is an invisible dialog (sometimes you see a flash of it) with an Ok button in the center of the bottom of the screen. So tapping on that invisible button dismisses the dialog and makes the keypad work again.

We've only recently (see bug 836215 and bug 845539) started displaying dialogs for invalid numbers, so this race condition would only have appeared in emergency call mode previously.

I assume that any bug that breaks the dialer has got to be tef+, so I'm going to nominate this.
(Reporter)

Comment 1

5 years ago
Nominating and cc'ing a bunch of people who have touched the dialer recently.

My initial hypothesis was that this might be related to the LazyL10N stuff in the dialer, but it seems to occur even after localization has happened, so now I think it is just a race somehow between the call screen going up, the error dialog going up and the call screen going down (and obscuring the error).

Note that bug 845539 has a pending PR to modify commuications/dialer/js/telephony_helper.js. That patch cleans up the error reporting code in that file a lot, but still displays this bug.
blocking-b2g: --- → tef?
(Reporter)

Comment 2

5 years ago
Neither James or Fabrice can reproduce this on their phones. Setting qawanted to get help determining if this is a real bug or if I've got something messed up on my phone.
Keywords: qawanted
(Reporter)

Comment 3

5 years ago
I've reflashed my phone with the 2/28 unagi nightly. I couldn't reproduce with that.

But when I installed today's gaia, I could reproduce again.  This time the bug only appeared when the dialer was first launched.  After that, if I dismissed the modal dialog with the hidden button then I could not reproduce anymore (though I could see lots of janky switching between call screen and error dialog).

So I'm back to hypothesising about whether this is a regression related to lazy loading. If the localization hasn't been done yet or if the call screen has not appeared yet, that would affect the timing of things.

Its a seriously bad bug. I hope someone else can reproduce it so we can get it fixed!
(Reporter)

Comment 4

5 years ago
I believe that this is a regression caused by bug 816941
Keywords: qawanted → regression
(Reporter)

Updated

5 years ago
Depends on: 816941
Hi David,

I can see the weird switch you comment between the call screen and the dialog, but dialer continues working for me.

bug 816941 already have a patch that I guess is in review, is this still happening if you apply that patch?

Cheers!
Yeah, we found a problem related to bug 816941 and solved it. Can you please rebase and check it again please, David? It works for me ;-) Thanks!
Flags: needinfo?(dflanagan)
(Reporter)

Comment 7

5 years ago
It works for me now.  Thanks. I'll close the bug.
Flags: needinfo?(dflanagan)
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
blocking-b2g: tef? → ---
You need to log in before you can comment on or make changes to this bug.