Clean up column reflow and get rid of mShouldRevertToAuto

RESOLVED DUPLICATE of bug 857324

Status

()

RESOLVED DUPLICATE of bug 857324
6 years ago
5 years ago

People

(Reporter: jwir3, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
During column reflow, when we've detected that we were balancing, but our lowest feasible balance height is > than the computed height of the column set, and we've exceeded the number of columns allowed, we set a flag called 'mShouldRevertToAuto'. This essentially restarts the reflow of columns, causing it to be as though 'column-fill: auto' were set initially, instead of 'column-fill: balance'. 

Instead of performing this series of steps, it's more efficient if we simply proceed with the current reflow operation under the assumption that we're no longer balancing (as the spec says not to balance overflow columns). If we do this, we can clean up the nsColumnSetFrame::ReflowChildren code so that we no longer need the mShouldRevertToAuto flag.
(Reporter)

Updated

5 years ago
Depends on: 861181
(Reporter)

Updated

5 years ago
Depends on: 861182
(Reporter)

Updated

5 years ago
Depends on: 861184
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 857324
You need to log in before you can comment on or make changes to this bug.