Closed Bug 84658 Opened 19 years ago Closed 19 years ago

Crash whith QT-Antialiasing Support

Categories

(Core Graveyard :: Ports: Qt, defect)

x86
Linux
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: Jan.Schubert, Assigned: jcgriggs)

References

Details

(Keywords: crash)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.5 i686; en-US; rv:0.9.1+) Gecko/20010607
BuildID:    0000000000

While building some qt-based versions (from cvs co), i've encounterd a problem
concerning the QT Font-Antialiasing Support. If i enable the QT AA (QT_XFT=1),
mozilla wont start. Instead i get a segemntation fault. If the AA-Option is
disbaled (QT_XFT) starts fine (i've also some other qt-based problems). I guess,
this is just a problem with the qt-build.

Reproducible: Always
Steps to Reproduce:
1.Build mozilla whith these options (from ~/.mozconfig as root):

ac_add_options --disable-logging
ac_add_options --enable-optimize=-O2
ac_add_options --disable-debug
ac_add_options --enable-strip-libs
ac_add_options --without-gtk
ac_add_options --enable-toolkit=qt
ac_add_options --with-qt
ac_add_options --with-qtdir=/usr/lib/qt

2.export QT_XFT=1
3.start mozilla


Actual Results:  segmentation fault

Expected Results:  startup

gcc 2.95.3
KDE 2.2alpha2 (current cvs co)
QT 2.3.0 (cvs co)
please attach a stack trace preferably w/ filenames+line numbers.
Assignee: asa → jcgriggs
Component: Browser-General → XP Toolkit/Widgets
Keywords: crash
QA Contact: doronr → timeless
Reporter, do KDE applications work for you with anti-aliasing turned on?
This is a known bug.  The issue with anti-aliased fonts turns out to be the 
underlying cause of the crash reported in Bugzilla #76033 (mozilla crashes on 
startup if using Qt-libs) and there are patches attached to Bugzilla #78939 
(Unicode font support for Qt Mozilla) that fix this (as well as adding unicode 
charset support to Qt Mozilla).  Please apply those patches and retest...
> Reporter, do KDE applications work for you with anti-aliasing turned on?


Yes. At least konqueror works fine (and looks different than QT_XFT unset).
While having some trouble to compile mozilla again after applying the patches 
everything look fine. Mozilla will start with QT_XFT set and unset (the fonts looks 
different). Unfortunately there are still some other QT-Bugs. I'm still not able to enter 
my mail-passwords (see Bug 84655).

I'm also not sure about the patches. I guess there is at least the line 
nsFontQT*  FindLangGroupPrefFont(nsIAtom *aLangGroup, PRUnichar aChar);
in nsFontMeztricsQT.h missing. Maybe i'd some unusal problems, because there 
was also changes through the cvs-checkout process (after applying the patches the 
first time).

Why are the patches not part of the main/cvs dsitribution ?
> I'm also not sure about the patches. I guess there is at least the line 
> nsFontQT*  FindLangGroupPrefFont(nsIAtom *aLangGroup, PRUnichar aChar);
> in nsFontMeztricsQT.h missing. Maybe i'd some unusal problems, because there 
> was also changes through the cvs-checkout process (after applying the patches 
> the first time).

It looks like I forgot to update the patch for nsFontMetricsQT.h when I update 
the one for the cpp file - D'Oh!!  I am not currently in a position to do 
anything about this, biut as soon as I get my development environment 
re-established I will correct this.

> Why are the patches not part of the main/cvs dsitribution ?

This patch was the last thing I did before leaving Corel.  I have not yet had 
time to shepard it through the review/super-review process (which would have 
identified the same problems you found and allowed me to correct them).  Again, 
as soon as I have my development environment re-established, I will pursue this.

Blocks: qt
This should be fixed now - the patches were checked into CVS last week.  The 
password problem should also be fixed (there was a focus problem that prevented 
text entry widgets from getting keyboard focus)  Please re-test.
Marking WORKSFORME based on lack of response.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
Component: XP Toolkit/Widgets → Ports: Qt
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.