Intermittent test_scroll_selection_into_view.html, test_bug231389.html, test_scroll_event_ordering.html, test_bug287446.html | Assertion count 1 is greater than expected range (Can't allocate graphics resources, aborting subprocess: 'Error')

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({assertion, intermittent-failure})

Trunk
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=20187530&tree=Firefox

Rev3 Fedora 12x64 mozilla-central debug test mochitest-4 on 2013-02-28 09:31:17 PST for push c65d59d33aa8
slave: talos-r3-fed64-046

09:38:44     INFO -  15310 INFO TEST-START | /tests/layout/base/tests/test_scroll_selection_into_view.html
09:38:44     INFO -  ++DOMWINDOW == 60 (0x7258dd8) [serial = 2670] [outer = 0x4194b28]
09:38:44     INFO -  ++DOCSHELL 0x6ca6a30 == 34 [id = 784]
09:38:44     INFO -  ++DOMWINDOW == 61 (0x6dd6fe8) [serial = 2671] [outer = (nil)]
09:38:44     INFO -  [Parent 2273] WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv) && subjPrincipal) failed: file ../../../docshell/base/nsDocShell.cpp, line 8396
09:38:44     INFO -  ++DOMWINDOW == 62 (0x1f60898) [serial = 2672] [outer = 0x6dd6fe8]
09:38:44     INFO -  ++DOMWINDOW == 1 (0xb6bbc8) [serial = 1] [outer = (nil)]
09:38:44     INFO -  [TabChild] SHOW (w,h)= (0, 0)
09:38:44     INFO -  [Parent 2273] ###!!! ASSERTION: Can't allocate graphics resources, aborting subprocess: 'Error', file ../../../dom/ipc/TabParent.cpp, line 1255
09:38:44     INFO -  mozilla::dom::PBrowserParent::OnMessageReceived(IPC::Message const&, IPC::Message*&) [/builds/slave/m-in-l64-d-0000000000000000000/build/obj-firefox/ipc/ipdl/PBrowserParent.cpp:1817]
09:38:44     INFO -  mozilla::dom::PContentParent::OnMessageReceived(IPC::Message const&, IPC::Message*&) [/builds/slave/m-in-l64-d-0000000000000000000/build/obj-firefox/ipc/ipdl/PContentParent.cpp:2447]
09:38:44     INFO -  mozilla::ipc::SyncChannel::OnDispatchMessage(IPC::Message const&) [/builds/slave/m-in-l64-d-0000000000000000000/build/obj-firefox/ipc/glue/../../../ipc/glue/SyncChannel.cpp:148]
09:38:44     INFO -  mozilla::ipc::RPCChannel::OnMaybeDequeueOne() [/builds/slave/m-in-l64-d-0000000000000000000/build/obj-firefox/ipc/glue/../../../ipc/glue/RPCChannel.cpp:400]
09:38:44     INFO -  MessageLoop::RunTask(Task*) [/builds/slave/m-in-l64-d-0000000000000000000/build/obj-firefox/ipc/chromium/../../../ipc/chromium/src/base/message_loop.cc:335]
09:38:44     INFO -  MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const&) [/builds/slave/m-in-l64-d-0000000000000000000/build/obj-firefox/ipc/chromium/../../../ipc/chromium/src/base/message_loop.cc:345]
09:38:44     INFO -  MessageLoop::DoWork() [/builds/slave/m-in-l64-d-0000000000000000000/build/obj-firefox/ipc/chromium/../../../ipc/chromium/src/base/message_loop.cc:442]
09:38:44     INFO -  mozilla::ipc::DoWorkRunnable::Run() [/builds/slave/m-in-l64-d-0000000000000000000/build/obj-firefox/ipc/glue/../../../ipc/glue/MessagePump.cpp:43]
09:38:44     INFO -  nsThread::ProcessNextEvent(bool, bool*) [/builds/slave/m-in-l64-d-0000000000000000000/build/obj-firefox/xpcom/threads/../../../xpcom/threads/nsThread.cpp:627]
09:38:44     INFO -  NS_ProcessNextEvent_P(nsIThread*, bool) [/builds/slave/m-in-l64-d-0000000000000000000/build/obj-firefox/xpcom/build/nsThreadUtils.cpp:238]
09:38:44     INFO -  mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) [/builds/slave/m-in-l64-d-0000000000000000000/build/obj-firefox/ipc/glue/../../../ipc/glue/MessagePump.cpp:83]
09:38:44     INFO -  MessageLoop::RunInternal() [/builds/slave/m-in-l64-d-0000000000000000000/build/obj-firefox/ipc/chromium/../../../ipc/chromium/src/base/message_loop.cc:217]
09:38:44     INFO -  MessageLoop::Run() [/builds/slave/m-in-l64-d-0000000000000000000/build/obj-firefox/ipc/chromium/../../../ipc/chromium/src/base/message_loop.cc:503]
09:38:44     INFO -  nsBaseAppShell::Run() [/builds/slave/m-in-l64-d-0000000000000000000/build/obj-firefox/widget/xpwidgets/../../../widget/xpwidgets/nsBaseAppShell.cpp:165]
09:38:44     INFO -  nsAppStartup::Run() [/builds/slave/m-in-l64-d-0000000000000000000/build/obj-firefox/toolkit/components/startup/../../../../toolkit/components/startup/nsAppStartup.cpp:289]
09:38:44     INFO -  XREMain::XRE_mainRun() [toolkit/xre/nsAppRunner.cpp:3886]
09:38:44     INFO -  XREMain::XRE_main(int, char**, nsXREAppData const*) [toolkit/xre/nsAppRunner.cpp:3952]
09:38:44     INFO -  XRE_main [toolkit/xre/nsAppRunner.cpp:4156]
09:38:44     INFO -  do_main [browser/app/nsBrowserApp.cpp:216]
09:38:44     INFO -  main [browser/app/nsBrowserApp.cpp:524]
09:38:44     INFO -  libc.so.6 + 0x1eb1d
09:38:44     INFO -  firefox + 0x1cd9
09:38:44     INFO -  ###!!! [Parent][SyncChannel] Error: Value error: message was deserialized, but contained an illegal value
09:38:44     INFO -  15311 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target1 into view with vPercent 0, starting at 0
09:38:44     INFO -  15312 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target1 into view with vPercent 100, starting at 0
09:38:44     INFO -  15313 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target1 into view with vPercent -1, starting at 0
09:38:44     INFO -  [Parent 2273] WARNING: pipe error (71): Connection reset by peer: file ../../../ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 431
09:38:44     INFO -  15314 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target1 into view with vPercent 0, starting at 500
09:38:44     INFO -  15315 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target1 into view with vPercent 100, starting at 500
09:38:44     INFO -  15316 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target1 into view with vPercent -1, starting at 500
09:38:44     INFO -  15317 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target2 into view with vPercent 0, starting at 0
09:38:44     INFO -  15318 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target2 into view with vPercent 100, starting at 0
09:38:44     INFO -  15319 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target2 into view with vPercent -1, starting at 0
09:38:44     INFO -  15320 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target2 into view with vPercent 0, starting at 500
09:38:44     INFO -  15321 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target2 into view with vPercent 100, starting at 500
09:38:44     INFO -  15322 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target2 into view with vPercent -1, starting at 500
09:38:44     INFO -  15323 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target3 into view with vPercent 0, starting at 0
09:38:44     INFO -  15324 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target3 into view with vPercent 100, starting at 0
09:38:44     INFO -  15325 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target3 into view with vPercent -1, starting at 0
09:38:44     INFO -  15326 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target3 into view with vPercent 0, starting at 1000
09:38:44     INFO -  15327 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target3 into view with vPercent 100, starting at 1000
09:38:44     INFO -  15328 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target3 into view with vPercent -1, starting at 1000
09:38:44     INFO -  15329 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target4 into view with vPercent 0, starting at 0
09:38:44     INFO -  15330 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target4 into view with vPercent 100, starting at 0
09:38:44     INFO -  15331 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target4 into view with vPercent -1, starting at 0
09:38:44     INFO -  15332 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target4 into view with vPercent 0, starting at 1000
09:38:44     INFO -  15333 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target4 into view with vPercent 100, starting at 1000
09:38:44     INFO -  15334 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target4 into view with vPercent -1, starting at 1000
09:38:44     INFO -  15335 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target5 into view with vPercent 0, starting at 0
09:38:44     INFO -  15336 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target6 into view with vPercent 0, starting at 0
09:38:44     INFO -  15337 INFO TEST-PASS | /tests/layout/base/tests/test_scroll_selection_into_view.html | Scrolling target7 into view with vPercent 0, starting at 0
09:38:44     INFO -  [Parent 2273] WARNING: RemoveObserver() called for unregistered observer: file ../../hal/Hal.cpp, line 205
09:38:44     INFO -  [Parent 2273] WARNING: RemoveObserver() called for unregistered observer: file ../../hal/Hal.cpp, line 205
09:38:44     INFO -  [Parent 2273] WARNING: RemoveObserver() called for unregistered observer: file ../../hal/Hal.cpp, line 205
09:38:44     INFO -  [Parent 2273] WARNING: RemoveObserver() called for unregistered observer: file ../../hal/Hal.cpp, line 205
09:38:44     INFO -  [Parent 2273] WARNING: RemoveObserver() called for unregistered observer: file ../../hal/Hal.cpp, line 205
09:38:44     INFO -  [Parent 2273] WARNING: waitpid failed pid:2345 errno:10: file ../../../ipc/chromium/src/base/process_util_posix.cc, line 260
09:38:44     INFO -  15338 INFO TEST-END | /tests/layout/base/tests/test_scroll_selection_into_view.html | finished in 283ms
09:38:44     INFO -  ++DOMWINDOW == 63 (0x5c1bd28) [serial = 2673] [outer = 0x4194b28]
09:38:44     INFO -  15339 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/base/tests/test_scroll_selection_into_view.html | Assertion count 1 is greater than expected range 0-0 assertions.
Comment hidden (Legacy TBPL/Treeherder Robot)
Reporter

Updated

6 years ago
Duplicate of this bug: 846601
Reporter

Updated

6 years ago
Blocks: 404077
Summary: Intermittent test_scroll_selection_into_view.html | Assertion count 1 is greater than expected range 0-0 assertions (Can't allocate graphics resources, aborting subprocess: 'Error') → Intermittent test_scroll_selection_into_view.html, test_bug231389.html, test_scroll_event_ordering.html | Assertion count 1 is greater than expected range (Can't allocate graphics resources, aborting subprocess: 'Error')
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Reporter

Comment 6

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=20576489&tree=Mozilla-Inbound
Summary: Intermittent test_scroll_selection_into_view.html, test_bug231389.html, test_scroll_event_ordering.html | Assertion count 1 is greater than expected range (Can't allocate graphics resources, aborting subprocess: 'Error') → Intermittent test_scroll_selection_into_view.html, test_bug231389.html, test_scroll_event_ordering.html, test_bug287446.html | Assertion count 1 is greater than expected range (Can't allocate graphics resources, aborting subprocess: 'Error')
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.