Closed Bug 846666 Opened 7 years ago Closed 7 years ago

Can't use CSSStyleSheet objects as WeakMap keys

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 846972

People

(Reporter: harth, Unassigned)

References

Details

Get error: "cannot use the given object as a weak map key".
This is a DOM issue; they need to be wrapper cached, presumably.

Andrew, is there anything else that needs to be done other than adding wrappercache to them to make this work?
Assignee: general → nobody
Component: JavaScript Engine → DOM
Flags: needinfo?(continuation)
Fundamentally, something has to have a preservable wrapper to be supported.  But the only things we support right now for old DOM bindings are nodes.  That could probably be loosened a bit.  Maybe it is the case that all wrapper cached old DOM bindings things are preservable now?
Flags: needinfo?(continuation)
I think wrappercached things in general are preservable.

But if all wrappercached WebIDL stuff is supported, we should just switch CSSStyleSheet to WebIDL.
(In reply to Boris Zbarsky (:bz) from comment #3)
> I think wrappercached things in general are preservable.
There used to be some CSS stuff that didn't work, perhaps since converted to new bindings.
Depends on: 846972
Fixed by bug 846972.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 846972
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.