Entire FF window intermittently disappears for 5-10 secs upon opening article.

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: John Kitz, Unassigned)

Tracking

19 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

1. Started FF.
2. Clicked on a website (in this case http://money.cnn.com) from the new tabs page.
3. Clicked on an hyperlink (http://money.cnn.com/2013/02/26/technology/mobile/intel-mobile/index.html?iid=HP_Highlight) for a particularly article on that page.



Actual results:

1. During the loading of that page the entire FF window disappeared.
2. To reappear after 5 - 10 secs, after which the loading of the selected page completed successfully.

Note that this happens intermittently, i.e. the second time I repeated step 3 in "What did you do?" the problem did not occur. Nor does the problem seem to be related to the article being loaded as I have noticed it happen while loading other articles as well. In addition please note that the problem does not seem to be related to version 19, since I have experienced it with release 18 as well, but didn't report it then.

The problem may be attributable to the site or other sites that it includes content from though, since to date I have not experienced it with other sites.


Expected results:

I expected the page to load without the window disappearing for some time in the process.

Comment 1

5 years ago
Did you try in safe mode (https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode) and with a new profile (https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles)?
Flags: needinfo?(John.Kitz)
(Reporter)

Comment 2

5 years ago
(In reply to Loic from comment #1)
> Did you try in safe mode
> (https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-
> mode) and with a new profile
> (https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-
> firefox-profiles)?

No, I did not. As stated, it's an intermittent pbm. that I have not been able to reproduce.
Flags: needinfo?(John.Kitz)
(Reporter)

Comment 3

5 years ago
Pbm. occured again with http://money.cnn.com/2013/02/27/investing/italy-debt/index.html?iid=HP_Highlight in step 3 of "What did you do?".

Comment 4

5 years ago
"What did you do?" where can I find that on that page?
Flags: needinfo?(John.Kitz)
(Reporter)

Comment 5

5 years ago
In reply to Loic from comment #4)
> "What did you do?" where can I find that on that page?

Under "Steps to reproduce:", but when an end-user fills out a trouble ticket form the header of the box that results in the "Steps to reproduce:" - section of the trouble ticket is "What did you do?". Likewise the header of the "Actual results:" section of the resulting trouble ticket is different from that on the form. But, I digress.
Flags: needinfo?(John.Kitz)

Comment 7

5 years ago
I'm not able to reproduce the issue, sorry.
(Reporter)

Comment 8

5 years ago
(In reply to Loic from comment #7)
> I'm not able to reproduce the issue, sorry.

No problem. Neither am I, but it does occur intermittently. Nor is it an issue that I can include something tangible, like a screenshot, of to the trouble ticket. I'll update this ticket as and when needed. Maybe some indication as to the cause of this becomes apparent as a result.
(Reporter)

Comment 9

5 years ago
Another occurrence on the homepage of money.cnn.com. My virus scanner is doing a full system scan at the same time, maybe that's the cause. Will check if this is the case as well if the pb. reoccurs.

Comment 10

5 years ago
Yes, the cause might be a third-party application trying to scan some files being read/written by Firefox during the page loading. Anyway, be sure your GPU drivers are up-to-date, many graphics issue are due to outdated drivers.
(Reporter)

Comment 11

5 years ago
Can confirm now that the virus scanning software doing a full scan is not the cause of the pbm. since it occurred again downloading a .pdf (forgot to copy the URL) without a full scan active.
(Reporter)

Comment 12

5 years ago
Another occurrence. Clicked hyperlink http://money.cnn.com/2013/03/06/news/economy/economy-uk-pay/index.html?iid=Lead from the main page http://money.cnn.com/. Had the chance to take a good look at the browser's behaviour while it occurred and as a result I think it is highly likely that the pbm. is somehow related to the loading of content external to the domain in which the URL of the article that is being rendered resides, i.e. mainly advertisements.

I believe this to be the case because prior to the window disappearing most of what appears to be content that resides within the domain with the exception of empty placeholders where ads, charts, etc. should go appears to have been rendered. At about the same time the window reappears so does the remaining content.

Comment 13

5 years ago
Could you try with HWA disabled in Firefox, please.
https://crash-stats.mozilla.com/report/index/bp-033e1e69-04b1-4b25-93c6-f46f32130307 (restart FF to apply)

Comment 14

5 years ago
Sorry for the wrong link, bad pasting.
Correct link: https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration
(Reporter)

Comment 15

5 years ago
Disabled it. Will update ticket as and when needed. Thanks.
(Reporter)

Comment 16

5 years ago
(In reply to Loic from comment #13)
> Could you try with HWA disabled in Firefox, please.
> https://crash-stats.mozilla.com/report/index/bp-033e1e69-04b1-4b25-93c6-
> f46f32130307 (restart FF to apply)

Although you pasted a wrong link, it reminded me to have a look at about:crashes and I have had four crashes to date this year. One Adobe flash related and four what appears to be Java Script related. I guess they get processed and addressed to in a separate pbm. resolution process, but if it would be useful for you I can include the crash id's. Just let me know.
(Reporter)

Comment 17

5 years ago
Another occurrence with HWA disabled. After clicking hyperlink http://money.cnn.com/2013/03/07/news/economy/hong-kong-property/index.html?iid=Lead from the main page http://money.cnn.com/.
(Reporter)

Comment 18

5 years ago
Upgraded to FF Version 19.0.2, HWA still disabled. Another occurrence while loading http://money.cnn.com/2013/03/08/autos/rolls-royce-wraith/index.html?iid=HP_Highlight.

Comment 19

5 years ago
So HWA is not involved, you can activate it again.
(Reporter)

Comment 20

5 years ago
I concur, HWA enabled again.
(Reporter)

Comment 21

5 years ago
Another occurrence while loading "http://money.cnn.com/2013/03/12/technology/security/samsung-knox/index.html?iid=Lead" of off the home page of "money.cnn.com".

I am pretty sure now that, as mentioned before in this ticket, it has something to do with the loading or rendering of ads, such as the ones above and to the right of the main article. Although the majority of occurrences have been with articles on "money.cnn.com" thus far I doubt the problem is limited to this particular site as I have seen it while loading content from other sites, such as the one mentioned in comment 6 above, as well.

Comment 22

5 years ago
Are ads in Flash on this website?
(Reporter)

Comment 23

5 years ago
(In reply to Loic from comment #22)
> Are ads in Flash on this website?

Assuming you're referring to "money.cnn.com" and looking at the HTML of some of the articles I experienced the described pbm. with, I'd have to answer that affirmative.
(Reporter)

Comment 24

5 years ago
(In reply to John Kitz from comment #23)
> (In reply to Loic from comment #22)
> > Are ads in Flash on this website?
> 
> Assuming you're referring to "money.cnn.com" and looking at the HTML of some
> of the articles I experienced the described pbm. with, I'd have to answer
> that affirmative.

Not all are though, from the articles mentioned herein I had a look at the top banner typically is not, while the right hand side box typically is Flash based.
(Reporter)

Comment 25

5 years ago
Another occurrence while loading "http://money.cnn.com/2013/03/12/news/hp-autonomy-uk-investigation/index.html?iid=HP_LN" of off the home page of "money.cnn.com". 

After completion of the loading and rendering of the page I checked the ads in the top banner and in the box to the right of the main article and both appeared to be flash based.
(Reporter)

Comment 26

5 years ago
(In reply to John Kitz from comment #24)
> (In reply to John Kitz from comment #23)
> > (In reply to Loic from comment #22)
> > > Are ads in Flash on this website?
> > 
> > Assuming you're referring to "money.cnn.com" and looking at the HTML of some
> > of the articles I experienced the described pbm. with, I'd have to answer
> > that affirmative.
> 
> Not all are though, from the articles mentioned herein I had a look at the
> top banner typically is not, while the right hand side box typically is
> Flash based.

Loaded all the pages mentioned in this ticket before comment 25 several times in a separate FF window and checked the ads in the top banner and box to the right of the article. My last comment directly above appears to be incorrect. In all cases the top banner contained either a static, a dynamic flash based or no ad and the ad in the box to the right a dynamic flash based ad.

While doing this the described pbm. did not reoccur.
(Reporter)

Comment 27

5 years ago
In an attempt to recreate the pbm. I rebooted my PC, started FF, then selected "money.cnn.com" from the about:newtab page, followed by clicking a random article "http://buzz.money.cnn.com/2013/03/12/apple-stock-iphone-sales/?iid=HP_LN" from the "Latest News" section, et voila, the pbm. reoccured.

Suggesting the pbm. is somehow related to a state that only occurs immediately after booting the PC and starting FF.
(Reporter)

Comment 28

5 years ago
Another occurrence while loading "http://money.cnn.com/2013/03/13/news/economy/europe-economy-industry/index.html?iid=HP_LN" from the "Latest News" section on the home page of "money.cnn.com". Both main ads where flash based.
(Reporter)

Comment 29

5 years ago
Another occurrence while loading "http://money.cnn.com/2013/03/14/technology/mobile/samsung-galaxy-s-iv/index.html?iid=Lead", the main article at the time on the home page of "money.cnn.com". Both main ads where flash based.

Time during which the FF window disappeared seemed to be in excess of 10 secs. and longer than on previous occasions.
(Reporter)

Comment 30

5 years ago
Accepted, downloaded and installed Adobe Flash upgrade to 11.6.602.180.
(Reporter)

Comment 31

5 years ago
Another occurrence while loading "http://money.cnn.com/2013/03/13/news/economy/europe-economy-industry/index.html?iid=HP_Highlight" from the "The New Europe" section on the home page of "money.cnn.com". Both main ads where flash based.

FF window disappeared for approx. 15 secs.

Comment 32

5 years ago
Please, stop spamming the bug by posting every page where you meet the issue, I think your issue is enough detailed now, thanks.
(Reporter)

Comment 33

5 years ago
(In reply to Loic from comment #32)
> Please, stop spamming the bug by posting every page where you meet the
> issue, I think your issue is enough detailed now, thanks.

Excuse me, I was merely trying to provide as much detail as possible to allow you to confirm, diagnose and resolve the issue. I'll refrain from further updates for the time being.
(Reporter)

Comment 34

5 years ago
Upgraded to 20 branch. Reported issue continues to occur, most recently while downloading and rendering "https://www.velux.nl/nl-NL/all_lists/Documents/Brochures/Algemene_VELUX_Brochure_2013_V1.pdf?brochurepoints=0".
Version: 19 Branch → 20 Branch
(Reporter)

Comment 35

5 years ago
Since some time the top section of the home page of money.cnn.com doesn't contain ads anymore. Since around the same time I haven't experienced the described pbm. with that site. The pbm. does continue to occur though as mentioned in comment 34. Giving further reason to suggest that the pbm. is somehow related to content external to some or all sites.
(Reporter)

Comment 36

5 years ago
Reported issue continues to occur, most recently while downloading and rendering "http://www.i-pos.nl/Pebble4_brochure_EN.pdf", resulting in the following error message "A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete. Script: resource://pdf.js/build/pdf.js:2744" being displayed.
(Reporter)

Comment 37

5 years ago
Upgraded to 21 branch on the 14th of May. In addition found some error messages in the system log indicating crashes of the display driver. The faulty driver appeared to have been installed as part of a Windows Update overwriting the original NVDIA driver. Upgraded to the most recent driver obtained from the NVDIA site.
(Reporter)

Comment 38

5 years ago
I raised this ticket when using FF version 19 almost five months ago. Since I'm using version 22 now, version 23 is due out in little more than a week and I have not experienced the described problem for some time I suggest closing this ticket unless it still serves a purpose to Firefox development staff.
Version: 20 Branch → 19 Branch

Comment 39

5 years ago
Closing as per comment 38.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.