Last Comment Bug 846706 - Username is confusing in the context of creating an IRC account.
: Username is confusing in the context of creating an IRC account.
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 22.0
Assigned To: Florian Quèze [:florian] [:flo] (PTO until August 29th)
:
Mentors:
: 857646 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-01 03:46 PST by Florian Quèze [:florian] [:flo] (PTO until August 29th)
Modified: 2013-04-03 10:27 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (1.77 KB, patch)
2013-03-01 03:46 PST, Florian Quèze [:florian] [:flo] (PTO until August 29th)
clokep: review+
Details | Diff | Splinter Review
Screenshot with the patch applied (33.91 KB, image/png)
2013-03-01 03:47 PST, Florian Quèze [:florian] [:flo] (PTO until August 29th)
no flags Details

Description Florian Quèze [:florian] [:flo] (PTO until August 29th) 2013-03-01 03:46:51 PST
Created attachment 719906 [details] [diff] [review]
Patch

See bug 845818 comment 10 11 and 12.

The proposal here to reduce the confusion is to use "nick" as the empty text of the username textbox in the IRC case, and to display "username (nick)" in the label at the top of that wizard step.

It's similar to what we did for Google Talk with "email address".
Comment 1 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2013-03-01 03:47:42 PST
Created attachment 719907 [details]
Screenshot with the patch applied
Comment 2 Patrick Cloke [:clokep] 2013-03-01 03:49:15 PST
Comment on attachment 719906 [details] [diff] [review]
Patch

I think this change is good. I was unsure whether to use "nick" or "nickname", but they're use fairly interchangeably.
Comment 3 :aceman 2013-03-01 04:24:06 PST
Great, thanks!
Comment 4 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2013-03-06 02:38:04 PST
https://hg.mozilla.org/comm-central/rev/f42101c185a6
http://hg.instantbird.org/instantbird/rev/8d2f3bca65e7
Comment 5 Patrick Cloke [:clokep] 2013-04-03 10:27:10 PDT
*** Bug 857646 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.